KEYBOARD
Computer Science With Application Software
THIRD EDITION

TEACHING GUIDE
About the Series

The computer in present-day society is an indispensable tool facilitating communication and work. From huge machines weighing several tons, the computer has evolved into light, sleek yet powerful tools that dominate today’s knowledge society. Many previously complex and time-consuming tasks have been reduced to the mere touch of a few buttons on the keyboard. Basic computing skills like word processing are an essential requirement in today’s job market. The Internet has revolutionised the way people communicate and interact. Geographical distances are no longer a constraint for effective business transactions, information dissemination, and interpersonal interactions, as distances have been overcome through extensive, intricately-designed communication networks.

Today computer science is an academic subject in its own right, governed by scientific and mathematical principles. It is an integral part of what is commonly called STEM (Science, Technology, Engineering, and Mathematics). Due to its increasing importance, computer classes have become an essential part of the education curriculum around the world.

However, the trend has been to favour Information and Communication Technology (ICT) rather than the science behind computers. ICT in schools usually focuses only on teaching how to use office productivity software, such as, word processors, presentation software, and spreadsheets. We, as teachers, should be careful that we teach not only ICT, but also computing, especially in the lower classes. This is an important distinction because ICT primarily involves simply understanding and memorising commands. As a consequence many students may get the impression that there is not much of creativity involved in using computers. This may possibly result in students losing interest in what they mistakenly believe to be computing. Students are not introduced to how computers work and are not provided with the opportunity to be creative through computing activities that challenge them to use their logical and analytical abilities along with being creative.

Computer science education should be such that children later on, if they choose to do so, would be capable of making a meaningful contribution either to further advance our digital society or use digital media optimally in their chosen field of study or work. Computer education in schools should equip every child with the basic understanding of how computers work and with the possibilities of information technology in a knowledge-based society and economy. This has been the rationale for developing this third edition of the Keyboard series—Keyboard: Computer Science with Application Software.
**Keyboard: Computer Science with Application Software**

*Keyboard: Computer Science with Application Software*, third edition, a series of eight books for Classes 1 to 8, is a comprehensively revised edition of *Keyboard: Computer Science with Application Software*, second edition, and carries forward the very same interesting and interactive approach that is a hallmark of the existing edition. The series aims to make the study of computer science engaging and interactive for students through a combination of interesting features.

The contents are based on the most recent feedback from teachers and incorporate the latest trends in computer education. We have taken particular care to update facts and figures, and to include the latest advancements in the field of information and communication technology. Thus, trendsetting topics such as social networking and cloud computing have been explained along with devices such as smartphones and tablets. Also, in keeping with the times, there is greater focus on animation and web-designing concepts.

The series introduces the subject in a language that is simple and direct. Technical jargon is used only where necessary and all such terms are defined at the end of each chapter. Comic strips, icons, cartoon characters, and illustrations make the learning process an enjoyable experience.

*Keyboard: Computer Science with Application Software* is an advanced course in computer science meant for those schools that wish to teach creative application software, such as Flash, HTML, Photoshop, and Dreamweaver, along with the basic concepts of computers, computer programming, and the Internet. In keeping with the times it also introduces students to sound (Audacity) and video-editing (Lightworks) software.

**COURSE FEATURES AND HIGHLIGHTS**

Each chapter in *Keyboard: Computer Science with Application Software* starts with an engaging introduction in comic strip format presenting a conversation between two characters, Goggle and Toggle. Goggle represents an average primary and middle school student, while Toggle is an animated laptop and an expert in computer science. Toggle helps Goggle understand all that is taught about computers and computer software in the series. The series has a hands-on approach to learning with text supported by relevant screenshots, and plenty of practical exercises. The MS Office screenshots are based on MS Office 2013, with the compact and user-friendly Windows 7 as the operating system.

**Practice Time, Exercises, In the Lab, and Group Project**

**Practice Time** is a feature that has been a part of all the computer science series we have written, and it has been found by teachers to be a very useful feature. We continue with it in *Keyboard: Computer Science with Application Software* also. The feature provides practical exercises after every major topic, in which the student applies the concept(s) learnt in the previous section to solve a practical problem. The detailed solution is given after the question, so that students are able to understand the practical application of a particular concept on their own. This frees the teacher from the process of trying to individually assess whether all the students have properly grasped the concept.

The **Exercises** and **In the Lab** questions in the series deserve particular mention, as they have been developed according to Bloom’s Taxonomy. The exercises in each chapter have sufficient theoretical and practical questions for concept application.

**Application-Based Questions** is a special analytical section within Exercises, aimed at encouraging students to evaluate a picture or a situation, and answer questions based on them.

The **In the Lab** questions are similar to those under **Practice Time** except that the solutions are not given. The questions too are more complex than those found under **Practice Time**. In both, however, the questions describe a variety of situations across subjects. Thus, both attempt to integrate the use of computers with problem-solving in other subjects.
Group Projects encourage the students to work in collaboration with their peers and implement what they learnt in the lessons.

Worksheets and Assessment Papers

Worksheets have been introduced in Classes I to V, while for Classes VI to VIII Assessment and Comprehensive Assessment papers have been included.

Teaching Resources

The teacher’s resources for the Keyboard: Computer Science with Application Software, series have two components: (a) Teaching Guides and (b) Teacher’s Digital Resources.

Teaching Guides

The Teaching Guides accompanying each of the coursebooks is carefully structured to provide useful support to teachers.

Each Teaching guide contains the following:

- A Lesson Plan that details the periods recommended for a particular chapter, the topics therein, the expected learning outcomes at the end of each topic, and the digital support available for each chapter. This is intended to assist teachers in respect of overall planning. Teachers may go through the lesson plan before stepping into the class or may use the recommendations for creating their own.
- A set of chapter-wise Worksheets follows the lesson plans, and has questions in the form of Crossword Puzzles, Word Searches, Jumbled Words, etc. designed to reinforce conceptual understanding.
- In addition to the Worksheets, a set of chapter-wise test papers has also been provided, which may be used by teachers to create their own assessment papers, or may be used as they are for classroom tests.
- The complete Answer Key to the Coursebook Exercises has been given in the teaching guide, including that for the In the Lab questions, Group Project, Worksheets/Assessment papers, Revision Questions, and the Cyber Olympiad Questions.

Digital Resources

The teacher’s digital support for the series is accompanied by a Test Generator.

This comprehensive and easy-to-use Test Generator is an effective assessment tool designed to benefit teachers by enabling them to create a variety of test papers.

It has two sections: (a) Coursebook questions (b) Questions beyond the coursebook.

Both include an extensive pool of questions, such as multiple choice, true or false, fill in the blanks, short answer, and long answer questions, as well as lab exercises wherever relevant. Answers have been provided to enable efficient and effective evaluation. The Test Generator allows the teacher to create test papers for one or more chapters, with a mix of questions from both the sections. The Student’s Books, and the accompanying Teaching Guides and teacher’s digital support, together form a complete package enabling one to teach the subject effectively.
Continuous and Comprehensive Evaluation

Learning takes place in a variety of ways — through experience, making and doing things, experimentation, reading, discussion, asking, listening, thinking and reflecting, and expressing oneself in speech, movement or writing. All these modes of learning are possible both individually and in groups. It would thus be advantageous for children to be given the opportunity to involve themselves in as many of these activities as possible.

CONTINUOUS AND COMPREHENSIVE EVALUATION (CCE)

The primary objectives of this system are (1) to maintain continuity in evaluation and (2) to reliably assess broad-based learning and behavioural outcomes.

In this system the term ‘continuous’ is meant to emphasize that evaluation of a student’s progress is a continuous process rather than an event. It is spread over the entire span of an academic session, and means regularity of assessment and unit-testing. It also includes a diagnosis of learning gaps, the use of corrective measures, retesting, as well as self-evaluation.

The term ‘comprehensive’ suggests that the system should cover both scholastic and co-scholastic aspects of a student’s growth and development.

This system expects assessment to be both formative and summative. Formative assessment is a tool used by the teacher to continuously monitor student progress in a supportive environment. It involves regular descriptive feedback, a chance for the student to reflect on the performance, take advice and improve upon it. If used effectively it can improve student performance tremendously.

Summative assessment is carried out at the end of a course of learning. It measures or ‘sums-up’ how much a student has learned from the course. It is usually a graded test, i.e., it is marked according to a scale or set of grades. It has been found that assessment that is predominantly of a summative nature will not by itself be able to yield a valid measure of the growth and development of the child. It, at best, certifies the level of achievement only at a given point of time.

The paper-pencil tests are basically a one-time mode of assessment and to exclusively rely on it to decide about the development of a child is both unfair and unscientific. Over-emphasis on examination marks makes children assume that assessment is different from learning. Besides encouraging unhealthy competition, the reliance on a summative assessment system also results in great stress and anxiety among learners.

The Keyboard: Computer Science with Application Software, series, comprising of Student’s Books, Teaching Guides, and Digital Resources, has a number of features that aid both continuous and comprehensive evaluation.

CONTINUOUS EVALUATION

Coursebooks

Beginning of Instruction (Formative Assessment)

- The introductory dialogue at the beginning of each chapter between Goggle and Toggle is a starter to the chapter topic and can be employed to test the prior knowledge of students by using the dialogue to ask for possible solutions or an answer to Goggle’s question. For example, in the following dialogue you can also ask them what is the alternative to clicking the Run button.
During Instruction (Formative Assessment)

- The conceptual grasp of students can be assessed during instruction through Practice Time, which has been placed after every major topic in the Student’s Book, by observing how fast they carry out the task as given. A couple of questions may also be added to test their understanding of the concept. For example, in the question below students may be asked if they can use the `tl` command in the solution to this question instead of the `tr` command.

**PRACTICE TIME**

Tina wants to draw a rectangle of breadth 40 steps and length 60 steps in KTurtle using the `turnright` (tr) command. Can you help her out?

**SOLUTION**

1. Tina should type the code given alongside in the KTurtle Editor pane.
2. After typing the code, she should click the Run button.
3. The output will appear as given here.

Note: Try doing the same using the `tl` command also.
End-of-Chapter (Summative Assessment)

- At the end of the chapter the student can be tested on acquired knowledge through the objective and descriptive questions of the Exercises, the Application-Based Questions, and on the practical application of concepts through In the Lab questions, and Group Project.

**End-of-Unit and Term** (Formative as well as Summative Assessment)

- Assessment at the end of a unit, or a set of three or four chapters, is facilitated through Worksheets in classes I to V.

**TEACHING GUIDES**

The Teaching guides provide the following support for formative and summative assessment:

- **Worksheets, one for each chapter**, have questions in the form of Crossword Puzzles, Word Searches, Jumbled Words, etc. designed to reinforce conceptual understanding.

- **Test papers, one for each chapter**, which may be used by teachers by photocopying them in a larger format for classroom tests.

**DIGITAL RESOURCES**

The downloadable digital resources are for the series provided accompanied with Test Generator.

The Digital resource for Keyboard: Computer Science with Application Software, includes:

- **Animations** for the theoretical chapters such as that on operating systems, history of computers, input and output devices, etc. that offer an interesting audio-visual element to technically complex or difficult concepts. There are one or more modules for each such chapter which may be paused at relevant points and feedback taken on what the children have seen, heard, and understood.

- **Demo Videos** that are linked to one of the Practice Times in software chapters (those chapters that describe the features and commands available in a software), and present a step-by-step audio-visual guide to solving the problem described in that particular Practice Time question. One or more objective type question(s) has (have) been introduced at (a) strategic point(s) under the feature Rapid Round during the demo to encourage children to participate in the solution to the problem. These questions could be also be used as a formative assessment tool.

- **Interactive Exercises** The objective type questions have been made interactive in the form of pop-up screens in which the right answer can be typed in or clicked. Clicking Submit will give you feedback, hence these can be used as a formative assessment tool for quick evaluation.

- **Printable documents** for every chapter in the form of soft copies of the worksheets and test papers given in
the Teaching Guides. The teacher is free to use either version of the worksheets and test papers as formative assessment tools.

- Additional projects, Cyber Olympiad questions for practice, revision questions, and sample assessment papers (in classes 6 to 8).

The Test Generator accompanying digital resources is an effective assessment tool designed to benefit teachers by enabling them to create a variety of test papers.

It has two sections: (a) Coursebook questions (b) Questions beyond the coursebook.

Both have an extensive pool of questions including multiple choice, true or false, fill in the blanks, very short answer, and short answer questions, as well as lab exercises wherever relevant. The Test Generator can be used to create test papers for one or more chapters, with a mix of questions from both the sections. The wide variety of objective and descriptive type of questions makes the tool flexible enough for teachers to employ it either for formative or for summative assessment. Answers have also been provided for these questions to aid efficient and effective evaluation by teachers.

## COMPREHENSIVE EVALUATION

Comprehensive evaluation involves, as explained above, both the scholastic and co-scholastic aspects of a student’s growth and development. It aims to assess the student not only in the area of pure knowledge but also in the areas of their analytical and creative ability, as well as in their general attitudes and aptitudes.

The key features in *Keyboard: Computer Science with Application Software*, have been designed to provide both scholastic and co-scholastic development.

### Scholastic

- The features such as Did You Know?, Fast Forward, Top Tip, Tricky Terms, and Memory Bytes, enhance and reinforce conceptual knowledge.

---

**Did you Know?**

One point equals 1/72\(^\text{th}\) of an inch.

**Fast Forward**

Font dialog box  Ctrl + D

**Top Tip**

Starter images are backgrounds with outlines of images, or 3D photographs, that you can use in Tux Paint.

**Font dialog box**

**Top Tip**

Starter images are backgrounds with outlines of images, or 3D photographs, that you can use in Tux Paint.

**Tricky Terms**

- **Template**: A pre-defined design layout that saves time while designing.
- **Objects**: The elements you place in your publication.
- **Guides**: They are horizontal and vertical lines.
- **Scratch Area**: The grey area around the publication page where objects can be placed before insertion in the publication page.
- **Drop Cap**: A text-formatting style that enlarges the first letter of the selected text.

**Memory Bytes**

- The AutoFill feature lets you quickly enter a predefined series of data.
- There are two ways to create custom lists: by importing the list or by entering the list in the [Custom Lists] dialog box.
- Filtering selectively displays rows/columns that meet the criteria specified by the user.
- Conditional formatting allows you to set a cell’s format according to the conditions you specify.
Co-Scholastic

- The features such as Computer Manners, Projects, and the design of the practical exercises focus both on scholastic and co-scholastic areas by creating awareness on ethical and correct use of computers, as well as the use of computers as a tool for applying their creativity and enhancing their problem-solving skills.

![Computer Manners](image1)

**APPENDIX**

**KTURTLE**

Type the following commands and execute it in KTurtle. Draw the figure you see on the canvas in the space provided.

Note: Read and enter the commands column-wise.

```
reset
canvascolor 255,0,0
pencolor 0, 255,0
penwidth 5
go 150,250
fw 120
tr 90
fw 100
tr 90
fw 120
tr 90
fw 100
tl 40
tr 90
fw 50
tr 90
fw 20
tr 90
fw 50
tr 90
fw 60
tr 90
fw 120
tr 45
fw 70
tr 90
fw 70
tl 135
go 60,250
```

Find out how many rectangles there are in the figure. ................................

**TUX PAINT**

In Tux Paint you can draw and color lines, curves, and geometrical figures. You can also add magical effects to your drawing, and you can write text in the drawing area. Do the following:

a. Fill a starter image as the one given here with colors of your choice.

**APPLICATION-BASED QUESTIONS**

a. Observe the given figure on the right and answer the following questions:
   i. Which tool is selected in the figure?
   ii. Name the modifier that has been used to draw line A.
   iii. Name the modifier that has been used to draw line B.
   iv. Which modifier will you use to draw lines without any modifications?
   v. Depict the figure with its corresponding labels.
   vi. What tool will she use for the following purposes?
      i. Paint freely on the stage
      ii. Draw a curve

**PROJECTS**

Type the following commands and execute it in KTurtle. Draw the figure you see on the canvas in the space provided.

Note: Read and enter the commands column-wise.

```
reset
canvascolor 255,0,0
pencolor 0, 255,0
penwidth 5
go 150,250
fw 120
tr 90
fw 100
tl 40
tl 90
fw 70
tr 90
fw 70
tl 135
go 60,250
```

Find out how many rectangles there are in the figure. ................................

**IN THE LAB**

1. Amir has designed a New Year greeting card in Paint as shown below. Make a New Year greeting card of your own, using the various tools in Paint, for your teacher.
SCHEME OF WORK AND LESSON PLANS

- A Scheme of work and Lesson Plan has been devised for each chapter which details the number of periods recommended for that chapter, the topics covered in that chapter, the recommended topic-wise allocation of periods, the learning outcomes, and the downloadable digital resources available for that chapter.

- The total number of periods in a year for computer science has been taken at 36 assuming one period in a week for the subject.

- Teachers may go through the lesson plan before stepping into the class. However, this is a proposed lesson plan, and teachers are free to modify it as per their teaching styles, sequence, and requirements in respect of the chapters.
# SCHEME OF WORK*

<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise Allocation of Periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
</table>
| 1. Introduction to Access 2013 | What is a Database? | 0.5 | The student should be able to:  
• define the term Database.  
• explain the requirement for a database.  
• discuss the four types of database.  
• define the terms – Relational database, Records and Fields. |
|   | Database Management System | 0.5 | • explain the meaning of DBMS.  
• discuss the functions of a DBMS. |
|   | Introducing Access 2013 | 0.5 | • explain the meaning of a primary key.  
• identify the elements of Access 2013.  
• demonstrate how to start Access 2013. |
|   | Creating a Database | 1 | • demonstrate how to create a database from template and from scratch, and also to save the database.  
• spell out the rules for naming a field correctly. |
|   | Setting Data Types | 1 | • describe the data types available in Access 2013.  
• discuss and demonstrate how to assign a data type. |
|   | Opening an Existing Database | 0.5 | • demonstrate how to open an already existing database. |
|   | Modifying Table Design | 1 | • add/delete a field, move a field, hide/unhide fields, freeze/unfreeze fields and change a field’s format. |
|   | Totaling, Sorting, Filtering and Searching Data | 2 | • demonstrate how to sum, sort, filter, and search data in Datasheet view.  
• use advanced filtering tools in Datasheet view. |
| 2. Access 2013: Design View, Queries, Forms and Reports | Create Table in Design View | 2 | The student should be able to:  
• identify the two sections in Table Design view.  
• practically create a table in Table Design view.  
• switch between Design view and Datasheet view.  
• explain the need for a primary key.  
• demonstrate how to set/remove a primary key.  
• describe the use of a Lookup field.  
• discuss the properties available in the Field Properties pane. |
|   | Queries | 2 | • define the term – query.  
• demonstrate various ways of creating, saving and running a query. |
|   | Forms | 2 | • explain the uses of forms.  
• demonstrate various ways of creating forms. |
|   | Reports | 2 | • explain the uses of a report.  
• demonstrate various ways of creating a report.  
• list the steps required in printing a report. |

*The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise Allocation of Periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
</table>
| 3. Lists and Images in HTML 5 | Creating Lists | 4 | The student should be able to:  
• recall and apply the properties (Text, Font, Margin, Border, Background, etc.) covered in class 7.  
• describe <LI> tag.  
• explain List properties.  
• differentiate between ordered and unordered lists.  
• discuss uses of <UL> tag.  
• describe List properties of an unordered list.  
• demonstrate how to set an image as List item marker.  
• discuss uses of <OL> tag.  
• describe List properties of an Ordered list. |
| Nesting Lists | 2 | • explain the concept of nested lists.  
• describe <DL>, <DT> and <DD> tags. |
| Inserting Images | 3 | • enumerate various image formats used in HTML.  
• discuss uses of <IMG> tag.  
• explain different attributes of <IMG> tag. |
| 4. Tables, Links, and Frames in HTML 5 | Creating tables | 3 | The student should be able to:  
• discuss basic <TABLE> tags.  
• describe Table properties.  
• set and clear properties of <td> tag.  
• demonstrate how to insert an image in a table cell. |
| Linking | 2 | • explain what hyperlinks are.  
• demonstrate the use of <A> tag.  
• explain how to define color for links.  
• show how to use an image as link. |
| Inserting Audio and Video | 1 | • demonstrate the use of <audio> tag and its attributes.  
• show the use of <video> tag and its attributes.  
• explain the use of <embed> tag and its attributes. |
| Creating Frames | 3 | • explain the concept of frames.  
• demonstrate the use of <iframe> tag.  
• describe the attributes of <iframe> tag. |

*The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.*
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise Allocation of Periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
<tbody>
<tr>
<td>5. Audacity</td>
<td>Starting Audacity</td>
<td>1</td>
<td>The student should be able to: &lt;ul&gt;&lt;li&gt;demonstrate how to start Audacity.&lt;/li&gt;&lt;li&gt;describe the components of audacity window.&lt;/li&gt;&lt;/ul&gt;</td>
</tr>
<tr>
<td></td>
<td>Creating a New Project</td>
<td>1</td>
<td>• demonstrate how to create a new project in Audacity. &lt;br&gt;• explain the available Quality preferences.</td>
</tr>
<tr>
<td></td>
<td>Importing and Playing Audio Files</td>
<td>3</td>
<td>• demonstrate importing and playing audio files. &lt;br&gt;• perform a recording. &lt;br&gt;• import multiple tracks in a Project. &lt;br&gt;• mix narration with Background music. &lt;br&gt;• demonstrate how to select a range in audio files. &lt;br&gt;• show how to delete a portion of audio file.</td>
</tr>
<tr>
<td></td>
<td>Copying or Moving Portions of Audio</td>
<td>3</td>
<td>• demonstrate how to copy or move a portion of audio file. &lt;br&gt;• add various sound effects to audio. &lt;br&gt;• save a project. &lt;br&gt;• export an audio file.</td>
</tr>
<tr>
<td>6. Lightworks</td>
<td>Starting Lightworks</td>
<td>0.5</td>
<td>The student should be able to: &lt;ul&gt;&lt;li&gt;explain video editing.&lt;/li&gt;&lt;li&gt;name various available video editing software.&lt;/li&gt;&lt;li&gt;follow the steps to start Lightworks.&lt;/li&gt;&lt;li&gt;start a new project.&lt;/li&gt;&lt;/ul&gt;</td>
</tr>
<tr>
<td></td>
<td>Project View</td>
<td>0.5</td>
<td>• identify the different parts of Project view. &lt;br&gt;• discuss importing media files. &lt;br&gt;• differentiate between bin and rack. &lt;br&gt;• describe the organization of a project in bin and rack. &lt;br&gt;• demonstrate how to play clip in Viewer. &lt;br&gt;• carry out mark and park procedure.</td>
</tr>
<tr>
<td></td>
<td>Basic Editing</td>
<td>3</td>
<td>• discuss the four basic editing functions—Replace, Insert, Delete and Remove. &lt;br&gt;• demonstrate the use of the above functions.</td>
</tr>
<tr>
<td></td>
<td>Trimming on the Timeline</td>
<td>1</td>
<td>• demonstrate how to trim on the timeline.</td>
</tr>
<tr>
<td></td>
<td>Transition Effects</td>
<td>1</td>
<td>• define transition effect. &lt;br&gt;• explain the steps to add effects.</td>
</tr>
<tr>
<td></td>
<td>Working with Audio</td>
<td>0.5</td>
<td>• demonstrate how to add audio.</td>
</tr>
<tr>
<td></td>
<td>Exporting Files</td>
<td>0.5</td>
<td>• describe the steps to export file and exit lightworks.</td>
</tr>
</tbody>
</table>

*The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.*
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise Allocation of Periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
<tbody>
<tr>
<td>7. Introduction to Photoshop CS3</td>
<td>Starting Adobe Photoshop</td>
<td>1</td>
<td>The student should be able to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• start Photoshop.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• describe the components of Photoshop window.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the use of Tools panel.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate how to open an existing file, create a new file, and save a file.</td>
</tr>
<tr>
<td></td>
<td>Selection tools</td>
<td>1</td>
<td>• step-wise change background and foreground colors.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• use Marquee and Lasso tools for selection.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate the use of Magic Wand tool.</td>
</tr>
<tr>
<td></td>
<td>Working with Images</td>
<td>1</td>
<td>• demonstrate how to move, copy, and crop an image.</td>
</tr>
<tr>
<td></td>
<td>Painting Tools</td>
<td>1</td>
<td>• demonstrate the uses of Brush tool.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• apply Gradient tool.</td>
</tr>
<tr>
<td></td>
<td>Drawing Tools</td>
<td>1</td>
<td>• demonstrate the use of drawing tools.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• use Custom Shape tool.</td>
</tr>
<tr>
<td></td>
<td>Transforming Objects</td>
<td>1</td>
<td>• step-wise perform scaling, rotating, skewing, distorting and applying perspective operations to an image.</td>
</tr>
<tr>
<td>8. Tools used in Photoshop CS3</td>
<td>Retouching Tools</td>
<td>2</td>
<td>The student should be able to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate the use of Spot Healing Brush tool and Healing Brush tool.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• use Clone Stamp and Pattern Stamp tools.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• use Eraser tool.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• apply Blur, Smudge, Dodge, and Burn tools.</td>
</tr>
<tr>
<td></td>
<td>Working with Layers</td>
<td>2</td>
<td>• describe Layers palette.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• display Layers palette.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the concept of background layer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate how to create a new layer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate selecting layers.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• change the order of layers.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• rename a layer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• show the steps to delete a layer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the concept of Flattening image.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate and apply Layer effects.</td>
</tr>
<tr>
<td></td>
<td>Working with Text</td>
<td>1</td>
<td>• show how to use Type tool.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate how to move the text.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the meaning of Warping.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• perform text warping.</td>
</tr>
<tr>
<td></td>
<td>Using Filters</td>
<td>1</td>
<td>• explain the use of Filters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate how to apply Filters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• describe the use of Filter gallery.</td>
</tr>
</tbody>
</table>

*The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.*
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise Allocation of Periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
</table>
| 9. Introduction to Dreamweaver CS3 | Adobe Dreamweaver | 0.5 | The student should be able to:  
• describe what Dreamweaver is used for.  
• explain the meaning of a WYSIWYG editor.  
• differentiate between local root folder and remote root folder.  
• demonstrate creating and saving a website of one page in Dreamweaver. |
| | Elements of Dreamweaver | 0.5 | • label the different elements of the Dreamweaver window. |
| | Adding Text and Images | 1 | • demonstrate how to add text and images on a webpage. |
| | Working with Hyperlinks | 2 | • define the term hyperlink.  
• demonstrate how to set text/image as a hyperlink.  
• explain the concept of named anchor links.  
• list the steps to set link colors.  
• explain how to modify links. |
| | Adding Flash Buttons | 1 | • define Flash buttons.  
• demonstrate how to insert a Flash button. |
| 10. Images and Framesets in Dreamweaver CS3 | Insert Date and Table | 0.5 | The student should be able to:  
• discuss the three formats of image files.  
• demonstrate the steps to insert date and table on a web page. |
| | Rollover Images | 1 | • explain what a rollover image is.  
• demonstrate how to create a rollover image. |
| | Image Placeholder | 0.5 | • explain the use of placeholder.  
• demonstrate how to insert a placeholder on a web page. |
| | Image Maps | 2 | • explain image maps and hotspots.  
• discuss why image maps are needed.  
• demonstrate how to create an image map. |
| | Frameset and Frames | 2 | • define the terms - frameset and frame.  
• demonstrate how to create a frameset.  
• list the steps for saving / selecting framesets and frames.  
• explain the properties of a frameset in the Property Inspector.  
• demonstrate how to control frame contents with links. |
| | Linking to Word and Excel Documents | 1 | • demonstrate how to add a link to a Microsoft Word or Excel document. |

*The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.*
LESSON PLANS*

Chapter 1  Introduction to Access 2013

Time for each lesson: 40 minutes

Resources: a laptop, a projector (if available), a table of your daily activities made in Excel, saved on your laptop, MS Excel, computer lab

Note: Have students go through the chapter at home once so that they are able to better comprehend the concepts taught in class.

Introduction (8 minutes)

You may start the lesson off by introducing MS Access to your students as a software that is better equipped to help users organise and retrieve their data easily. Conduct an activity by asking students to create a students’ enrolment list in MS Excel with Student Number, Student Name, Father’s Name, Address, and Contact Number as its headings. Ask them to fill in at least four records. Once they are done, ask them to give two students the same Student number. Once they have done this, you may then explain how MS Access has certain features that prevents users from assigning two students the same Student number, and how this is very helpful especially when maintaining large amounts of data. You may also have a general discussion on the functions of a Database Management System (DBMS).

Explanation (25 minutes)

You may take your students to the computer lab and introduce them to MS Access and its different elements. Demonstrate the two ways in which they can create a database, and show them how to sort, filter, and search for data. Encourage them to explore and apply the advanced filtering options in MS Access.

It is recommended that students be given ample time to perform all the Practice Time questions as part of their classwork. It will help them retain in memory the things they have learnt in class. You can then assign any of the following tasks for classwork.

- Exercises
- In the Lab
- Application Based Questions
- Group Project

Assessment

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- explain the term, Database.
- explain the requirement for a database.
- discuss the four types of database.
- define the terms- Relational Database, Records, and Fields.
- explain the meaning of DBMS and discuss its functions.
- explain the meaning of a primary key.
- identify the elements of Access 2013.
- demonstrate how to create a database from template and from scratch, and also to save the database.
- spell out the rules for naming a field correctly.

*. The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
• describe the data types available in Access 2013.
• discuss and demonstrate how to assign a data type.
• demonstrate how to open an already existing database.
• add/delete a field, move a field, hide/unhide fields, freeze/unfreeze fields, and change a field’s format.
• demonstrate how to sum, sort, filter, and search data in Datasheet view.
• use advanced filtering tools in Datasheet view.

Conclusion (7 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 2 Access 2013: Design View, Queries, Forms and Reports

Time for each lesson: 40 minutes

Resources: a laptop, a projector (if available), MS Excel, computer lab

Note: Have students go through the chapter at home once so that they are able to better comprehend the concepts taught in class.

Introduction (5 minutes)

You may start the lesson off by asking students to briefly recap the main points of the previous chapter. This will help engage them in a discussion related to the topic. You can also encourage them to share whatever knowledge they may have regarding MS Access.

Explanation (25 minutes)

You may take your students to the computer lab and show them the different ways of creating tables, forms, and reports in MS Access. Explain to them the importance of a primary key and demonstrate how to set a field as a primary key field. Here, you can also ask them to recall the primary key activity conducted in the previous class. Introduce them to the concept of queries and how they help in easy retrieval of data. You may have them perform the practice time questions in the computer lab. (In case there is a shortage of computers, divide the students in groups of three and have them practice different parts of a question.) You can also make them practice all the examples given in the chapter. All of this will help strengthen their practical knowledge of MS Access.

You can then assign any of the following tasks for classwork.

• Exercises
• In the Lab
• Application Based Questions
• Group Project

Assessment

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

• identify the two sections in Table Design view.
• practically create a table in Table Design view.

*. The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
• switch between Design view and Datasheet view.
• explain the need for a primary key.
• demonstrate how to set/remove a primary key.
• describe the use of a Lookup field.
• discuss the properties available in the Field Properties pane.
• define the term–query.
• demonstrate various ways of creating, saving, and running a query.
• explain the uses of forms.
• demonstrate various ways of creating forms.
• explain the uses of a report.
• demonstrate various ways of creating a report.
• list the steps required in printing a report.

Conclusion (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

**Chapter 3  Lists and Images in HTML 5**

**Time for each lesson:** 40 minutes

**Resources:** a laptop, a projector (if available), HTML 5, computer lab

**Note:** Have students go through the chapter at home once so that they are able to better understand the concepts taught in class.

**Introduction** (5 minutes)

You may start the lesson off by asking students to recall what they have studied about HTML 5 in their previous year (Keyboard Book 7). Engage them in a discussion where they share all the main points of HTML 5 that they have previously studied. You can also take them to the computer lab and have one student demonstrate all the previous functions to refresh their memories.

**Explanation** (25 minutes)

This lesson mainly deals with the creation of lists in HTML 5. You may take your students to the computer lab and demonstrate to them the ways in which different lists i.e. ordered lists, unordered lists, nesting lists etc. are created. You must also show them how to insert images in an HTML document.

You may have students perform the Practice Time questions in the computer lab. (In case there is a shortage of computers, then divide them in groups of 3 and have them practice different parts of a question.) You can also assign any of the following tasks for classwork.

- Exercises
- In the Lab
- Application Based Questions
- Group Project

*. The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
Assessment

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

recall and apply the properties (Text, Font, margin, Border, Background, etc. covered in Class 6.)
- describe <LI> tag.
- explain list properties.
- differentiate between ordered and unordered lists.
- discuss uses of <UL> tag.
- describe List properties of an Unordered list.
- demonstrate how to set an image as List item marker.
- discuss uses of <OL> tag.
- describe list properties of an Ordered list.
- explain the concept of nested lists.
- describe <DL>, <DT>, and <DD> tags.
- enumerate various image formats used in HTML.
- discuss uses of <IMG> tag.
- explain different attributes of <IMG> tag.

Conclusion (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 4  Table, Links, and Frames in HTML 5

Time for each lesson: 40 minutes

Resources: a laptop, a projector (if available), HTML 5, Internet access, computer lab

Note: Have students go through the chapter at home once so that they are able to better comprehend the concepts taught in class.

Introduction (5 minutes)

You may start the lesson off by asking students to briefly recap the main points of the previous chapter. This will help engage them in a discussion related to the topic. You can also encourage them to share whatever knowledge they may have regarding MS Access.

Explanation (25 minutes)

This lesson requires that you take your students to the computer lab. Demonstrate to them how to create tables in HTML 5 and how to insert images in them. In order to explain the linking concept, you may conduct a small activity. You may ask your students to search for ‘Oxford University’ on www.google.com.pk. Ask them to note down the colour of the first link on google, and then click on that link. Upon clicking, ask them to note down the colour change. After this activity, you can teach them how to specify a colour for a link, depending on the action performed. For the image, audio, and video insertions, ask students to practice the examples that are given in the chapter. This will help them remember the steps involved in performing those tasks.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
It is also recommended that you have students perform Practice Time questions as part of their classwork. You can also select relevant questions from ‘In the Lab’, ‘Application based questions’, and ‘Group Project’ to help them practice what they have learnt during the lesson. You can then assign any of the following tasks for classwork.

- Exercises
- In the Lab
- Application Based Questions
- Group Project

Assessment

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- discuss basic <TABLE> tags.
- describe Table properties.
- set and clear properties of <td> tag.
- demonstrate how to insert an image in a table cell.
- explain what hyperlinks are.
- demonstrate the use of <A> tag.
- explain how to define colour for links.
- show how to use an image as link.
- demonstrate the use of <audio> tag and its attributes.
- explain the use of <embed> tag and its attributes.
- explain the concept of frames.
- demonstrate the use of <iframe> tag.
- describe the attributes of <iframe> tag.

Conclusion (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 5 Audacity

Time for each lesson: 40 minutes

Resources: a laptop, a projector (if available), Audacity, computer lab

Note: Have students go through the chapter at home once so that they are able to better comprehend the concepts taught in class.

Introduction (5 minutes)

You may start the lesson off by asking students about their favourite songs. Initiate a discussion on how students think songs are recorded, what equipment might be required to record songs, etc. Gradually introduce them to the Audacity as a software that is used for recording and editing sound.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
Explanation (25 minutes)

This lesson requires that you take your students to the computer lab. Show them the interface of Audacity and familiarise them with its many elements. Demonstrate how to create projects and how to import audio to Audacity. You can enlist the help of a student, when showing them how to record audio on Audacity. Make sure they have developed the skills to move and copy audio files, add effects to it, and also, how to export it.

It is recommended that you have students perform Practice Time questions as part of their classwork. (In case there is a shortage of computers, then divide them in groups of three and have them practice different parts of a question.) You can also select relevant questions from ‘In the Lab’, ‘Application based questions’, and ‘Group Project’ to help them practice what they have learnt during the lesson. You can then assign any of the following tasks for classwork.

- Exercises
- In the Lab
- Application Based Questions
- Group Project

Assessment

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and teamwork. At the end of the lesson, students will be able to:

- demonstrate how to start Audacity.
- describe the components of Audacity window.
- demonstrate how to create a new project in Audacity.
- explain the available Quality preferences.
- demonstrate importing and playing audio files.
- perform a recording.
- import multiple tracks in a project.
- mix narration with Background music.
- demonstrate how to select a range in audio files.
- show how to delete a portion of audio file.
- demonstrate how to copy or move a portion of audio file.
- add various sound effects to audio.
- save a project.
- export an audio file.

Conclusion (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 6 Lightworks

Time for each lesson: 40 minutes

Resources: a laptop, a projector (if available), Lightworks, computer lab

*. The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
Note: Have students go through the chapter at home once so that they are able to better understand the concepts taught in class.

Introduction (5 minutes)
You may start the lesson off by asking students to briefly recap the main points of the previous chapter. From there you can move on to video making. You may ask them if they have any favourite animated movies and whether or not they are aware that Mir Zafar Ali, a Pakistani won the Academy Award for the best visual effects in three different movies (The Golden Compass, The Life of Pi, and Frozen). Encourage students to take part in the class discussion by sharing any knowledge that they may have regarding video editing or animations.

Explanation (25 minutes)
This lesson requires that you take your students to the computer lab. Introduce them to the different elements of Lightworks. Explain to them the concept of racks and bins. Demonstrate to them the various editing actions (Replace, Edit, Delete, and Insert), transition effects, inserting audio, and trimming on the timeline.

It is recommended that you have students perform Practice Time questions as part of their classwork. You can also select relevant questions from ‘In the Lab’, ‘Application based questions’, and ‘Group Project’ to help them practice what they have learnt during the lesson. You can then assign any of the following tasks for classwork.

- Exercises
- In the Lab
- Application Based Questions
- Group Project

Assessment
Students’ learning should be assessed on Bloom's taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- explain video editing.
- name various available video editing software.
- follow the steps to start Lightworks.
- start a new project.
- identify the different parts of project view.
- discuss importing media files.
- differentiate between bin and rack.
- describe the organisation of a project in bin and rack.
- demonstrate how to play clip in Viewer.
- carry out mark and park procedure.
- discuss the four basic editing functions: Replace, Insert, Delete, and Remove.
- demonstrate the use of the above functions.
- demonstrate how to trim on the timeline.
- define transition effect.
- explain the steps to add effects.
- demonstrate how to add audio.
- describe the steps to export file and exit Lightworks.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
**Conclusion** (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

---

**Chapter 7  Introducing to Photoshop CS3**

**Time for each lesson:** 40 minutes

**Resources:** a laptop, a projector (if available), Photoshop CS3, computer lab

**Note:** Have students go through the chapter at home once so that they are able to better comprehend the concepts taught in class.

**Introduction** (5 minutes)

You may start the lesson off by asking students if they have ever edited pictures on mobile phones (It could be by adding filters or by using different apps). Lead them into a discussion involving ‘Photoshop’ and encourage all students to participate in it.

**Explanation** (25 minutes)

This lesson requires that you take your students to the computer lab. Introduce them to Adobe Photoshop and its many tools. Demonstrate to them how to use the Marquee tool, the Lasso tool and the Magic Wand tool. Similarly, they should be aware of all the painting tools including, Brush tool, Gradient tool, and when to use them. The concept of transforming objects should also be clear to them, along with image editing actions. It will benefit your students if you allow them time to practice all the examples in the chapter.

It is also recommended that you have them perform Practice Time questions as part of their classwork. You can also select relevant questions from ‘In the Lab’, ‘Application based questions’, and ‘Group Project’ to help them practice what they have learnt during the lesson. You can then assign any of the following tasks for classwork.

- Exercises
- In the Lab
- Application Based Questions
- Group Project

**Assessment**

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- start Photoshop.
- describe the components of Photoshop window.
- explain the use of Tools panel.
- demonstrate how to open an existing file, create a new file, and save a file.
- step-wise change background and foreground colours.
- use Marquee and Lasso tools for selection.
- demonstrate the use of Magic Wand tool.
- demonstrate how to move, copy, and crop an image.

*The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.*
• demonstrate the uses of Brush tool.
• apply Gradient tool.
• demonstrate the use of drawing tools.
• use Custom Shape tool.
• step-wise perform scaling, rotating, skewing, distorting, and applying perspective operations to an image.

Conclusion (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 8  Tools used in Photoshop CS3

Time for each lesson: 40 minutes

Resources: a laptop, a projector (if available), Photoshop CS3, computer lab

Note: Have students go through the chapter at home once so that they are able to better understand the concepts taught in class.

Introduction (5 minutes)

You may start the lesson off by asking students to briefly recap the main points of the previous chapter. This will help engage them in a discussion related to the topic. You can also encourage them to share whatever knowledge they may have regarding Photoshop CS3.

Explanation (25 minutes)

This lesson requires that you take your students to the computer lab. You must now demonstrate to them the different tools that can be used to further refine an image, for example, burn tool, healing brush tool, etc. Also, how to work with text and filters in Photoshop. As part of a simple class activity, you may provide students with images and ask them to refine it by performing certain Photoshop actions.

It is also recommended that you have students perform Practice Time questions as part of their classwork. (In case there is a shortage of computers, then divide them in groups of 3 and have them practice different parts of a question.) You can also select relevant questions from ‘In the Lab’, ‘Application based questions’, and ‘Group Project’ to help them practice what they have learnt during the lesson. You can then assign any of the following tasks for classwork.

• Exercises
• In the Lab
• Application Based Questions
• Group Project

Assessment

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

• demonstrate the use of Spot Healing Brush tool and Healing Brush tool.
• use Clone Stamp and Pattern Stamp tools.
• use eraser tool.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
• apply Blur, Smudge, Dodge, and Burn tools.
• describe and display Layers palette.
• explain the concept of background layer.
• demonstrate how to create a new layer.
• demonstrate selecting layers.
• change the order of layers.
• rename a layer.
• show the steps to delete a layer.
• explain the concept of Flattening image.
• demonstrate and apply Layer effects.
• show how to use Type tool.
• demonstrate how to move the text.
• explain the meaning of Wrapping.
• perform text wrapping.
• explain the use of filters.
• demonstrate how to apply Filters.
• describe the use of Filter gallery.

**Conclusion** (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

---

**Chapter 9 Introduction to Dreamweaver CS3**

**Time for each lesson:** 40 minutes

**Resources:** a laptop, a projector (if available), Dreamweaver CS3, computer lab

**Note:** Have students go through the chapter at home once so that they are able to better understand the concepts taught in class.

**Introduction** (5 minutes)

You may start the lesson off by asking students to recall what they learnt about HTML 5. Then introduce them to Adobe Dreamweaver as a software that lets users design webpages without writing HTML codes.

**Explanation** (25 minutes)

This lesson requires that you take your students to the computer lab. Show them Adobe Dreamweaver and familiarise them with its many elements. Demonstrate how to insert images and text in a Dreamweaver document. Also, tell them the importance of using hyperlinks in websites. And finally, show them how to add flash buttons. As part of classroom activity, you may ask them to create a simple webpage on their favourite sport game.

It is also recommended that you have students perform Practice Time questions as part of their classwork. (In case there is a shortage of computers, then divide them in groups of three and have them practice different parts of a question.) You can also select relevant questions from ‘In the Lab’, ‘Application based questions’, and

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
‘Group Project’ to help them practice what they have learnt during the lesson. You can then assign any of the following tasks for classwork.

- Exercises
- In the Lab
- Application Based Questions
- Group Project

Assessment

Students’ learning should be assessed on Bloom's taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- describe what Dreamweaver is used for.
- explain the meaning of WYSIWYG editor.
- differentiate between local root folder and remote root folder.
- demonstrate creating and saving a website of one page in Dreamweaver.
- label the different elements of the Dreamweaver window.
- demonstrate how to add text and images on a web page.
- define the term hyperlink.
- demonstrate how to set text/image as a hyperlink.
- explain the concept of named anchor links.
- list the steps to set link colours.
- explain how to modify links.
- define Flash buttons.
- demonstrate how to insert a Flash button.

Conclusion (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 10  Images and Framesets in Dreamweaver CS3

Time for each lesson: 40 minutes

Resources: a laptop, a projector (if available), Dreamweaver CS3, computer lab

Note: Have students go through the chapter at home once so that they are able to better understand the concepts taught in class.

Introduction (5 minutes)

You may start the lesson off by asking students to briefly recap the main points of the previous chapter. This will help engage them in a discussion related to the topic. You can also encourage them to share whatever knowledge they may have regarding Dreamweaver CS3.
**Explanation (25 minutes)**

This lesson requires that you take your students to the computer lab. Demonstrate to them the various functions explained in the chapter. Explain to them the concept of image placeholder, image maps, rollover images, and framesets and frames.

It is recommended that you have students perform Practice Time questions as part of their classwork. (In case there is a shortage of computers, then divide them in groups of three and have them practice different parts of a question.) You can also select relevant questions from ‘In the Lab’, ‘Application based questions’, and ‘Group Project’ to help them practice what they have learnt during the lesson.

**Assessment**

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- discuss the three formats of image files.
- demonstrate the steps to insert date and table on a web page.
- explain what a rollover image is.
- demonstrate how to create a rollover image.
- explain the use of placeholder.
- demonstrate how to insert a placeholder on a web page.
- explain image maps and hotspots.
- discuss why image maps are needed.
- demonstrate how to create an image map.
- define the terms- frameset and frame.
- demonstrate how to create a frameset.
- list the steps for saving/selecting framesets and frames.
- explain the properties of a frameset in the Property Inspector.
- demonstrate how to control frame contents with links.
- demonstrate how to add a link to a Microsoft Word or an Excel document.

**Conclusion (10 minutes)**

Encourage students to give you a recap of the main points they have learnt in the lesson. Have a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

*The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.*
ANSWER KEY TO THE COURSEBOOK

• The complete Answer Key to the Coursebook Exercises has been given here including that for the In the Lab questions, Group Projects, Worksheets/Assessment papers, Revision Questions, and the Cyber Olympiad Questions.

• These are only suggested answers, and variations are possible especially for the open-ended questions, such as the descriptive questions, and those of In the Lab. Teachers may use their discretion while checking the answers provided by the students, and give them marks based on conceptual accuracy and conceptual clarity.

• Teachers should consider the following, while conducting the Group Project activity:
  i. Groups should not be larger than five members; pair work obviously means two people working together; it is always a good idea to make groups of mixed ability.
  ii. Be very clear in your expectations from the group, this means telling them clearly what the assignment is about and what you expect to be submitted.
  iii. Make it clear to the students that part of their marks will depend on how well they work with each other and that you expect all of them to be involved in the project.
  iv. Get the students to select their own group leader; if you see that a group is reluctant to do so, you could assign one; also remind the students that they need to listen to the group leader.
  v. Let the group leader divide the tasks that need to be accomplished.
  vi. As a teacher your role should be to observe what each group is doing, how well they are collaborating with each other and offer advice if needed; the focus should be on the students working without too much teacher input.
Chapter 1 Introduction to Access 2013

OBJECTIVE TYPE QUESTIONS

1. a. ii. Form  b. ii. ID  c. iii. Yes/No
d. ii. Student.Name  e. iv. all of these  f. ii. Long Text

DESCRIPTIVE TYPE QUESTIONS

a. A DBMS is a software that performs the functions of creating, modifying, deleting, and adding data in a database. The advantages of a DBMS are:
   • It reduces data redundancy.
   • It controls data inconsistency.
   • It facilitates sharing of data.
b. Table, Form, Query, Report, Macro, and Module are the six database objects.
c. The two ways of creating a database are:
   • Using a Template.
   • Using a Blank desktop database.
d. Rules for naming a field are:
   • A field name can be 1 to 64 characters long.
   • A field name can include letters, numbers, and some special characters like underscore.
   • A field name cannot have a period, an exclamation mark, brackets or grave accent.
   • A field name cannot start with a blank space.
   • A field name can be in upper, lower, or mixed case.
e. The various data types available in Access 2013 are: Short Text, Long Text, Number, Date/Time, Currency, AutoNumber, Yes/No, OLE Object, Hyperlink, Attachment, and Calculated.
f. Hiding a field makes the field completely invisible (hidden) in the Datasheet view. Freezing one or more fields fixes them to the left of the datasheet and makes it/them visible at all times no matter where you scroll in the datasheet.
g. To show the Total row in an Access table:
   i. Double-click the table for which you want the Total field. It opens in the Datasheet view.
   ii. Click Totals in the Records group of the HOME tab.
   iii. This shows the Totals row at the bottom of the datasheet.
h. The advantages and disadvantages of DBMS are as follows:

<table>
<thead>
<tr>
<th>Advantages</th>
<th>Disadvantages</th>
</tr>
</thead>
<tbody>
<tr>
<td>It puts all information in one location.</td>
<td>Information can be scattered in different folders.</td>
</tr>
<tr>
<td>It provides easy access to information through the use of key fields.</td>
<td>Access can be difficult especially if data is in different locations.</td>
</tr>
<tr>
<td>It reduces any chances of data redundancy.</td>
<td>Duplication of data cannot be traced properly.</td>
</tr>
<tr>
<td>It is less likely to have inconsistent data.</td>
<td>There is no way to check if data is inconsistent.</td>
</tr>
<tr>
<td>It can generate a variety of reports using DBMS.</td>
<td>Collecting data together for reports can be a lengthy process.</td>
</tr>
</tbody>
</table>

i. Below is a comparison of the two ways of creating a database:

<table>
<thead>
<tr>
<th>Using Template</th>
<th>From Scratch</th>
</tr>
</thead>
<tbody>
<tr>
<td>The user can choose from a number of predefined styles.</td>
<td>The user will have to define each field.</td>
</tr>
<tr>
<td>It is quicker to set up a database.</td>
<td>It can be time consuming if there are a large number of fields.</td>
</tr>
<tr>
<td>There are less chances of errors in defining fields.</td>
<td></td>
</tr>
</tbody>
</table>

Opinions of students can vary, they need to show their thought processes behind their answer.

j. This question should be assigned during lab time, when the students have access to the internet to conduct research as well as work on developing their database.

**APPLICATION-BASED QUESTIONS**

a.  
   i. Yes. **ItemNo** can be taken as a primary key.
   
   ii. The data type could be AutoNumber, Short Text, or simply Number, as long as it contains unique value in each row.

b.  
   i. **EmpId**
   
   ii. **EmpId**: AutoNumber; **EmpName**: Short Text; **JobTitle**: Short Text;
       **Date of Joining**: Date/Time; **EmpSalary**: Number; **Grade**: Short Text

c. To search for data quickly, the Search box at the bottom of the Access screen can be used. The steps are:
   
   i. Enter the account number to be searched for in the Search box and press the ENTER key.
   
   ii. Access highlights the first record in the table that matches the given account number.
   
   iii. To find the next matching record, press the ENTER key again. Access finds all records that match the given account number, anywhere in the datasheet.

d.  
   i. Between
   
   ii. Less Than
   
   iii. Greater Than
   
   iv. Does Not Equal
   
   v. Equal

e.  
   i. Ascending order
   
   ii. Descending order
1. To create the desired table:
   i. Open the database in which the table has to be created.
   ii. Click the CREATE tab. Under the Tables group, click the Table button.
   iii. You will see a blank table – Table1- in the Datasheet view where you can add data. Notice that the FIELDS tab is selected. If not, select the FIELDS tab.
   iv. Click the ID field and select Short Text from the Data Type list box under the Formatting group of the FIELDS tab.
   v. Click the down arrow of the Click to Add field and select Short Text. It adds a field – Field1 with the Short Text data type. Notice that the Click to Add field has shifted to the right.
   vi. Click the down arrow of the Click to Add field and select Short Text. It adds a field – Field2 with the Short Text data type. Notice that the Click to Add field has shifted to the right.
   vii. Repeat the same for adding other fields.
   viii. Click the down arrow of the Click to Add field and select Date/Time. It adds a field – Field5 with the Date/Time data type.
   ix. Click the down arrow of the Click to Add field and select Yes/No. It adds a field – Field6 with the Yes/No data type.
   x. Double-click the ID field and type AdmissionNo.
   xi. Double-click Field1 and type Name.
   xii. Double-click Field2 and type FName.
   xiii. Double-click Field3 and type LName.
   xiv. Double-click Field4 and type TeleNo.
   xv. Double-click Field5 and type DOB.
   xvi. Double-click Field6 and type BusAvailed
   xvii. Double-click Field7 and type BusNo.

To enter records, click inside the cell and start typing. Press ENTER or Arrow key to move to the next field/row.

2. To create the desired table:
   i. Open the database in which the table is to be created.
   ii. Click the CREATE tab. Under the Tables group, click the Table button.
   iii. You will see a blank table – Table1 in the Datasheet view where you can add data. Notice that the FIELDS tab is selected. If not, select the FIELDS tab.
   iv. Click the ID field and select Short Text from the Data Type list box under the Formatting group of the FIELDS tab.
   v. Click the down arrow of the Click to Add field and select Short Text. It adds a field – Field1 with the Short Text data type. Notice that the Click to Add field has shifted to the right.
   vi. Click the down arrow of the Click to Add field and select Short Text. It adds a field – Field2 with the Short Text data type. Notice that the Click to Add field has shifted to the right.
   vii. Repeat the same for adding other fields. For the AmountPaidMonthly field you can use the Currency data type.
   viii. Double-click Field1 and type Name.
   ix. Double-click Field2 and type GameJoined.
x. Double-click Field3 and type Category.

xi. Double-click Field4 and type AmountPaidMonthly.

To enter records, click inside the cell and start typing. Press ENTER or Arrow key to move to the next field/row.

3. The data types that can be used for the given fields are: ID: AutoNumber; Model: Short Text; Manufacturer: Short Text; Price: Currency; Quantity: Number.

To create this table do the following:

   i. Open the database in which the table is to be created.
   ii. Click the CREATE tab. Under the Tables group, click the Table button.
   iii. You will see a blank table – Table1 in the Datasheet view where you can add data. Notice that the FIELDS tab is selected. If not, select the FIELDS tab.
   iv. Click the ID field and select AutoNumber from the Data Type list box under the Formatting group of the FIELDS tab.
   v. Click the down arrow of the Click to Add field and select Short Text. It adds a field – Field1 with the Short Text data type. Notice that the Click to Add field has shifted to the right.
   vi. Click the down arrow of the Click to Add field and select Short Text. It adds a field – Field2 with the Short Text data type. Notice that the Click to Add field has shifted to the right.
   vii. Repeat the same for adding other fields. For the Price field you can use the Currency data type. For the Quantity field use the Number data type.
   viii. Double-click Field1 and type Model.
   ix. Double-click Field2 and type Manufacturer.
   x. Double-click Field3 and type Price.
   xi. Double-click Field4 and type Quantity.

To enter records, click inside the cell and start typing. Press ENTER or Arrow key to move to the next field/row.

To sort the data in descending order of the price:

   i. Click the arrow to the right of the Price field to display a menu of sorting and filtering options.
   ii. Click Sort Largest to Smallest to rearrange the records in the descending order of Price.

4. The data types that can be used for the given fields are: SNo: AutoNumber; Name: Short Text; LName: Short Text; FName: Short Text; TotalMarks: Number; CGPA: Number; Grade: Short Text.

For CGPA less than or equal to 10 do the following:

   i. Open this table in Design View. Click at the CGPA column. Enter <=10 in the Validation Rule property of this field.
   ii. Type It should be less than or equal to 10 in the Validation Text property of this field.

For TotalMarks in the range 1 and 600 do the following:

   i. Click at the TotalMarks column. Enter >=1 AND <= 600 in the Validation Rule property of this field.
   ii. Type It should be between 1 and 600 in the Validation Text property of this field.

To enter a record, click on the cell, type the entry and press ENTER.

5. Create a table as given in the figure. Name it—Inventory.

To sort in the ascending order of Price:

   i. In the Tables group, double-click Inventory to open the table in the Datasheet view.
   ii. Click the arrow to the right of the Price field to display a menu of sorting and filtering options.
iii. Click **Sort Smallest to Largest** to rearrange the records in the ascending order of **Price**.

To sort the table in descending order of **Quantity**:

i. Click the arrow to the right of the **Quantity** field to display a menu of sorting and filtering options.

ii. Click **Sort Largest to Smallest** to rearrange the records in the descending order of **Quantity**.

iii. On the **HOME** tab, in the **Sort & Filter** group, click the **Remove Sort** button to clear the sort from the field.

To filter records:

i. Click the arrow at the right side of the **Price** column header. You can also select the column header and click the **Filter** button in the **Sort & Filter** group of the **HOME** tab. In the menu that appears, click **Number Filters**, and click **Between** in the submenu.

ii. The **Between Numbers** dialog box appears. Type 100 in **Smallest** text box and 200 in **Largest** text box and click **OK**.

iii. Click at the filter icon next to **Quantity** field and click **Clear filter from Quantity**.

To search for data quickly, use the **Search** box at the bottom of the Access screen.

i. Enter the word **Toothpaste** in the **Search** box and press the ENTER key.

ii. Access highlights the first record in which the word **Toothpaste** appears.

iii. To find the next matching record, press the ENTER key again. Access finds all records that contain the word **Toothpaste**, anywhere in the datasheet.

---

**GROUP PROJECT**

Please refer to the group project guidelines at the beginning of this teaching guide.

This lesson could be spread over 2-3 sessions, when students are allowed to conduct research and then put their presentations together. The last session could be used for the final presentations.

---

**Chapter 2 Access 2013: Design View, Queries, Forms and Reports**

**OBJECTIVE TYPE QUESTIONS**

1. a. i. 255 characters  
   b. ii. Required  
   c. iv. Datasheet View  
   d. ii. Long Text  
   e. ii. >=1 AND <=500

**DESCRIPTIVE TYPE QUESTIONS**

a. The **Field Definition Grid** consists of **Field Selector**, **Field Name**, **Data Type** and **Description**.
   
i. **Field Selector**: Field selector allows selection of a field. One can then insert a row above the selected field, delete a row, or drag a row up or down to reposition the field in the table. The field selector box also identifies the primary key field of the table by displaying the **Primary Key** icon (a small picture of a key with a right-pointing arrow).

   ii. **Field Name**: This part of the grid lists the field names for the table being created.
iii. **Data Type**: The type of data of the fields is specified in this part. When a new field is added in **Design View**, it is by default assigned the **Short Text** data type. One can change a field’s data type by clicking on the arrow next to the entries in the **Data Type** column and selecting a new data type from the list that appears.

iv. **Description**: It contains an optional description of the field.

b. To set a field as a primary key:
   i. Select the field to be set as primary key.
   ii. Click **Primary Key** in the **Tools** group of the **DESIGN** tab.
   Or
   i. Right-click the field selector of the column that will be the primary key.
   ii. Select **Primary Key** from the context menu.

c. A **Form** is preferred over a **Datasheet View** in data entry because it provides an easy way to enter, edit, delete and view data in a table. Moreover, a form can enforce data validation on the data being entered. This provides greater control on the data entry.

d. To switch from the **Datasheet View** to the **Design View**, click the **View** drop-down menu arrow in the **Views** group on the **DESIGN** tab. Select **Design View**. To go back again to the **Datasheet View**, click the **View** drop-down menu arrow in the **Views** group on the **DESIGN** tab. Select **Datasheet View**.

e. **AutoNumber** field stores an integer that increments automatically as records are added. It is the default data type for the **ID** field. Yes, the data type of any field can be assigned as an AutoNumber. However, Access allows only one field to be AutoNumber data type in a table.

f. The validation rule `=1 or =2 or =3` will allow the user to enter only 1, 2 or 3 as input in that field.

g. Below is a comparison between the two methods of creating a table in MS Access:

<table>
<thead>
<tr>
<th>Datasheet View</th>
<th>Design View</th>
</tr>
</thead>
<tbody>
<tr>
<td>It shows data in the database and allows the user to enter and edit data.</td>
<td>It can create or change the table, form as well as configure fields.</td>
</tr>
<tr>
<td>The format of database cannot be changed.</td>
<td>It can set keys to restrict values that are entered.</td>
</tr>
<tr>
<td></td>
<td>It cannot change the data.</td>
</tr>
</tbody>
</table>

h. Both design view and datasheet view are important and need to be used interchangeably when using MS Access.

Students should be able to demonstrate the skills they’ve learned in this chapter. They should understand how databases are used to store large amounts of data in an organised manner, and the importance of appropriately labelling all data fields. Some students might list each field property and write only its definition which does not come up to the entire requirement of the question.

i. Answers will vary but the correct use of the method chosen will guide the final assessment. The fields they select as part of their database are also of importance.

---

**APPLICATION-BASED QUESTIONS**

a. i. There are 3 records and 5 fields in the table.
   ii. AdmnNo
   iii. AdmnNo: Short Text; Name: Short Text; Class: Short Text; DateOfAdmission: Date/Time; Nationality: Short Text
   iv. Default Value
b. i. The fields that can be present in the table are: BusPassID, RollNo, Class, Name, TelephoneNo, and BusFees.

   ii. BusPassID: Short Text; RollNo: Short Text; Class: Short Text; Name: Short Text; TelephoneNo: ShortText; and BusFees: Number.

   iii. BusPassID

c. | Field      | Property                        |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>MemberID</td>
<td>Field Size: 5</td>
</tr>
<tr>
<td>Name</td>
<td>Field Size: 30</td>
</tr>
<tr>
<td>Mobile</td>
<td>Required: Yes</td>
</tr>
<tr>
<td></td>
<td>Input Mask: (###)###-####</td>
</tr>
<tr>
<td>SportsJoined</td>
<td>Lookup Field</td>
</tr>
<tr>
<td>Charges</td>
<td>Validation Rule: &gt;=1500 and &lt;=3000</td>
</tr>
<tr>
<td></td>
<td>Validation Message: Not in the range.</td>
</tr>
<tr>
<td>Category</td>
<td>Validation Rule: =1 or =2</td>
</tr>
</tbody>
</table>

e. i. To display only ItemId, Quantity, and Price in the Query Design Grid, deselect the checkbox against the Show field of ItemName.

   ii. To show only those records with Price less than 100, in the Criteria of the Price field, type <100.

   iii. To display only those records with Quantity greater than 5, in the Criteria of the Quantity field, type >5.

   iv. To display records in the descending order of Price, choose Descending from the Sort box of Price.

---

**IN THE LAB**

1. a. To create and save a form:

   i. Click the table – PatientDetails in the Navigation pane.

   ii. Click Form in the Forms group of the CREATE tab. The DESIGN, ARRANGE and FORMAT tabs now appear on the ribbon.

   iii. Select the text box and resize it.

   iv. In the DESIGN tab, do the following:

      - Click on Logo in the Header/Footer group. The Insert Picture dialog box appears. Select a picture and click Insert.
      - Click on Title in the Header/Footer group. Type ‘Patient Information’ as the title for the form. The buttons for Form View, Layout View and Design View appear at the right end of the status bar.
      - Click on Date and Time in the Header/Footer group. A Date and Time dialog box appears, select a format and click OK
      - Click the Themes down-arrow of Themes group and select a required theme.

   v. Select the FORMAT tab and do the following:

      - Select the label and using the Font Color button in the Font group, change the text colour to blue.
      - Click anywhere inside the blank area of the form.
      - Click the down-arrow of Shape Fill in the Control Formatting group. Select a colour from the color palette.
vi. Click the **FILE** tab. Select the **Save** option to open the **Save As** dialog box. Type the form name and click on **OK**.

b. To enter records, click on the **Form** view in the status bar. Enter the records one-by-one in the form.

2. a. To create and save a form:
   i. Click the table – RoomDetails in the **Navigation pane**.
   ii. Click **Form** in the **Forms** group of the **CREATE** tab. The **DESIGN**, **ARRANGE**, and **FORMAT** tabs now appear on the ribbon.
   iii. Select the text box and resize it.
   iv. In the **DESIGN** tab, do the following:
      - Click on **Logo** in the **Header/ Footer** group. The **Insert Picture** dialog box appears. Select a picture and click **Insert**.
      - Click on **Title** in the **Header/ Footer** group. Type ‘Room Details’ as the title for the form. The buttons for **Form View**, **Layout View** and **Design View** appear at the right end of the status bar.
      - Click on **Date and Time** in the **Header/Footer** group. A **Date and Time** dialog box appears, select a format and click **OK**
      - Click the Themes down-arrow of **Themes** group and select a required theme.
   v. Select the **FORMAT** tab and do the following:
      - Select the label and using the **Font Color** button in the **Font** group, change the text colour to blue.
      - Click anywhere inside the blank area of the form.
      - Click the down-arrow of **Shape Fill** in the **Control Formatting** group. Select a colour from the color palette.
   vi. Click the **FILE** tab. Select the **Save** option to open the **Save As** dialog box. Type the form name as **frmRoomDetails** and click on **OK**.

To enter records, click on the **Form** view in the status bar. Enter the data for 10 records in the form one-by-one.

b. To create the query:
   i. Click **Query Design** in the **Queries** group on the **CREATE** tab.
   ii. The **Show Table** dialog box appears. Click the table RoomDetails and then click on **Add**, or just double-click the table.
   iii. Click on **Close**. The **Query Design** screen appears.
   iv. Select the fields to be included in the query by double-clicking the fields or by clicking and dragging individual fields to the query grid. Or, double-click the asterisk (*) to include all the columns of the query.
   v. In the **Criteria** of RoomStatus field, type =‘Available’.
   vi. Click **Run** in the **Results** group on the **DESIGN** tab. The output for the query will be displayed.
   vii. Click the **Save** button on the **Quick Access Toolbar**. **Save As** dialog box appears. Type the **Query Name** as qryAvailableStatus and click on **OK**.

3. a. To enter data in the **Datasheet View**, double click the cell and start typing.

b. To create the report:
   i. Click on **Report Wizard** in the **Reports** group of the **CREATE** tab.
   ii. **Report Wizard** screen 1 of 5 appears. Choose the table TempEmpDetails, add all the fields, and click on **Next**.
iii. **Report Wizard** screen 2 of 5 appears. Select the grouping level within the report and click on **Next**.

iv. **Report Wizard** screen 3 of 5 appears. Select field – Salary – from the drop-down menu. By default, sorting is in **Ascending** order. Leave it as it is.

v. **Report Wizard** screen 4 of 5 appears. Select the type of **Layout** within the report. In the **Orientation** section, select either **Portrait** or **Landscape**. Click on **Next**.

vi. **Report Wizard** screen 5 of 5 appears. Type the title for the report, rptAscendingSalary. Select **Preview the report** and click on **Finish**. The report will appear on the screen.

4. To create the table:
   i. Open the database and select the **CREATE** tab. Click **Table Design** in the **Tables** group.
   ii. For all the fields, one at a time, type the **Field Name**, select the **Data Type** and type the **Description**.
   iii. For the field **Grade**, select the data type as **Lookup Wizard** and do the following:
      - In the first screen, click “I will type in the values that I want” and click **Next**.
      - In the second screen, click in the blank row below **Col1**, type the grade and then press TAB or the down arrow key. After entering all the values, click **Next**.
   a. To enter data in **Datasheet** view, select the cell and start typing the data.
   b. To create the query using:
      i. Click **Query Design** in the **Queries** group on the **CREATE** tab.
      ii. The **Show Table** dialog box appears. Click the table StudentDetails and then click on **Add**, or just double-click the table.
      iii. Click on **Close**. The **Query Design** screen appears.
      iv. Select the fields to be included in the query by double-clicking the fields or by clicking and dragging individual fields to the query grid.
      v. In the **Criteria** of **Grade** field, type =’A’.
      vi. Click the **Save** button on the **Quick Access Toolbar**. **Save As** dialog box appears. Type the **Query Name** as qryGrade and click **OK**.
   c. To create the query to display records in the ascending order of StuName follow the same steps as in Q b. In step (v), select **Ascending** in the **sort** field of **StuName** column in the query grid.
   d. To create the report:
      i. Click on **Report Wizard** in the **Reports** group of the **CREATE** tab.
      ii. **Report Wizard** screen 1 of 5 appears. Choose the table StudentDetails, add all the fields, and click on **Next**.
      iii. **Report Wizard** screen 2 of 5 appears. Select the grouping level as Grade within the report and click on **Next**.
      iv. **Report Wizard** screen 3 of 5 appears. To sort data, click the **Ascending** button to change it to **Ascending**.
      v. **Report Wizard** screen 4 of 5 appears. Select the type of **Layout** within the report. In the **Orientation** section, select either **Portrait** or **Landscape**. Click on **Next**.
      vi. **Report Wizard** screen 5 of 5 appears. Type the title for the report, rptGrade. Select **Preview the report** and click on **Finish**. The report will appear on the screen.

5. To create the table:
   i. Open the database and select the **CREATE** tab. Click **Table Design** in the **Tables** group.
   ii. For all the fields, one at a time, type the **Field Name** and select the **Data Type**.
iii. Select the Field Selector of the field RollNo and click the Primary key button under Tools group of the DESIGN tab. A key like icon will appear on the field selector on the left of the field.

iv. Select the Field Selector of AssignmentMarks and do the following:
   • Select Yes as the value of Required. Now, this field cannot be left blank when you enter data.
   • Click the Validation Rule text box and type >=0 and <=50.

v. Select the Field Selector of TestMarks and type >=0 and <=100.

vi. Select the Field Selector of Assignment20% and do the following:
   • In the Expression text box, type [AssignmentMarks]* 0.20.
   • In the Result Type, select Single. Now you will get the output in decimal number.

vii. Select the Field Selector of Test80% and do the following:
   • In the Expression text box, type [TestMarks]*0.80 .
   • In the Result Type, select Single. Now you will get the output in decimal number.

viii. Select the Field Selector of Total and do the following:
   • In the Expression text box, type [Assignment20%] + [TestMarks80%].
   • In the Result Type, select Single. Now you will get the output in decimal number.

ix. Close the table design.

x. Type the table name ‘ScienceMarks’ when prompted for the table name.

xi. Double click the table ‘ScienceMarks’ and type in the 10 records.

xii. Close the table when done.

b. To create and print the report:
   i. Click on Report Wizard in the Reports group of the CREATE tab.

   ii. Report Wizard screen 1 of 5 appears. Choose the table ScienceMarks, add all the fields and click on Next.

   iii. Report Wizard screen 2 of 5 appears. Since no grouping level is required here, click Next.

   iv. Report Wizard screen 3 of 5 appears. Select field Total in the drop down box to sort the report on this field. Also click at the Ascending button to change it to Descending. Click Next.

   v. Report Wizard screen 4 of 5 appears. Select the type of Layout within the report. In the Orientation section, select either Portrait or Landscape. Click on Next.

   vi. Report Wizard screen 5 of 5 appears. Type the title for the report, rptDescendingTotal. Select Preview the report and click on Finish. The report will appear on the screen.

   viii. To print the report, click on Print in the Print group of the PRINT PREVIEW tab that appears. In the Print dialog box that appears, select the required option and click OK.

GROUP PROJECT

Please refer to the group project guidelines at the beginning of this teaching guide.

This activity could be divided into 3-4 sessions. The first two sessions could be lab based, one for research and the other to create the database. The third and fourth sessions could be used for feedback. Encourage each group to share the way they went about creating their database. Encourage class participation so there is an open and constructive sharing of ideas.

Resources: The students will need access to the computer lab and the internet for at least two sessions.
Chapter 3  Lists and Images in HTML 5

OBJECTIVE TYPE QUESTIONS

1. a. ii. Unordered  
b. iv. all of these  
c. i. list-style-image  
d. iv. Any one of these  
e. i. <img>  
f. i. src  
g. ii. medium  
h. i. <li>

DESCRIPTION TYPE QUESTIONS

a. A list in which the order of items is neither fixed nor important is called an **unordered list**. Each item in an unordered list is marked by a small symbol or image called bullet. Therefore, it is also known as **bulleted list**.

On the other hand, a list in which the order of items is fixed and important is called an **ordered list**. The individual items in an ordered list are marked by a number. Hence it is also called as **numbered list**.

b. The values that can be assigned to the **list-style-type** property of an ordered list are decimal, lower-roman, upper-roman, lower alpha, and upper-alpha.

c. The tags used for creating an ordered list are: <ol> tag and <li> tag; while those used for creating an unordered list are: <ul> tag and <li> tag.

d. The <dd> tag (definition list description) is a description list tag and is used to build a list of definitions.

e. The tags required to create a description list are <dl>, <dt>, and <dd>.

f. The <img> tag is used to insert an image in an HTML document. It is an empty element. Two attributes of this tag are:
   
   • src: This specifies the URL of the image to be inserted.
   • alt: This is used to specify an alternate text for an image.

g. The various ordering styles that can be given to the items of an ordered list are:
   
   decimal (default), lower-roman, upper-roman, lower-alpha, or upper-alpha.

h. GIF: Graphics Interchange Format  
   PNG: Portable Network Graphics

i. Students should identify ‘ordered’, ‘unordered’, and ‘description’ as the three types of lists. There is no real right answer as to why a student would pick one over the other, it is a matter of preference. The reasons that they give for using a particular method will be indicative of their learning.

j. HTML is used to create web pages which usually contain many visuals. Web pages need to be attractive so that visitors to any particular web page will find it enjoyable to go through the information. It also gives the website an overall style of presentation.

k. This question will require the students to practise coding in the computer lab. They will need to write their code and test it. As well as assessing students on the type of code that they’ve written (this depends on how the web page looks), marks can also be awarded for creativity.

APPLICATION-BASED QUESTIONS

a. i. **<img>** tag  
   
   ii. Two attributes of the **<img>** tag are:
   
   • alt: It is used to specify an alternate text for the image.
   • height: It is used to specify the height of the image.
iii. The src attribute of the `<img>` tag is used to specify the URL of the image. For example, `<img src="a1.jpg">` provides the URL of the image file named “a1.jpg”.

b. i. The tags needed to create this list are: `<dl>`, `<dt>`, and `<dd>`.
  ii. `<dl>`: Definition list; `<dt>`: Definition list item; `<dd>`: Definition list description
  iii. The two properties that can be used with these tags are color and font-size.

c. i. Ordered list or Numbered list.
  ii. She will use `<ol>` tag to create this list.
  iii. The list-style-type is used to specify the type of list-item marker. The values that can be set for this property are: decimal, lower-alpha, upper-alpha, lower-roman, and upper-roman.

d. | Given Code | Correct Code | Error |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;head&gt;</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td><code>&lt;title&gt;</code>Creating Ordered List</td>
<td><code>&lt;title&gt;</code>Creating Ordered List</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td><code>&lt;title&gt;</code></td>
<td>Missing closing tag</td>
</tr>
<tr>
<td><code>&lt;style type=&quot;text/ &quot;&gt;</code></td>
<td><code>&lt;style type=&quot;text/css&quot;&gt;</code></td>
<td>Incomplete string</td>
</tr>
<tr>
<td><code>ol {list-style-type: upper}</code></td>
<td><code>ol {list-style-type: upper-roman}</code></td>
<td>Incomplete type specification</td>
</tr>
<tr>
<td><code>&lt;/head&gt;</code></td>
<td><code>&lt;/style&gt;</code></td>
<td>Corresponding closing tag</td>
</tr>
<tr>
<td><code>&lt;/style&gt;</code></td>
<td><code>&lt;/head&gt;</code></td>
<td>Corresponding closing tag</td>
</tr>
</tbody>
</table>

### IN THE LAB

1. To create a web page:
   i. Open **Notepad** and type the following code:  
   ii. Save the document with a .html extension.  
   To view the output, open a web browser and select this file in the address bar of the browser.

2. To create the web page:
   i. Open **Notepad** and type the following code:

```
<!DOCTYPE html>
<html>
<head>
  <title>Summer Courses</title>
  <style type="text/css">
    ul {list-style-type: circle }
    li {color: red}
  </style>
</head>
<body>
  <h1>Summer Courses</h1>
  <ul>
    <li>Dance class</li>
    <li>Music class</li>
    <li>Badminton coaching</li>
    <li>Swimming lessons</li>
  </ul>
</body>
```
ii. Save the document with a .html extension.

To view the output, open a web browser and select this file in the address bar of the browser.

3. To create a web page:
   i. Open Notepad and type the following code:

```html
<!DOCTYPE html>
<html>
<head>
<title>Conducting Experiment</title>
<style type="text/css">
ul {list-style-type: square}
</style>
</head>
<body>
<h1>List of Materials</h1>
<ul>
<li>Paper</li>
<li>Cloth</li>
<li>Rubber</li>
<li>Matchstick</li>
<li>Glass</li>
<li>Plastic</li>
</ul>
</body>
</html>
```

ii. Save the document with a .html extension.

To view the output, open a web browser and select this file in the address bar of the browser.

4. To create a web page:
   i. Open Notepad and type the following code:

```html
<!DOCTYPE html>
<html>
<head>
<title>Uses of Non-Metals</title>
<style type="text/css">
h1 {color: blue}
ol {list-style-type: lower-roman; color: green }
li {color: green}
</style>
</head>
<body>
</body>
```
<h1>USES OF NON-METALS</h1>
<p>Some of the uses of non-metals are:</p>
<ol>
<li>Iodine is used as an antiseptic.</li>
<li>Graphite is used in batteries and in pencils.</li>
<li>Diamond is used for making jewellery. It is also used in cutting and grinding tools.</li>
<li>Coal is used as a fuel.</li>
<li>Oxygen is used in oxygen masks.</li>
</ol>

ii. Save the document with a .html extension.

To view the output, open a web browser and select this file in the address bar of the browser.

GROUP PROJECT

Please refer to the group project guidelines at the beginning of this teaching guide.
Provide ample time, perhaps as much as two lessons in the lab for the students to research the topic on the internet. The students will probably find it best to make their presentations using PowerPoint software. The relevance of the data, its organisation, and the overall presentation are all key learning indicators.

Chapter 4 Tables, Links, and Frames in HTML 5

OBJECTIVE TYPE QUESTIONS

1. a. F. An image can be set as a hyperlink.
   b. F. A caption can also be placed at the bottom of a table.
   c. F. The padding property specifies the space between the border and the content of a cell.
   d. T
   e. F. The <a> tag is a container element

2. a. III. both i. and ii. b. i. controls c. iv. all of these d. iv. any of these
   e. ii. <img> f. i. active g. i. href h. i. Pixels

DESCRIPTIVE TYPE QUESTIONS

a. The <b>src</b> attribute of the <audio> tag is used to specify the URL of the audio file. The <b>control</b> attribute is used to display the audio controls on the web page.

b. The <b>td</b> tag is the table data tag. It is used to specify an individual block or cell in a table row. The <b>tr</b> tag is the table row tag. It is used to define a horizontal row of cells.
c. The vertical-align property is used to set the vertical alignment of text in a table. The acceptable values for this property are: top, bottom, and middle.

d. Three kinds of links can be created on a web page:
   - **Internal**: A link to a point on the current page.
   - **Local**: A link to another page on the same website.
   - **Global**: A link to a page on a different website.

e. The anchor tag `<a>` is used to create a link. One attribute of this tag is `HREF`, which specifies the destination page or the file where the link will take the user to when clicked.

f. The answers here will vary. Make sure that students give you the URL for the web page which they are analysing. Their answers should show that they know what tables are used for and how they are created in HTML.

g. For programmers this feature is extremely useful as they can organise their codes in a better way, especially when writing a complicated or long code. They can develop a key and keep track of all the different actions that the page requires the user to make. From an aesthetic point of view, it also adds to the presentation of the page.

h. This lesson will require students to have access to the lab for at least two lessons. Two properly created frames with the audio and video embedded so that they are functional are required. Also, the heading and background colour should be appropriate to the subject matter used for both the audio and the video. As well as marking the technical aspect of the question, marks can also be allocated for creativity.

### APPLICATION-BASED QUESTIONS

a. i. The table will have a 4 pixel wide red coloured dashed border.
   
   ii. The position of the caption is ‘bottom’. The default position of a caption is ‘top’.
   
   iii. To have a space of 7px between the cell border and the cell content change the padding from 4px to 7px (i.e., `td {padding: 7px}`).

b. `<style type="text/css">
   a: hover {color: orange}
   a: alink {color: maroon}
   a: vlink {color: green}
</style>`

c. | Given Code | Correct Code | Error |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><code>td</code></td>
<td><code>td</code></td>
<td>None</td>
</tr>
<tr>
<td><code>{</code></td>
<td><code>{</code></td>
<td>None</td>
</tr>
<tr>
<td>cell-padding: 20px</td>
<td>padding: 20px</td>
<td>Incorrect property name</td>
</tr>
<tr>
<td>text-alignment: center</td>
<td>text-align: center</td>
<td>Incorrect property name</td>
</tr>
<tr>
<td>vertical-alignment: middle</td>
<td>vertical-align: middle</td>
<td>Incorrect property name</td>
</tr>
<tr>
<td><code>}</code></td>
<td><code>}</code></td>
<td>None</td>
</tr>
<tr>
<td><code>th</code></td>
<td><code>th</code></td>
<td>None</td>
</tr>
<tr>
<td><code>{</code></td>
<td><code>{</code></td>
<td>None</td>
</tr>
<tr>
<td>back-color: orange</td>
<td>background-color: orange</td>
<td>Incorrect property name</td>
</tr>
<tr>
<td>text-color: green</td>
<td>color: green</td>
<td>Incorrect property name</td>
</tr>
<tr>
<td><code>}</code></td>
<td><code>}</code></td>
<td>None</td>
</tr>
</tbody>
</table>
d. She should make use of the `<video>` tag to add a video to her HTML document. Assuming that the name of her video file is ‘movie1.mp4’, the code is listed below.

```html
<video src="movie1.mp4">
</video>
```

This tag will load the video in the browser but not play it unless clicked. To make the video play automatically when the page completes loading, the code is as shown below.

```html
<video src="movie1.mp4" autoplay="autoplay">
</video>
```

To show the video player controls, the code is as shown below.

```html
<video src="movie1.mp4" autoplay="autoplay" controls="controls">
</video>
```

### IN THE LAB

1.1. `<!DOCTYPE html>`

```html
<html>
<head>
<title>The French Connection</title>
<style type="text/css">
  h1 {text-align: center}
  h3 {text-align: center}
  p {text-align: justify}
  table{
    border: 2px solid black; empty-cell: hide; border-spacing: 2px 4px}
  th, td, tr {border: 2px solid green}
  td {padding: 4px}
</style>
</head>
<body>
<h1>The French Connection</h1>
<p>Numerous French words have a permanent place in the English Language. The table below gives the meaning of some commonly used French words.</p>
<table>
<tr>
  <th>French Words</th>
  <th>Meaning</th>
</tr>
<tr>
  <td>Adieu</td>
  <td>Goodbye</td>
</tr>
<tr>
  <td>Chef</td>
  <td>Head cook</td>
</tr>
<tr>
  <td>Bon voyage</td>
  <td>Happy journey</td>
</tr>
<tr>
  <td>Grand Prix</td>
  <td>Type of motor car racing</td>
</tr>
</table>
</body>
</html>
```

1.2. `<!DOCTYPE html>`

```html
<html>
<head>
<title>Air</title>
<style type="text/css">
</style>
</head>
<body>
</body>
</html>
```
The air around the earth is always moving. Moving air is called *wind*. The following table gives the names of some local winds that blow in different countries:

<table>
<thead>
<tr>
<th>Name</th>
<th>Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Loo</td>
<td>Pakistan</td>
</tr>
<tr>
<td>Simoon</td>
<td>Saudi Arabia</td>
</tr>
<tr>
<td>Mistral</td>
<td>France</td>
</tr>
<tr>
<td>Nor’wester</td>
<td>Argentina</td>
</tr>
<tr>
<td>Zonda</td>
<td>New Zealand</td>
</tr>
<tr>
<td>Norte</td>
<td>Mexico</td>
</tr>
</tbody>
</table>

### 1.3. Metals.html

```html
<!DOCTYPE html>
<html>
<head>
<title>Metals</title>
<style type="text/css">
body {background-color: yellow}

h1 {font-family: "Comic Sans MS"; color: maroon; text-align: center}
ol {list-style-type: decimal}
li{font-family: "Times New Roman"}

</style>
</head>
<body>
<h1>PROPERTIES OF METALS</h1>
<ol>
<li>All metals are solids, except mercury, which is a liquid.</li>
<li>Metals have high melting point.</li>
<li>They have high density.</li>
<li>They are malleable and ductile.</li>
</ol>
</body>
</html>
```
They are good thermal and electrical conductors.

They are good thermal and electrical conductors.

Click to see properties of non-metals

Click to see properties of non-metals

1. Non-metals.html

Non-metals can be solids, liquids, or gases.

They generally have low melting and boiling points.

They have low density.

They are not malleable and ductile.

They are non-conductors of heat and electricity, except graphite, which is a good conductor of electricity.

Click to see properties of metals

Click to see properties of metals

1.4. Greenhouse.html

GREENHOUSE EFFECT
The rays of the sun warm the earth’s surface. A part of the radiation falling on the earth is absorbed by its surface while the rest is reflected back to the atmosphere. Some gases, like carbon dioxide, methane, etc., trap some of the radiation that is reflected from the earth. These gases are called greenhouse gases.

The radiation trapped by these gases further warms the earth. This warming effect is called the greenhouse effect.

1. GlobalWarming.html

<!DOCTYPE html>
<html>
<head>
<title>Global warming</title>
<style type="text/css">
body {background-color: green; color: white}
hl {font-family: "Comic Sans MS"; color: orange; text-align: center}
ul {list-style-type: circle; color: orange}
li{font-family: "Times New Roman"; color: yellow}
</style>
</head>
<body>
<h1>GLOBAL WARMING</h1>
Due to the greenhouse effect, the average temperature of the earth’s atmosphere is gradually increasing. This is called global warming.

The following measures can be taken to check global warming:
<ul>
<li>The use of fossil fuels, like wood, coal, etc., should be minimized.</li>
<li>Cutting of trees should be banned.</li>
<li>More trees should be planted.</li>
<li>Electricity should be generated from hydroelectric power plants.</li>
</ul>
<p><a href="greenhouse.html">Click to read about the greenhouse effect</a></p>
</body>
</html>
GROUP PROJECT

Please refer to the group project guidelines at the beginning of this teaching guide. Provide at least three lessons for this group work. The first lesson could be spent doing research. The second lesson could be set aside for creating the website. The third lesson could then be used to present the websites. For this resources such as a multimedia projector may be required.

As this is a group project, students could be assessed on how well they’ve worked together, as well as demonstrating the different skills that have been used in order to create the campaign websites.

Chapter 5 Audacity

OBJECTIVE TYPE QUESTIONS

1. a. iv. all of these  
   b. i. Spacebar  
   c. ii. Ctrl+D  
   d. i. Effect  
   e. i. Ctrl+A  
   f. ii. .aup  
   g. i. Import  
   h. ii. Ctrl+V

DESCRIPTIVE TYPE QUESTIONS

a. To create a copy of the selected portion of an audio on the same track:
   i. Select the portion of audio track you want to copy.
   ii. Select the Copy option from the Edit menu.
   iii. Click at the position on the track where you want to insert the copied audio.
   iv. Select the Paste option from the Edit menu.

b. To export an audio file to a program like Windows Media Player, follow the steps below:
   i. Select File ➤ Export.
   ii. In the Export File dialog box that appears, enter the desired file name and select a format in the Save as type: menu.
   iii. Click on Save.

c. The Default Sample Rate is 44100Hz and the Default Sample Format is 32-bit float.

d. WAV, AIF, and MP3 are some of the common audio file formats that can be opened in Audacity.

e. The duration of an audio can be measured in minutes and seconds using the ruler (the Timeline) above the waveform.

f. To play an audio, click the Play button on the Transport toolbar or press the Spacebar.

g. Yes. To change the name of a track:
   i. Click the drop-down menu arrow of the Audio Track option and select Name...
   ii. The Track Name dialog box appears. Type a track name of your choice and click OK.

h. To import a music file as a background:
   i. Select File ➤ Import ➤ Audio. The Select one or more audio files... dialog box appears.
   ii. Select a file of your choice and click Open.
   iii. The selected music file is added as a background.

i. The properties of the different formats that can be played on Audacity are as follows:
WAV | AIFF | MP3
---|---|---
used for raw and uncompressed data | Microsoft Windows, Macintosh, and Linux operating systems | developed by Moving Pictures
compatible with Microsoft Windows, Macintosh, and Linux operating systems | better sound quality than WAV | good sound quality
large files, so not usually shared over Internet | | popular because uses file compression which means files are of smaller size

The question about the restrictions on how to use the software is a subjective one and students will answer differently, so there is no right or wrong answer here. As for the importance of why there should be an open software, students might give reasons such as:

- more people can access the software
- it is cheaper
- it is possible to experiment with different software

Nothing is actually free. It is important that students realise that there is a cost associated with developing any software. ‘Free’ software packages are often basic versions of the complete software and therefore have limited functionalities so if the user want to use all its features then the full software package will need to be purchased.

j. • This will make the documentary more pleasing to watch and listen to because carefully chosen music can add to the mood of the narration.
  • Multiple tracks allow different parts of the documentary to have different types of movie moods. For example, if the documentary is about lions hunting, more thrilling, and lively music can be used to illustrate this part of the documentary whereas lions at rest could be illustrated by gentler music.
  • These effects help in smoothing out the sound in general. ‘Fade in’ helps avoid abrupt transitions, whilst the silence generator is more important when the user wants to cut out unwanted words or language.

k. The quality of the recording will determine how well the students have mastered the skills of using audacity. The music teacher may be able to assist with making the ‘musical judgement.’

**APPLICATION-BASED QUESTIONS**

a. i. Meter Toolbar  
   ii. Timeline  
   iii. Selection Toolbar

b. i. Tools Toolbar  
   ii. • Envelope tool  
   • Time shift tool

c. i. The **Edit menu** and the **Preferences** option.  
   ii. 8000Hz  
   iii. 16-bit

d. i. The first track is a mono track and the second one is a stereo track.  
   ii. In a mono file, there is only single channel and identical audio is heard in both the left and the right speakers. In a stereo file, there are two channels, namely, the left and the right channel with differing waves and they produce a distinct sound each.
IN THE LAB

1. The needed sequence of steps:
   i. Open the existing instrumental track file by clicking **File ▶ Open** or **File ▶ Import Audio**. The **Select one or more audio files...** dialog box appears.
   ii. Select the desired file and click **Open**.
   iii. Click the **Record** button. Notice that a new track is automatically created and recording starts from the beginning. You can hear the instrumental recording as you record the voice track.

2. The steps to make the recording are:
   i. Select **Speakers** as the output device and **Microphone** as the input device in the **Device** toolbar.
   ii. Also select the **Input Channel** as **Mono**.
   iii. Click on the downward arrow next to the microphone symbol in the **Meter Toolbar**. Then click on **Start Monitoring** so that you can hear your recording.
   iv. Adjust the recording volume using the input **Volume slider** in the **Mixer Toolbar**.
   v. Click the **Record button** in the **Transport toolbar**. Start recording the narration. Notice the waveforms appearing when you are recording.
   vi. After recording is over, click the **Stop** button.

3. To extract a portion of a song, you need to use the **Selection** tool and follow the steps below:
   i. Use the **Zoom In** button in the **Edit** toolbar to get a closer look at the waveform.
   ii. Click the **Selection** tool.
   iii. Click on the point from where you want to start the selection.
   iv. While holding down the **SHIFT** Key, click to the right where you want the piece to end.
      Or
      Place the cursor over the edge of the selection until you get the pointing finger.
      Then click and drag left or right to make the selection.
   v. Having made the selection, click at **Edit ▶ Copy** command to extract this portion of the audio track. The extracted audio clip is now available on the clipboard. This clip can be inserted anywhere on any audio track by completing the **Paste** command (press **Ctrl+V** or click **Edit ▶ Paste** option).

4. To open an existing file, click **File ▶ Open** or **File ▶ Import Audio**. The **Select one or more audio files...** dialog box appears. Select the desired file and click **Open**. Repeat the same for another file. Make sure that among the two files selected one is a mono file and the other a stereo file.

   Take a screenshot of the window with the two files opened and paste the same in notebook.

GROUP PROJECT

Please refer to the group project guidelines at the beginning of this teaching guide.

The students will require considerable time to research and make a comparative analysis. This could be at least two lessons for research and then another lesson for putting together the presentations. A further lesson can then be used for the groups to present their findings. Students can be assessed on team work, quality of information, as well as on the presentation itself.
Chapter 6 Lightworks

OBJECTIVE TYPE QUESTIONS

1. a. F. The Edit Viewer has a red border.
   b. T       c. T
   d. F. The selection appears white.
   e. F. The Replace and Insert functions are used to get pictures and sound into the edit.

2. a. iv. all of these       b. iv. both i. and ii.        c. iv. both i. and ii.
   d. iv. all of these     e. iv. all of the above

DESCRIPTIVE TYPE QUESTIONS

a. To import a file or a group of files into your project:
   i. Click the Import icon on the toolbar. The Select Files to Import dialog box appears.
   ii. Click on Places at the top-left corner of the dialog box. From the menu that opens, navigate to the directory containing the files you wish to import.
   iii. Select the files you wish to import into your project in the Select files to import dialog box that opens. The Name, Format, Rate, Size, and Date of each clip is displayed here. Make sure that the frame rate of the file is compatible with the project frame rate.
   iv. Click Import. A panel reporting the progress of the import process is displayed.

   Or

   Another way of importing files is Batch Import. Right-click the Import icon and select Batch Import.... The Batch Import dialog box opens. Click Add Files. The Select files to import dialog box appears. Choose your files, click Start and click Import.

b. Video files with the extensions AVI, MOV, MXF, MPG, and MPEG can be imported into Lightworks for processing.

c. To create a new bin:
   i. Click the Bin icon on the toolbar. This opens the bin.
   ii. Drag the tiles in the Imports dialog box to the bin to add them to the bin folder.

   To make the added files permanent:
   i. Click the cogs icon on the bin and select the Permanence as Permanent.

d. For many editing operations, one needs to select a length of the source clip. This can be done by marking the In point and the Out point on the clip. This process is called mark and park in Lightworks. To mark and park do the following:
   i. Position the frame marker where you want the clip to begin.
   ii. Press the ‘In’ mark button on the console. A blue marker comes up below the current frame red marker.
   iii. Now move the current frame red marker to where you want the clip to end.
   iv. The portion between the blue marker and the current red frame marker is now selected and appears in white (i.e., marked).

e. To export the file:
   i. Drag the Export icon on the toolbar onto the edit, clip, tile or bin.
Or
Right-click on the edit, clip, tile or bin, and from the menu that opens, select Export.

ii. The Export window opens.
iii. Select the destination drive for the exported media.
iv. Type the name of the exported file.
v. Click Start.
vi. A Status window opens, displaying the progress of the export.
vii. After completion, a report displays in a Tasks Log window.

f. Bins allow the user to keep all the audio and video clips that are going to be used in one place, while racks allow the user to store and keep track of all the bins. These two features are important because a movie can consist of a large number of video and audio clips and the user may save them haphazardly thereby losing track of where all the material is.

Rooms are important because they store the material for one project. This allows for further organisation of projects. So, racks and bins ensure that individual projects remain organised and rooms allow the user to maintain organised data for different projects.

g. Videos are made of many frames and a good software will allow the user to manipulate those frames to make the best possible video. The ‘slip a shot’ feature allows the user to increase or decrease the length of the beginning clip without affecting the middle clip. The ‘slide a shot’ feature is also important because it lets the user increase or decrease the first clip at its end while at the same time increasing or decreasing the third clip at its beginning, while leaving the middle clip intact. Both are important because a good video depends on how a videographer manipulates frames.

h. It is best to define the time limit for the videos when this work is assigned to students. A 2 to 3 minute short video should be enough, both in terms of duration and the level of work that will be required. When watching the final product ask students questions about which features they used and how they used them. Mark the video for visual and audio quality, as well as creativity.

APPLICATION-BASED QUESTIONS

a. (i) To create a new rack:
   • Click on the Rack icon on the Toolbar
   • A new rack opens. To rename the rack, left-click on the title bar and type the new rack name.
(ii) Bin1 is closed.
(iii) To place Bin1 inside a rack:
   • If Bin1 is already open, click on the Shrink button to close it.
   • Click on the closed Bin1 and drag it onto the rack.
(iv) Click the cogs icon on the rack and select the Permanence as Permanent to make it permanent.

b. (i) 2
(ii) Yes. The soundtrack Wildlife has been added to the clip.
(iii) To see the waveforms more clearly, resize the timeline by right-clicking the bottom edge and dragging it down.

c. (i) The white band means that this particular portion is selected.
(ii) The name of the procedure used for marking the clip is mark and park.
d. (i) To mark the ‘in point’ do the following:
   • Position the frame marker where the clip is to begin.
   • Press the ‘In’ mark button on the console. A blue marker comes up below the current frame red marker.

(ii) (i) To manually change the dB level, mark the portion in the clip and type the dB level desired for that portion. (ii) To change the dB level by using a mouse, position the mouse over the audio track and drag the mouse to raise or lower the level.

(iii) To add a transition effect, click the Effects button.

(e. (i) To make the fields visible, click the Advanced button on the timeline and make the adjustments.

(ii) (i) To manually change the dB level, mark the portion in the clip and type the dB level desired for that portion. (ii) To change the dB level by using a mouse, position the mouse over the audio track and drag the mouse to raise or lower the level.

(iii) To add a transition effect, click the Effects button.

IN THE LAB

1. To create a movie:
   i. Double-click the Lightworks icon on the desktop.
   ii. In the Project Browser, type the name of the project. Select the Frame rate as Auto and click Create.
   iii. This opens the Project View window with Select Files to Import dialog box.
   iv. Click on Places in the Select Files to Import dialog box.
   v. From the menu that opens, navigate to the directory containing the files to import. Select the file(s) and click Import.
   vi. To store the clips in a bin, click the Bin icon. Drag the files in the Imports dialog box to the bin. One can rename the bin. To make it permanent, click the Cogs icon and select Permanence as Permanent.
   vii. Click the Edit icon on the toolbar. An Edit Viewer and Timeline open.
   viii. Double-click a tile in the bin to load it into the Source Viewer. The clip has a blue border. One may pin the Source Viewer, Edit Viewer and Timeline.
   ix. Mark the Source Viewer using Mark and Park procedure and click the Replace button.
   x. Double-click another tile in the bin to load into the Source Viewer. Mark the Source Viewer using the Mark and Park procedure and click the Replace button.
   xi. Similarly, add other clips.
2. To add music to the movie created above:
   i. Click the Cogs icon on the Timeline and select Add Tracks. The Add Tracks dialog box appears.
   ii. Change Type to Audio and click Add.

3. To create a movie follow the steps as given in question 1. To add special effects to the movie:
   i. Click Effects button. The Add Effects dialog box appears.
   ii. Select the Category and Apply to as Current Clip. Click Add.
   iii. Another screen appears. Select the Type and click Close. Also click the Close button of the Add Effects dialog box.

4. To create a movie:
   i. Double-click the Lightworks icon on the desktop.
   ii. In the Project Browser, type the name of the project. Select the Frame rate as Auto and click Create. This opens the Project View window with Select Files to Import dialog box.
   iii. Click on Places in the Select Files to Import dialog box. From the menu that opens, navigate to the directory containing the files to import. Select the file(s) and click Import.
   iv. To store the clips in a bin, click the Bin icon. Drag the files in the Imports dialog box to the bin. The bin can be renamed if needed. To make it permanent, click the Cogs icon and select Permanence as Permanent.
   v. Click the Edit icon on the toolbar. An Edit Viewer and Timeline open.
   vi. Double-click a tile in the bin to load it into the Source Viewer. The clip has a blue border. One may pin the Source Viewer, Edit Viewer and Timeline.
   vii. Mark the Source Viewer using Mark and Park procedure and click the Replace button.
   viii. Double-click another tile in the bin to load into the Source Viewer. Mark the Source Viewer using the Mark and Park procedure and click the Replace button. Similarly, add other clips.

To add audio to the movie:
   i. Click the Cogs icon on the Timeline and select Add Tracks. The Add Tracks dialog box appears.
   ii. Change Type to Audio and click Add.
   iii. Double-click the sound file in the bin to add to the Source Viewer.
   iv. Mark the Source Viewer.
   v. Deselect all the track and select the track where the sound tracks are added.
   vi. Mark and Park the Edit View where the sound track is added.
   vii. Adjust the volume of the audio track if desired by right-clicking on it and keeping the right-mouse button pressed, dragging it up or down.

5. To create a movie with audio and effects, follow the steps given in the previous question. To export the movie to a CD:
   i. Drag the Export icon on the Toolbar to the Edit Viewer. The Export dialog box appears.
   ii. Select the destination drive. Type the name of the exported file and click Start.

**GROUP PROJECT**

Please refer to the group project guidelines at the beginning of this teaching guide.

Give students ample time to finish this project, at least 3-4 lessons in the lab. The final assessment will be influenced
by observations of group work as well as the finished product. To test the students’ ability to use the different features and commands, stop the video at random moments and ask them which feature they applied and how.

Chapter 7  Introduction to Photoshop CS3

OBJECTIVE TYPE QUESTIONS

1.  a. iv. all of these  
b. ii. Status bar  
c. i. Lasso Tool  
d. iv. any one of these  
e. iii. Elliptical Marquee Tool  
f. i. Custom Shape  
g. iii. Magnetic Lasso Tool  
h. ii. Shift + Ctrl +S

DESCRIPTIVE TYPE QUESTIONS

b. The default foreground and background colours are black and white respectively.
c. To create new file:
   i. Select File ➤ New. The New dialog box appears.
   ii. In the New dialog box, specify the following:
      • Name: Assign a name to the file. By default, Photoshop names the files Untitled-1, Untitled-2, etc.
      • Width and Height: Enter the width and height of the new file. You can choose the required unit (pixels, inches, centimetres, points, or picas). The default unit is pixels.
      • Resolution: Enter the desired resolution.
      • Color Mode: Choose from the given options (bitmap, grayscale, RGB color, CMYK color).
      • Background Contents: Choose from white, background color, and transparent.
   iii. Click OK. A new blank file opens on the screen.
d. The Gradient Tool is used to fill a selected portion or an entire layer with a gradient (a fill consisting of two or more colors blending together).
e. To change the foreground color:
   i. Click the Foreground colour selection box in the tools panel. The Color Picker dialog box appears.
   ii. Drag the color slider.
   iii. Click in the Color Field and choose a colour.
   iv. Click OK.
f. The Circular (or Elliptical) Marquee tool is used to select an elliptical or a circular area of an image.
g. The Marquee tools are used to select rectangular, square, elliptical, or circular areas of an image while the Lasso tools are used to make free-hand selections of an image.
h. Resolution is the number of pixels per inch that make up an image. At a higher resolution, an image is sharper but its file size is also bigger.
i. The different ways that an image can be transformed include: skewing, rotating, scaling, flipping horizontally or vertically, applying a perspective, and distorting. The benefits of having so many options are that it
allows the user to present images in a variety of different ways according to the need of the webpage and the message that is being conveyed. It offers the user flexibility in manipulating images.

j. • Using the crop tool, the area that is focussed on can be selected. When the Enter key is pressed only the selected area will remain.
  • The gradient tool will allow the user to blend two colours together.
  • The transform tool can be used to do this.

In all three cases, the requirements of the task are made easy by the use of specific tools designed for that purpose.

k. This is a lab-based question and it is recommended that students be given at least one lesson to complete this. Advise the students to save only one image with all the tasks performed on it rather than four separate ones. Students can be assessed on their selection of the correct tool as detailed below:
  • Colour tool to change foreground and background colours
  • Crop tool for cropping away unwanted details
  • Use one of the selection tools such as the lasso tool to choose the part of the image the user wants to move, then click on the Move tool. Finally, using the ALT key, drag the cut portion where ever the user wants to place it on the screen.
  • The gradient tool to add the gradient and the transform tool for the transforming the picture.

APPLICATION-BASED QUESTIONS

a. (i) Menu bar  (ii) Options bar  (iii) Image Title bar  (iv) Tools Panel

b. (i) The File menu and the New option.  (ii) Untitled-1  (iii) Pixels

c. (i) Rectangular Marquee tool
   (ii) Elliptical Marquee tool  (iii) Lasso tool

d. (i) The steps for copying a selected part of an image to another location in the same image are:
   • Click on the Move tool in the tools panel.
   • With the ALT key pressed, drag the selection to the desired location.

(ii) The steps for copying the selected portion of an image to another image are:
   • Select Edit ➤ Copy.
   • Open the destination image.
   • Select Edit ➤ Paste.

IN THE LAB

1. The steps for copying the selected portion of the image (horse) to another image (landscape) are:
   • Open the image. Make a selection using the Marquee or the Lasso tool.
   • Select Edit ➤ Copy.
   • Open the destination image.
   • Select Edit ➤ Paste.

2. To create an aquarium:
   i. Start Photoshop CS3.
   ii. To insert the images of fish, turtle, etc.:
      • Select the Custom Shape tool.
• Click the arrow beside the Shape option in the Options bar and select the required shape.
• Click and drag the mouse to draw the shape.
• You can also change the colour of the shape.

iii. To add water wave strokes to the image:
• Click the Brush tool in the tools panel.
• Click the arrow beside the Brush command in the Options bar. The Brush Preset Picker appears.
• Click on a brush style of your choice.
• Click on Set foreground color in the Tools panel. The Color Picker Palette appears.
• Choose the colour you want from the Color Picker Palette and click OK.
• Click and drag the mouse pointer on the image to draw strokes of the selected colour.

3. To open an existing image file of a landscape:
   i. Select File ▶ Open.
   ii. The Open dialog box appears.
   iii. Using the Look in option, select the location of the file you want to open. Then, select the file.
   iv. Click Open.

The steps for copying a part of the image to another location:
   i. Select an area using the Marquee or the Lasso tool.
   ii. Click on the Move tool in the tools panel.
   iii. With the ALT key pressed, drag the selection to another location.

To add pictures of birds in the sky:
   i. Select the Custom Shape tool.
   ii. Click the arrow beside the Shape option in the Options bar and select the required shape.
   iii. Click and drag the mouse to draw the shape.
   iv. You can also change the colour of the shape.

4. To change the background colour:
   i. Click the Background color selection box in the tools panel. The Color Picker dialog box appears.
   ii. Drag the color slider.
   iii. Click in the Color Field and choose a color.
   iv. Click OK.

To add different shapes:
   i. Select the Custom Shape tool.
   ii. Click the arrow beside the Shape option in the Options bar and select the required shape.
   iii. Click and drag the mouse to draw the shape.
   iv. You can also change the colour of the shape.

**GROUP PROJECT**

Please refer to the group project guidelines at the beginning of this teaching guide.
Students may need two lessons for research and one lesson to put their presentations together. The last lesson of the exercise should be given for the students to present their work.
Chapter 8 Tools used in Photoshop CS3

OBJECTIVE TYPE QUESTIONS

1. a. ii. Background Eraser Tool  
   b. i. Background  
   c. iv. all of these  
   d. ii. Layers palette  
   e. i. Type Layer  
   f. iii. Options bar  
   g. i. Filters  
   h. iv. all of these

DESCRIPTIVE TYPE QUESTIONS

a. Yes, we can select multiple layers in Photoshop. For this, click the first layer and then press Shift key and click on the last layer.

b. The **Spot Healing Brush Tool** is used to remove blemishes, scars, spots, and other imperfections in a photograph. One can simply click and drag the mouse pointer across the affected area and the flaw disappears.

c. To flatten all visible layers, we have to make sure that all the layers are visible, and then select **Layer Flatten Image** command located in **Layers** menu.

   Flattening reduces the file size by merging all visible layers into the background.

d. The currently selected layer in Photoshop is called the active layer.

e. To rename a layer:

f. The use of layers is an important aspect of working in Photoshop. Layers allow a lot of flexibility for the user. If something should go wrong, that particular layer can be fixed without touching other layers, thus saving on effort and time.

g. Most tools derive their names from the type of functions that they perform.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blur</td>
<td>Can soften or blur a particular area of an image</td>
</tr>
<tr>
<td>Clone</td>
<td>Duplicates selected areas of an image</td>
</tr>
<tr>
<td>Smudge</td>
<td>Creates the effect of wet paint being smudged by a finger</td>
</tr>
<tr>
<td>Dodge</td>
<td>Can make darker areas lighter</td>
</tr>
<tr>
<td>Burn</td>
<td>Darkens the pixels in an image</td>
</tr>
</tbody>
</table>

h. This is a lab-based lesson and students should be given ample time to complete their work, preferably 2 lessons. Students can be assessed on the finished project as well as on their documentation of it to clarify the correct use of tools.

   i. Double-click the layer in the **Layers palette**.

   ii. Type a new name for the layer.

APPLICATION-BASED QUESTIONS

a. (i) **Spot Healing Brush Tool**

   (ii) To use this tool:

   • Open the image.

   • Select the **Spot Healing Brush** tool from the **Tools panel**.

   • Specify the following in the **Options bar**: 
Brush size

Type: Choose from Proximity Match or Create Texture

Sample All Layers: Click to sample data from all visible layers. Deselect this option to sample data from the active layer only.

• Click the area you want to fix, or click and drag, to remove the flaws.

b. (i) To create a new layer:

• Choose Layer ▶ New ▶ Layer.
• The New Layer dialog box appears. Set the following options:
  ➢ The default name of the new layer is Layer 1. Change it to something more appropriate.
  ➢ Click the drop-down menu arrow in the Color text box, and select a color for the layer.
  ➢ Set the Opacity value.
• Click OK.

The keyboard shortcut to insert a new layer: Shift + Ctrl + N

(ii) Yes, it can be done. To change the order of layers:

• Click and drag the layer up or down in the Layers palette.
• Release the mouse button when the highlighted line appears where you want to place the layer.

c. (i) Layer 1, Layer 2, and so on are the default names given to the new layers inserted.

(ii) To rename a layer:

• Double-click the layer in the Layers palette.
• Type a new name for the layer.

d. (i) Type layer.

(ii) The Create Warped Text button is used to change the shape and style of text. It is present in the Options bar.

IN THE LAB

1. To design a book cover:
   i. Start Photoshop CS3.
   ii. Create a new file.
   iii. To add a new layer:
      • Select Layer ▶ New ▶ Layer.
      • Give the layer an appropriate name.
      • Click OK. You will see a new blank layer in the Layers palette.
   iv. Copy the required images and paste them into this new layer.
   v. To create an effect like, say, wet paint smudged with a finger:
      • Select the Smudge tool from the tools panel.
      • Click and drag on the image to smudge an area.
   vi. To make the darker portions of an image lighter:
      • Select the Dodge tool from the Tools panel.
      • Click the arrow next to Brush in the Options bar. Select a soft-edge brush.
      • Click and drag the mouse on the image area to lighten the pixels.
vii. To darken the pixels in an image:
   • Select the **Burn** tool in the **Tools** panel.
   • Drag the brush over the image to darken it.

viii. The steps to add text to an image are given below:
   • Click the **Type** tool in the tools panel.
   • Select font, size, and colour in the **Options** bar.
   • Click the left mouse button on the image and type the text.

2. To design a cover for the attendance register, Ghazal should follow the steps given in the above answer. To change the background:
   i. Click the **Background** color selection box in the tools panel. The **Color Picker** dialog box appears.
   ii. Drag the color slider.
   iii. Click in the **Color Field** and choose a color.
   iv. Click **OK**.

3. To apply a filter to the entire layer, make sure that the layer is active. To apply a filter to a part of a layer, select that area, and do the following:
   i. Choose a filter from the submenus of the **Filter** menu.
   ii. Insert desired fill values and select options in the dialog box.
   iii. Click **OK** to apply the filter.

4. The tools that can be used to create a Rangoli design are: **Brush** tool, **Smudge** tool, **Dodge** tool, **Burn** tool, etc.

**GROUP PROJECT**

Please refer to the group project guidelines at the beginning of this teaching guide.

This project will require considerable group discussion and sharing of ideas by the groups. Each group could be provided with a flipchart/chart paper to make their list. Answers will vary, but as long as the group can justify why they chose a particular feature they can be marked accordingly.

**Chapter 9 Introduction to Dreamweaver CS3**

**OBJECTIVE TYPE QUESTIONS**

1. a. F. An image can be resized by mentioning its height and width in the Property Inspector.
   b. F. By default, the Property Inspector is located at the lower edge of the workspace.
   c. T
   d. F. **Show Code and Design views** allows you to see both the code and the web page for the same document in a single window.
   e. T
   f. T

2. a. iv. self b. iii. * c. iii. Page Properties d. ii. Status bar e. ii. Link
DESCRIPTIVE TYPE QUESTIONS

a. A local root folder is a folder on one’s local computer which stores the files one is currently working on, whereas a remote folder is a folder on the computer where the web server is running.

b. To create a new Website:
   i. In the opening page, under Create New, click Dreamweaver Site.
      Or
   ii. Click Site ▶ New Site to open a new website. The Site Definition dialog box appears. It has two tabs – Basic and Advanced. The Basic tab is selected by default. Here we enter information for the website in a series of screens that appear as we keep clicking the Next button.
   iii. We can now see our website folder listed in the Files panel.

c. To add a web page to a website folder follow these steps:
   i. Select File ▶ New.
   ii. The New Document dialog box appears. By default, the following options are selected: the new document is a Blank Page, the Page Type is HTML, and the layout is None. Click Create.
   iii. The Document window appears. Type the text as needed.
   iv. Click File ▶ Save to save the HTML file. The Save As dialog box appears. Type a name for the file and click Save.

d. For this, select the text or image and drag the Point to File icon next to the Link text box in the Property Inspector to the target document in the Files panel. Then select the option in the Target text box.

e. Flash buttons are images that can be hyperlinked. To add a Flash button to a web page do the following:
   i. Place the cursor where you want to insert the Flash button.
   ii. On the Common tab of the Insert bar, select Media and choose the Flash Button option from the menu.
      Or
   Select Insert ▶ Media ▶ Flash Button.
   The Insert Flash Button dialog box appears. Select the Style for the button. Type the Button text. Select the Font and font Size. Browse to the file linked to this button. Select the Target window. You can change the background color of the button. After applying all the desired changes, click Apply. The button will appear on the web page. If you like the button, click OK. Otherwise, change your selections and click Apply again to see how it looks. Finally, click OK.

f. There is no right or wrong to a person’s preference, so students could prefer either but they should be able to justify their answer.

Advantages of using Dreamweaver:
- efficiency and ease of use
- can use templates to make webpages
- can make consistent looking websites and webpages
- managing and updating websites is quicker

Advantages of using HTML:
- easy to understand
- supported by all browsers
- free software
- search engine friendly
- most development tools support HTML
g. A named anchor link allows the user to link to a particular part of a long document. Providing different colours to links; dependent on the action performed; makes it easier for the user to know which links have been utilised, for example, rollover link, active, visited. Hyperlink placement is important because it adds to the user-friendliness of the webpage.

h. This is a lab-based exercise and students could be given at least two lessons to complete this work. Students may be required to document which tools and commands they used and could be asked to justify their choices.

**APPLICATION-BASED QUESTIONS**

a. i. The * sign after the web page’s name means that there are unsaved changes in the file.
   ii. She should press SHIFT+ENTER keys.

b. i. **Preview/Debug in Browser** button is used to view the web page in a Web browser.
   ii. **Show Code** view

c. i. The text in blue and underlined is the hyperlinked text, i.e., on clicking this text one is directed to a new document or a new section within the current document.
   ii. **Page Properties** of the **Property Inspector** has been used to set the desired color for the link.

d. **Page properties, Bold, Text color, Background color, Page font, etc.**

e. i. To set the border, change the value of the **Border** property to 10. The colour of the border will be black.
   ii. The quickest method of making this image a hyperlink is to select the image and drag the **Point to File** icon next to the **Link** text box in the **Property Inspector** to the target document in the **Files panel**. Then select the option in the **Target text** box.
   iii. The colour of the border of the linked image will become blue.

**IN THE LAB**

1. Follow these steps to create a web page:
   i. Create a folder called WebSite1 on the desktop. Start Dreamweaver.
   ii. Click **Site ► New Site**. The **Site Definition** dialog box appears.
   iii. Click on the **Advanced** tab. Type the site name as WebSite1. Set the **local root folder** to the WebSite1 folder and click **OK**. Store the image file of the class teacher in this folder.
   iv. Right-click on the WebSite1 folder in the **Files panel**. Select **New File** from the context menu. Name it as ClassVIII_A.html.
   v. Double-click ClassVIII_A.html to open the page.
   vi. Type the text as required.
   vii. The text is formatted as follows:
      a. Select the relevant text and click the **bold** button.
      b. Select the relevant text and click the **Italic** button.
      c. Select the text and click the **Text Color** down-arrow; a color palette appears. Select a color from the palette.
      d. To add a bulleted list, select the relevant text and click the **Unordered list** button.
      e. To center the text, select the text and click the **Align Center** button.
viii. To add the image, select the image in the **Files panel** and drag it to the required position on the web page.

ix. To center the image, select the image and click the **Align Center** button.

x. To save the web page after making all these changes, press **CTRL + S**.

xi. Preview the web page by clicking the **Preview/Debug in browser** button.

2. Follow these steps to create a web page:

i. Create a folder called WebSite1 on the desktop. Start Dreamweaver.

ii. Click **Site ▶ New Site**. The **Site Definition** dialog box appears.

iii. Click on the **Advanced** tab. Type the site name as WebSite1. Set the **local root folder** to the WebSite1 folder and click **OK**.

iv. Right-click on the WebSite1 folder in the **Files panel**. Select **New File** from the context menu. Name it as SchoolFacilities.html

v. Double-click SchoolFacilities.html to open the page.

vi. Type the text as required.

vii. The text is formatted as follows:
   a. Select the relevant text and click the **bold** button.
   b. Select the relevant text and click the **Italic** button.
   c. Select the text and click the **Text Color** down-arrow; a colour palette appears. Select a colour from the palette.
   d. To add a bulleted list, select the relevant text and click the **Unordered list** button.
   e. To center the text, select the text and click the **Align Center** button.

viii. To add the image, select the image in the **Files panel** and drag it to the required position on the web page.

ix. To center the image, select the image and click the **Align Center** button.

x. To save the web page after making all these changes, press **CTRL + S**.

xi. Preview the web page by clicking the **Preview/Debug in browser** button.

---

To add a named anchor:

i. In **Design** view, place the cursor where you want the named anchor.

ii. Select **Insert ▶ Named Anchor**.

Or

Click **Named Anchor** on the **Common** tab of the **Insert** bar.

iii. The **Named Anchor** dialog box appears.

iv. Type a valid name for the anchor, for example, Top, and click **OK**. The name cannot contain any space. The anchor icon appears where the cursor is in the **Document** window.

v. Select the text that will become the hyperlink, i.e., Top of Page.

vi. Type the name of the named anchor along with a # sign in the **Link** text box of the **Property Inspector**. Here we type #Top.

vii. Select **File ▶ Save** to save the file.

viii. Press F12 or click **Preview/Debug in Browser** to view the page in a browser.

ix. Click the named anchor text, it will move to the place where the anchor icon is set.

x. Close the browser.
3. Follow the steps given in the first two answers to create the required web pages. To create hyperlinks:
   i. Select the text or image that you want to set as hyperlink.
   ii. Click the Hyperlink button in the Common category of the Insert menu.
   iii. The Hyperlink dialog box will appear.
   iv. Click the Browse button. The Select File dialog box will appear. Browse to the folder that has the target document for the hyperlink and select the file. Then click OK to return to the Hyperlink dialog box.
   v. From the Target menu of the Hyperlink dialog box, select the window in which the target file should open.
   vi. Enter a title for the link in the Title text box. This appears in the browser window.
   vii. Enter a one-letter keyboard equivalent in the Access Key text box. This will select the link in the browser.
   viii. In the Tab Index text box, enter the link’s number in the tab order.
   ix. Click OK. The selected text/image is changed to a hyperlink.

4. Follow these steps to create a web page:
   i. Create a folder called webSite1 on the desktop. Start Dreamweaver.
   ii. Click Site ▸ New Site. The Site Definition dialog box appears.
   iii. Click on the Advanced tab. Type the site name as WebSite1. Set the local root folder to the WebSite1 folder and click OK. Store the image files corresponding to each generation of Computers in this folder.
   iv. Right-click on the WebSite1 folder in the Files panel. Select New File from the context menu. Name it as ComputersTutorials.html.
   v. Double-click ComputersTutorials.html to open the page.
   vi. Type the text as required.
   vii. The text is formatted as follows:
      a. Select the relevant text and click the bold button.
      b. Select the relevant text and click the Italic button.
      c. Select the text and click the Text Color down-arrow; a colour palette appears. Select a colour from the palette.
      d. To add a bulleted list, select the relevant text and click the Unordered list button.
      e. To center the text, select the text and click the Align Center button.
   viii. To add the images, select the images in the Files panel and drag it to the required position on the web page.
   ix. To center the image, select the image and click the Align Center button.
   x. To save the web page after making all these changes, press CTRL + S.
   xi. Preview the web page by clicking the Preview/Debug in browser button.

5. Follow these steps to create a web page:
   i. Create a folder called webSite1 on the desktop. Start Dreamweaver.
   ii. Click Site ▸ New Site. The Site Definition dialog box appears.
   iii. Click on the Advanced tab. Type the site name as WebSite1. Set the local root folder to the WebSite1 folder and click OK. Store the image files corresponding to each type of pollution in this folder.
iv. Right-click on the WebSite1 folder in the Files panel. Select New File from the context menu. Name it as PollutionTypes.html

v. Double-click PollutionTypes.html to open the page.

vi. Type the text as required.

vii. The text is formatted as follows:
    a. Select the relevant text and click the **bold** button.
    b. Select the relevant text and click the **Italic** button.
    c. Select the text and click the **Text Color** down-arrow; a colour palette appears. Select a color from the palette.
    d. To add a bulleted list, select the relevant text and click the Unordered list button.
    e. To center the text, select the text and click the **Align Center** button.

viii. To add the images, select the images in the Files panel and drag it to the required position on the web page.

ix. To center the image, select the image and click the **Align Center** button.

x. To save the web page after making all these changes, press **CTRL + S**.

xi. Preview the web page by clicking the **Preview/Debug in browser** button.

To add a Flash button:

i. Place the cursor where you want to insert the Flash button.

ii. In the Insert panel of Common category, select Media and click the Flash Button option of the menu.
   Or Select Insert ▶ Media ▶ Flash Button.

   The Insert Flash Button dialog box appears. Select the Style for the button. Type the Button text. Select the Font and font Size. Browse to the file linked to this button. Select the Target window. You can change the background colour of the button. After applying all changes, click Apply. The button will appear on the web page. If you like the button, click OK.

---

**GROUP PROJECT**

Please refer to the group project guidelines at the beginning of this teaching guide.

Students may choose to produce the guide in a PowerPoint document with perhaps three slides per software. They could use the textbook for reference. Three lessons could be used for this activity – one for research, one for putting together the presentation (which could be a lab period) and finally a period when the group present their work to the class. There are no right or wrong answers here, but students must be able to justify why they prefer one software over the others.

---

**Chapter 10 Images and Framesets in Dreamweaver CS3**

**OBJECTIVE TYPE QUESTIONS**

1. a. F. One can add any number of images to a web page.
   b. T c. T d. T e. T

2. a. ii. Width and Height b. ii. ALT c. ii. Hotspot
d. ii. Frameset e. ii. ALT
DESCRIPTIVE TYPE QUESTIONS

a. Graphic Interchange Format (GIF), Joint Photographic Experts Group (JPEG), and Portable Network Group (PNG) are the formats supported by most web browsers.

b. Two ways of inserting rollover images are:
   - Click **Images** drop-down menu on the **Insert** bar of the **Common** tab and select **Rollover Image**.
   - Or
   - Select **Insert ▶ Image Objects ▶ Rollover Image**.

c. Rectangle, circle, and polygon are the three shapes that can be used to define an Image Map area.

da. To add an Excel file to a web page:
   i. Open the page that will have the link to the Excel document.
   ii. Drag the Excel file from its current location to anywhere on the Dreamweaver page. The **Insert Document** dialog box appears.
   iii. Select **Create a link** and click **OK**. If the document you are linking to is not in your site’s root folder, Dreamweaver prompts you to copy it to the site root folder. This ensures that the document will be available when you publish the Website.
   iv. Press F12 or click **Preview/Debug in Browser**.
   v. The web page will show a link to the Excel file. The file is downloaded when you click to open the file.

e. The most common use of frames or framesets is for navigation. A set of frames often includes one frame containing a navigation bar and another frame to display the main content pages. Using frames in this way has the following advantages:
   - A visitor’s browser doesn’t need to reload the navigation-related graphics for every page.
   - Each frame has its own scroll bar (if the content is too large to fit in a window), so that a visitor can scroll the frames independently. For example, a visitor who scrolls to the bottom of a long page of content in a frame doesn’t need to scroll back up to the top to use the navigation bar if the navigation bar is in a different frame.

f. Tariq should open a new document and go to the ‘Page from Sample’ option and choose ‘Frameset’. A list will drop down where all these choices will be mentioned. He can pick each in turn and see how it looks. He could include each choice on chart paper.

g. For someone who is beginning to make webpages, tables provide an easy and structured way to maintain data, and create a webpage. Each space is predefined and guides the developer in a step by step manner.

h. Students will probably only require one lesson to apply these features to their existing page. Assessment will be on the correct use of each of the items and how they fit into the overall scheme of the webpage.

APPLICATION-BASED QUESTIONS

a. He can use **Image Placeholder** until the final image to be added is decided. To place an Image Placeholder:
   i. In the Document window, place the insertion point where you want to insert a placeholder graphic.
   ii. Click **Images** drop-down arrow in the **Insert** bar of the **Common** category and select **Image Placeholder**. Or Select **Insert ▶ Image Objects ▶ Image Placeholder**.
   iii. The **Image Placeholder** dialog box appears. In **Name** (optional) enter the text you may prefer as a label for the image placeholder. Leave the text box blank if you do not want a label to appear. The name must begin with a letter and can contain only letters and numbers; spaces are not allowed.
• For **Width** and **Height** (required), type a number to set the image size in pixels.
• Select a color from the color palette.
• For **Alternate Text** (optional), enter text to describe the image for the viewers using a text-only browser.
• Click **OK**.

b. i. The concept of **Frame** and **Framesets** is shown in the figure.
ii. Input Devices is hyperlinked in the left frame.
iii. **_parent** will be the Target value so that the linked file appears in the main frame.

c. i. To increase the width of the left frame,
   • In the **Frame Property Inspector**, deselect the **No resize** option.
   • Drag the frame border of the frame to increase or decrease the width of the frame.
ii. To select the top frame, press ALT and click inside the frame in **Design** view, or click the frame in the **Frames panel**.
iii. Delete the other frames in the window. To delete a frame, drag a frame border off the page or to the border of the parent frame.
iv. To prevent others from resizing the frames, select the **No resize** option in the **Frame Property Inspector**.

d. i. Image Map
ii. The pointer changes to a hand.

e. To add a Word file to the web page:
   i. Open the page that will have the link to the Word document.
   ii. Drag the Word file from its current location to anywhere on the Dreamweaver page. The **Insert Document** dialog box appears.
   iii. Select **Create a link** and click **OK**. If the document you are linking to is not in your site’s root folder, Dreamweaver prompts you to copy it to the site root folder.
   iv. Press F12 or click **Preview/Debug in Browser**.
   v. The web page will show a link to the Word file. The file is downloaded when you click to open the file.

**IN THE LAB**

1. To create the desired web page:
   i. Create a root folder for a website. You can also use an existing folder.
   ii. Right-click the folder in the **Files panel** and select **New Folder** from the shortcut menu.
   iii. Rename the folder and call it Collage.
   iv. Right-click the folder and select **New File** from the shortcut menu.
   v. Rename the file Collage1.html.
   vi. Create another file and rename it as Photo1.html.
   vii. Double-click the file Collage1.html. The **New Document** dialog box appears.
   viii. Type the text and insert the image of the collage that you made.
   ix. Select the image in the **Document** window.
   x. In the **Property Inspector**, select the **Rectangle** tool and click around the image of a photograph to make a hotspot. Click the **Arrow** tool to close the shape.
xi. After creating the hotspot as shown, the Property Inspector displays hotspot properties. Do the following:
   • In the Link box, drag Point to File to the required file in the Files panel.
   • In the Target popup menu, select _self so that the linked web page appears in the same window.
   • In the Alt box, type the alternative text for text-only browsers.

xii. Repeat steps (x) and (xi) to define additional hotspots in the image map.

xiii. After you finish, click the blank area in the document to change the Property Inspector.

xiv. Double-click the file Photo1.html in the Files panel and type the required content.

xv. At the end, insert a Flash button and link it with the file Collage1.html.

xvi. Save the web page by clicking File ➤ Save.

xvii. Similarly, create the web page for each photograph and type the required contents.

xviii. Double-click Collage1.html and press F12 to view it in a browser.

xix. Move the pointer over the Photo1 image. The shape of the pointer changes because that part of the image is hyperlinked. Click Photo1 and the linked page (Photo1.html) will appear.

2. To add an Excel file to the web page:
   i. Open the page that will have the link to the Excel document.
   ii. Drag the Excel file from its current location to anywhere on the Dreamweaver page. The Insert Document dialog box appears.
   iii. Select Create a link and click OK. If the document you are linking to is not in your site’s root folder, Dreamweaver prompts you to copy it to the site root folder.
   iv. Press F12 or click Preview/Debug in Browser.
   v. The page will show a link to the Excel file. The file is downloaded when you click to open the file.

3. To insert a rollover image:
   i. Place the insertion point where you want the rollover image to appear in the Document window.
   ii. Click Images drop-down arrow on the Insert bar of the Common tab and select Rollover Image. Or, select Insert ➤ Image Objects ➤ Rollover Image.
   iii. The Insert Rollover Image dialog box appears. Set the following properties.
      - Image Name: Type the name of the image
      - Original Image: Provide the link of the original image.
      - Rollover image: Provide the link to the rollover image.
      - Preload Rollover image: Select to avoid a delay in loading of rollover image.
      - Alternate Text: (Optional) Text to describe the image for viewers using a text-only browser.
      - When Clicked Go to URL: Enter the URL of the file that opens when the rollover image is clicked.
   iv. Press F12 or click Preview/Debug button and select the browser. Or, select File Preview to view the web page in a browser.
   v. Move the pointer over the original image to see the rollover image.

4. She should insert a table in the web page. To insert a table:
   i. In the Design view of the Document window, place the insertion point where you want the table to appear.
   ii. Select Insert ➤ Table. Or, on the Common tab of the Insert bar, click Table.
   iii. The Table dialog box appears. Set the various attributes of the table, for example, Rows, Column, Table Width, Border Thickness, Cell Padding, etc.
iv. Click **OK** to create the table.

v. Click in the individual cells and type the data or insert an image.

5. To create a tutorial on ‘Evolution of Computers’:
   i. Create a folder for the new website.
   ii. Right-click the folder in the **Files panel** and select **New Folder** from the context menu.
   iii. Rename the folder as **Frameconcept**.
   iv. Select the folder and click **File ▶ New**. The **New Document** dialog box appears.
      - Select the **Page from Sample** category.
      - Under **Sample Folder**, select **Frameset**.
      - Under **Sample Page**, select **Fixed Top, Nested Left**.
   v. You will see a frameset with a fixed-size top frame and a nested left frame on the right of the dialog box. Click **Create**.
   vi. The **Frame Tag Accessibility Attributes** dialog box appears. You can specify a title for each frame or let the frame name appear as a title name. Click **OK**. The **Untitled Frameset** will appear.
   vii. To save the frameset and frames, select **File ▶ Save All** and save the frameset as **topframe**, **leftframe** and **mainframe**. Click the **Save** button every time. Notice while saving the frame, a border appears around the frame.
   viii. Drag the border of the left frame to make the frame wider.
   ix. Select the top frame and type the text ‘Evolution of Computers-A Tutorial’. Make the following changes in the **Property Inspector**:
      - Change the **Font** to **Times New Roman**.
      - Change the size to **xx-large**.
      - Go to **Page Properties** and change the background color to light yellow.
   x. Select the left frame and type FirstGeneration, SecondGeneration, ThirdGeneration, and so on . . . Make the following changes in the **Property Inspector**:
      - Change **Font** to **Default Font**.
      - Change **Size** to 18.
      - Click **Page Properties** and change **Background color** to dark pink, **Link color** to blue, **Rollover links** to red, and **Visited links** to green.
   xi. To create a web page ‘FirstGeneration’ do the following:
      - Right-click the folder and click **New File**. Rename the file as FirstGeneration.html.
      - Type the content as required.
      - Similarly, create the other web pages (‘SecondGeneration.html’, etc.)
   xii. Then to link the HTML document FirstGeneration.html to its corresponding label in the left frame:
      - Select the word ‘FirstGeneration’ in the left frame. Drag the **Point to File** icon next to the **Link** text box to the file ‘FirstGeneration.html’ in the **Files panel**. The filename will appear in the text box.
      - Set the **Target** to mainframe, i.e., the frame on the right.
      - Repeat the last two steps for the other words set as hyperlinks.
   xiii. Select the mainframe and click **Page Properties** and change **Background color** to light pink.
   xiv. Select **File ▶ Save All** to save the frameset and all the documents in frames.
xv. Press F12 to view the page or click **Preview/Debug in browser**.

xvi. In the browser, click the word, ‘First Generation’ in the left frame. The file ‘FirstGeneration.html’ will appear in the main frame.

### GROUP PROJECT

Please refer to the group project guidelines at the beginning of this teaching guide.

At least two lessons in the lab may be required for the students to combine their work. The complexity of what they end up with could be the guide as to how well they have learned to use the different commands and tools. The private and secure tabs are important because webpages may contain personal information and there should be proper security for accessing them.

### ASSESSMENT 1

### SECTION A (THEORY)

1.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Licence_No</td>
<td>Short Text</td>
</tr>
<tr>
<td>Date_Of_Servicing</td>
<td>Date/Time</td>
</tr>
<tr>
<td>Service_details</td>
<td>Long Text</td>
</tr>
<tr>
<td>Bill_Amount</td>
<td>Currency</td>
</tr>
</tbody>
</table>

2. a. ItemNo            b. AccountNo

3. a. For the value $P$ to be already added while entering the data, in the **Field Properties Pane** of the TypeOfService column, set the **Default Value** as $P$.
   b. Lookup Wizard
   c. **Validation Rule** should be set as $>=10000$ and $<=60000$ in the **Field Properties Pane** of the Salary column.
   d. **Validation Text** for Salary should be set as “Enter in the range 10000 to 60000”.
   e. The **Caption** for EmpName should be set as **Name of the Employee**.
   f. **Datasheet View**
   g. **Input Mask** for the field Mobile should be set as (@@@)@@@@-@@@@.

4. a. Relational Database Management System
   b. MySQL and Oracle

### SECTION B (PRACTICAL)

1. a. To create the desired table:
   i. Open the database in which the table is to be created.
   ii. Click **CREATE** tab. Under **Tables** group, click **Table** button.
   iii. You will see a blank table – Table1 in Datasheet view where you can add data. Notice that **FIELDS** tab is selected. If not, select the **FIELDS** tab.
iv. Click the ID field and select Auto Number from Data Type list box under Formatting group of FIELDS tab.

v. Click the down arrow of Click to Add field and select Short Text. It adds a field – Field1 with Short Text data type. Notice that Click to Add field shifted to right.

vi. Click the down arrow of Click to Add field and select Short Text. It adds a field – Field2 with Short Text data type. Notice that Click to Add field shifted to right.

vii. Repeat the same for adding other fields. For the Salary field you can use the Number data type.

viii. For the Gender field you can use the Lookup Wizard data type. Set the values F and M in the Lookup Field.

ix. Double-click ID field and type CoachID

x. Double-click Field1 and type CoachName.

xi. Double-click Field2 and type Sports.

xii. Double-click Field3 and type Salary.

xiii. Double-click Field4 and type Gender.

xiv. Save the table with the name Club.

b. To create the form:

i. Click the table – Club in the Navigation pane.

ii. Click Form in the Forms group of the CREATE tab. The DESIGN, ARRANGE and FORMAT tabs now appear on the ribbon.

iii. Select the text box and resize it.

iv. In the DESIGN tab, do the following:

• Click on Logo in the Header/ Footer group. The Insert Picture dialog box appears. Select a picture and click Insert.

• Click on Title in the Header/ Footer group. Type ‘Club Information’ as the title for the form. The buttons for Form View, Layout View, and Design View appear at the right end of the status bar.

• Click on Date and Time in the Header/Footer group. A Date and Time dialog box appears, select a format and click OK

• Click the Themes down-arrow of Themes group and select a required theme.

v. Select the FORMAT tab and do the following:

• Select the label and using the Font Color button in the Font group, change the text colour to blue.

• Click anywhere inside the blank area of the form.

• Click the down-arrow of Shape Fill in the Control Formatting group. Select a colour from the colour palette.

vi. Click the FILE tab. Select the Save option to open the Save As dialog box. Type the form name as frmClub and click on OK.

c. To enter records, click on the Form view in the status bar.

d. To create the query using the Query Wizard:

i. Click Query Wizard in the Queries group of the CREATE tab.

ii. The New Query dialog box appears. Select Simple Query Wizard and click on OK.

iii. Simple Query Wizard screen 1 of 3 appears. In the Tables/Queries box, select the table Club and then add all the fields.
iv. **Simple Query Wizard** screen 2 of 3 appears. Select Detail or Summary and click on Next.

v. **Simple Query Wizard** screen 3 of 3 appears. Type a query name in the text box, select Open the query to view information, and click on Finish.

vi. The query result will appear in the Datasheet View.

vii. Select Ascending from the drop-down menu of the Salary field.

To save this query:

i. Click the FILE tab and select Save option.

Or

Click the Save button on the Quick Access Toolbar. Type the query name: qryAscSalary and click on OK.

e. To create the query using the Query Wizard:

i. Click Query Wizard in the Queries group of the CREATE tab.

ii. The New Query dialog box appears. Select Simple Query Wizard and click on OK.

iii. **Simple Query Wizard** screen 1 of 3 appears. In the Tables/Queries box, select the table Club and then add all the fields.

iv. **Simple Query Wizard** screen 2 of 3 appears. Select Detail or Summary and click on Next.

v. **Simple Query Wizard** screen 3 of 3 appears. Type a query name in the text box, select Open the query to view information, and click on Finish.

vi. The query result will appear in the Datasheet View.

vii. Select F from the drop-down menu of the Gender field.

To save the query:

i. Click the FILE tab and select Save option.

Or

Click the Save button on the Quick Access Toolbar. Type the query name: qryFemaleCoach and click on OK.

f. To create the report:

i. Click on Report Wizard in the Reports group of the CREATE tab.

ii. **Report Wizard** screen 1 of 5 appears. Choose the table Club, add the fields, and click on Next.

iii. **Report Wizard** screen 2 of 5 appears. Select the grouping level as Gender within the report and click on Next.

iv. **Report Wizard** screen 3 of 5 appears. To sort data, click at Salary in the drop-down menu and click the Ascending button to change it to Descending.

v. **Report Wizard** screen 4 of 5 appears. Select the type of Layout within the report. In the Orientation section, select either Portrait or Landscape. Click on Next.

vi. **Report Wizard** screen 5 of 5 appears. Type the title for the report, Coach Details. Select Preview the report and click on Finish. The report will appear on the screen.

vii. Save the report by pressing Ctrl+S and giving it the name—rptCoachDetails.
ASSESSMENT 2

SECTION A (THEORY)

1. a. font-family  b. <li>  c. unordered list  d. padding  e. anchor tag <a>

2. TABLE  TR  IMG  VIDEO  TABLE  TR  CAPTION  OL  IMG  VIDEO  CAPTION  AUDIO  LI

3. a. <style type= “text/css”>
   a:visited {color: pink}
   a:hover {color: blue}
   a:active {color: green}
</style>
   b. i. Pause  ii. Play  iii. Stop
      iv. Skip to Start  v. Skip to End  vi. Record

SECTION B (PRACTICAL)

1. <!DOCTYPE html>
   <html>
      <head>
         <title> Creating Ordered List </title>
         <style type=“text/css”>
            ol {list-style-type: upper-alpha }
         </style>
      </head>
      <body>
         <h1>List of Subjects</h1>
         <ol>
            <li>English</li>
            <li>Urdu</li>
            <li>Mathematics</li>
            <li>General Science</li>
            <li>Social Science</li>
         </ol>
      </body>
   </html>

COMPREHENSIVE ASSESSMENT I

1. a. <img>  b. <iframe> tag  c. <td>...</td>
   d. table  e. database

2. a. <caption> tag defines a caption for the title of the table.
   b. Ordered list
c. `<ul>` tag is used to define an unordered list. This list is also called bulleted list.
d. i. Definition list term
   ii. Definition list description
e. Hyperlinks are used to tie the web pages together in a website or across different websites.
f. Validation Rule for Salary field: >=10000 and <= 50000
g. Caption property should be set to **Roll Number**.
h. Number
i. Yes/No
j. Lookup Wizard
3. a. The space between cells of a table is called cell spacing. Padding is the space between the cell contents and the cell border.
b. i. caption-side
   ii. border-spacing
c. decimal, lower-alpha, upper-alpha, and lower-roman
d. `<img>` tag is an empty element. src and alt are the two attributes used with this tag.
e. **Number** data type is used for numeric data that will be used in calculations. **AutoNumber** data type stores an integer that increments automatically as records are added.
4. ```html
<!DOCTYPE html>
<html>
<head>
<title>Creating Tables</title>
<style type="text/css"> 
 table{border: 2px solid blue; empty-cell: hide; border-spacing: 2px 4px}
th, td, tr {border: 2px solid green}
td {padding: 4px} caption {text-align: center;}
</style> </head>
<body>
<table>
<caption><h5> Student Table</h5></caption>
<tr>
<th><h3>Roll No.</h3></th>
th, td, tr {border: 2px solid green}
td {padding: 4px} caption {text-align: center;}
</style> </head>
<body>
<table> <caption><h5> Student Table</h5></caption>
<tr>
<th> <h3>Roll No.</h3></th>
<th> <h3>Name</h3></th>
<th> <h3>Class</h3></th>
</tr>
<tr> 
<td>1001</td><td>Arham</td><td>8 F</td> </tr>
<tr> 
<td>1124</td><td>Mishal</td><td>8 G</td> </tr>
</table>
</body>
</html>
```
5. a. In the Query Design Grid, for **ItemName** change the Sort value to **Descending** and press Run.
b. In the Query Design Grid, for **Price** set the Criteria as >=100 and <=200 and press Run.
c. In the Query Design Grid, for **ItemName** set the **Criteria** as “Pen” or “Pencil” and press **Run**.
d. In the Query Design Grid, for **Quantity** set the **Criteria** as <5.
e. In the Query Design Grid, deselect the **Show** checkbox for **ItemName** and **Quantity**.

6. a. i. Table b. ii. top c. iv. All of these
d. iii. Unordered list e. iii. Both i and ii f. iv. All of these
g. ii. Record h. iv. Field i. ii. 255
j. ii. For long entries

---

**ASSESSMENT 3**

**SECTION A (THEORY)**

1. a. Title bar b. Menu bar c. Options bar
d. Image Window e. Status bar

2. a. Crop Tool b. Magic Wand Tool c. Rectangular Marquee Tool

3. a. Replace, Insert, Delete, and Remove are the four functions performed while editing a video in Lightworks.
   b. To play a clip in Tile, either use the **Play** button on the console or the spacebar for play/pause.

4. a. **File** menu and **New** option.
   b. The file size will increase.
   c. RGB colour, CMYK colour
d. Pixels

**SECTION B (PRACTICAL)**

1. To design a school magazine cover:
   i. Start Photoshop CS3.
   ii. Create a new file.
   iii. To add a new layer:
      - Select **Layer** \(\rightarrow\) **New** \(\rightarrow\) **Layer**.
      - Give the layer an appropriate name.
      - Click **OK**. You will see a new blank layer in the Layers palette.
   iv. Copy the required image and paste it into this new layer.
   v. To create the effect like wet paint smudged with a finger:
      - Select the Smudge tool from the tools panel.
      - Click and drag on the image to smudge an area.
   vi. To make the darker portions of an image lighter:
      - Select the Dodge tool from the Tools panel.
      - Click the arrow next to Brush in the Options bar. Select a soft-edge brush.
      - Click and drag the mouse on the image area to lighten the pixels.
vii. To darken the pixels in an image:
   - Select the Burn tool in the Tools panel.
   - Drag the brush over the image to darken it.

viii. The steps to add text to an image shown in are given below:
   - Open the image.
   - Click the Type tool in the tools panel.
   - Select font, size, and colour in the options bar.
   - Click the left mouse button on the image and type the text.

---

**ASSESSMENT 4**

**SECTION A (THEORY)**

1. a. A rollover image, when viewed in a browser, changes as the pointer moves across it. The primary and secondary images used for this should be of the same size.
   b. An image placeholder is a graphic you use until the final image added to a web page is not decided. You can set the placeholder’s size and color as well as the text label.

2. a. Advanced  
   b. New  
   c. Files  
   d. text  
   e. Hand

3. a. It displays the HTML code for the web page.
   b. It displays the web page in the upper half of the window and HTML code in the lower half.
   c. It displays the web page.
   d. It is the place to enter a title to be displayed in the browser’s title bar.
   e. It allows you to preview or debug your document in a browser.
   f. It updates the Design view of the web page with the changes made in Code view.

4. a. SHIFT+ENTER  
   b. ENTER

**SECTION B (PRACTICAL)**

1. To create the web page:
   i. Create a folder called WebSite3. Open Dreamweaver.
   ii. Click Site ► New Site. The Site Definition dialog box appears.
   iii. Click on the Advanced tab. Type the site name as Pakistani Leaders. Set the local root folder to the WebSite3 folder and click OK. Store all image files in this folder.
   iv. Right-click on the WebSite3 folder in the Files panel. Select New File from the shortcut menu. Name it Index.html.
   v. Double-click Index.html to open the page.
   vi. Type the required text on any of the given personalities.
   vii. To format the text, select the text and click the required option in the Property Inspector.
viii. To give background colour, click Page Properties in the Property Inspector. This will open the Page Properties dialog box. Select the Background colour and click OK.

ix. To insert the image, select the image in the Files panel and drag it to the required position and click Align Center in the Property Inspector to center aligned the image.

x. Save the page by clicking CTRL + S.

Use the same process to create another web page Content.html.

To create hyperlink:

i. Select the text or image that you want to set as hyperlink.

ii. Click the Hyperlink button in the Common category of the Insert menu.

iii. The Hyperlink dialog box will appear.

iv. Click the Browse button. The Select File dialog box will appear. Browse to the folder that has the target document for the hyperlink and select the file. Then click OK to return to the Hyperlink dialog box.

v. From the Target menu of the Hyperlink dialog box, select the window in which the target file should open.

vi. Enter a title for the link in the Title text box. This appears in the browser window.

vii. Enter a one-letter keyboard equivalent in the Access Key text box. This will select the link in the browser.

viii. In the Tab Index text box, enter the link’s number in the tab order.

ix. Click OK. The selected text/image is changed to a hyperlink.

To add a Flash button:

i. Place the cursor where you want to insert the Flash button.

ii. In the Insert panel of Common category, select Media and click the Flash Button option of the menu. Or

Select Insert Media Flash Button.

The Insert Flash Button dialog box appears. Select the Style for the button. Type the Button text. Select the Font and font Size. Browse to the file linked to this button. Select the Target window. You can change the background colour of the button. After applying all changes, click Apply. The button will appear on the web page. If you like the button, click OK.

### COMPREHENSIVE ASSESSMENT II

1. a. Audacity  
   b. Resolution  
   c. Spot Healing Brush  
   d. Cogs  
   e. Export

2. Answer the following questions

   a. Clone Stamp tool  
   b. Background Eraser tool and Magic Eraser tool  
   c. Blur tool  
   d. Auto  
   e. Clip, Bin, and Rack  
   f. as many as desired  
   g. Frameset  
   h. .bmp  
   i. #Top
3. a. To change the colour of the text in Dreamweaver, select the text and click the **Text Color** drop-down arrow, a colour pallet appears. Select a colour from the pallet.

b. To insert date:
   i. In the **Document** window, place the insertion point where you want the date to be inserted.
   ii. Select **Insert Date**
       Or
       In the **Common category** of the **Insert bar**, click the **Date** button.
   iii. The **Insert Date** dialog box appears. Select a **Day format**, **Date format**, and **Time format**.
   iv. Select **Update automatically on save**, if you want the inserted date to be updated every time you save the document.
   v. Click **OK** to insert the date and time.

c. Pixels and percentage

d. The space between cells of a table is called cell spacing. Padding is the space between the cell contents and the cell border.

e. The image that gets displayed when the pointer rolls over the original image. Two images are required for this i.e. Primary image and Secondary image.

4. a. Layer 1. To rename this layer:
   i. Double-click the layer in the **Layers** palette.
   ii. Type the new name.

b. Smudge tool
c. Burn tool
d. Rectangular Marquee tool

5. a. Yes
   b. Outer glow, and Bevel and Emboss are being used here.
   c. **Layer** menu and **Layer Style** option

6. a. i. Foreground colour
    b. iv. none of these
c. ii. .psd
d. iv. 

e. iii.
f. iii. Adobe Photoshop
g. ii. Status bar
h. ii. 2
i. iv. Pixels
j. iv. Properties Inspector

---

**Cyber Olympiad Questions**

21. a 22. b 23. d 24. c 25. a  
26. a 27. d 28. a 29. a 30. c  
31. d 32. b 33. d 34. d 35. c  
36. c 37. b 38. b 39. a 40. d  

**Revision Questions**

1. Each specific piece of information in a table is called value.
2. 20
3. AdmissionNo
4. Short Text
5. Four parts of **Field Grid** pane are:
   a. Field Selector
   b. Field Name
   c. Data Type
   d. Description (Optional)
6. Tab
7. To add the field of a table to Query Design Grid, click the field and drag it to the required column in the grid.
8. To select multiple fields, press the CTRL key and click the **Field Selector**.
9. = “Karachi” or “Lahore”
10. Text-align property specifies the horizontal alignment of text or a block of text. Values that can be assigned to this property are: left, right, center, and justify.
11. Normal, italic, and oblique
12. Margin-bottom: Sets the fixed bottom margin of an element in px, pt, cm, etc.
    Margin-left: Sets the left margin of an element in px, pt, cm, etc.
13. List-style property is used to set all the list properties in one statement. For example: list-style: square inside.
14. Tables help in organising data and presenting it in a clear way.
15. `<th>` tag is used to add headings to a table whereas, `<td>` is used to add columns to a table.
16. `<audio>` tag attributes: autoplay, controls, `src`, and `loop`.
17. Shrink button is used to close the bin and return it to the rack.
18. AVI, MOV, MXF, MPG, and MPEG are file extensions supported by Lightworks.
19. Audacity is a popular editing software used for editing and recording digital audio.
20. **Slip a shot** and **Slide a shot**.
21. To save a file in Audacity, click on **File ▶ Save Project As. Save As** dialog box appears. Enter the file name and click on OK.
22. Clipping is a sort of distortion that causes a harsh sound at the distortion points during playback of your recording.
26. Lasso-tools are used to make free-hand selections in an image.

27. To change the foreground or background colour, the steps are:
   - Click the **Foreground** or **Background** colour selection box in the tools panel. The **Color Picker** dialog box appears.
   - Drag the colour slider.
   - Click in the colour selection box and choose a colour.
   - Click **OK**.

28. Resolution in the number of pixels per inch.

29. Crop tool

30. The **Spot Healing Brush** tool can remove blemishes, scars, spots, and other imperfections in your photograph. The **Healing Brush** tool is used to paint with sampled pixels from an image.

31. To change the order of layers:
   - Click and drag the layer up or down in the **Layers palette**.
   - Release the mouse button when the highlighted line appears where you want to place the layer.

32. To rotate an image:
   - Select the Layer or image.
   - Select **Edit Transform Rotate**. The rotation handles appear.
   - Click and drag the rotation handle.
   - Double-click inside the image to apply the transformation.

33. The **Filter Gallery** in Photoshop lets you apply filters incrementally and apply individual filters more than once.

34. Blue

35. To change link colour in Dreamweaver, Click **Page Properties** in **Property Inspector**. The **Page Properties** dialog box appears. Click the **Links** Category. Select a link colour of your choice and click **OK**.

36. A **Named anchor** is a named marker in a document, typically at the top of a long page, whose link anywhere in the document, when clicked, returns to the location of the marker.

37. To remove the hyperlink property of a text, right click on the linked text. A dialog box appears. From the dialog box, select **Remove Link**.

38. Play

39. GIF, JPEG, and PNG are file formats preferred in web pages.

40. A **primary image** is the image which is displayed when the web page is first loaded. A **secondary image** is the image which appears when the pointer moves over the primary image. This happens if the images are set as **Rollover images**.
WORKSHEETS

- Worksheets have been provided for all the chapters of the course book.
- Each worksheet is of 15 marks and is recommended as a formative assessment paper.
- It is possible to use these worksheets as they are by photocopying them in magnified size (120% approx.) and distributing to the students.
- The questions in the worksheets may also be used as samples to create your own additional worksheets.
- They are also available as printable documents in digital resources.
Chapter 1  Introduction to Access 2013

1. Who am I?  (5)
   a. I arrange all your data in an orderly manner so that you can retrieve information easily when you require it.
   b. I am an organised collection of data.
   c. I contain programming statements written in VB.
   d. I am the area below the title bar.
   e. I am a view used primarily for entering data into a table.

2. Unjumble the letters to form words using the hints given.  (5)
   a. Porter
      Hint: It displays data in an easy-to-read format for printing
   b. Croma
      Hint: Automates tasks that are performed often.
   c. Latnaliore
      Hint: A very popular database model.
   d. Dielsf
      Hint: Columns in a table
   e. Yuccnerr
      Hint: A data type

3. Search for any five words related to MS Access in the grid below:  (5)

   \[
   \begin{array}{cccccccc}
   W & F & I & L & T & E & R & K & V \\
   K & E & T & L & O & S & S & X & A \\
   T & A & L & U & E & S & R & S & L \\
   A & P & Q & U & E & R & Y & O & U \\
   B & M & I & X & E & D & S & E & E \\
   L & O & T & E & M & M & A & R & U \\
   E & T & K & P & E & C & T & E & T \\
   T & O & F & O & R & M & Y & R & E \\
   \end{array}
   \]
### Chapter 2  Access 2013: Design View, Queries, Forms and Reports

1. **Who am I?**
   
   a. I am a method to getting answers to questions about data.
   
   b. I am a type of key which is a field or combination of fields that uniquely identifies a record.
   
   c. I am a way for viewing, entering, editing, and deleting data in a table.
   
   d. I am a view in which you can modify the structure of a table.
   
   e. I am an effective way to present data in printed format.

2. **Give three facts about the following:**

   a. Access Queries
   
   b. Access Forms

3. **Search for any four words related to Tabs in MS Access in the grid below:**

<table>
<thead>
<tr>
<th>WIN HOME KEF</th>
<th>CETLOSSXO</th>
<th>RERTAPER</th>
<th>EPBCRMOM</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARMOUSEA</td>
<td>TOTEMART</td>
<td>EMOCTEN</td>
<td>MADEIGNE</td>
</tr>
</tbody>
</table>
Chapter 3 Lists and Images in HTML 5

1. Who am I?  (5)
   a. I am the tag using which graphics can be inserted into an HTML document.
   b. I am a list in which the order of items is not important.
   c. I am a list where each item has a block of text acting as definition.
   d. I am the extension of an HTML document.
   e. I am the starting tag of an ordered list.

2. Give three facts about the following:  (3 x 2 = 6)
   a. Unordered List
   b. Images in HTML

3. Search for any four terms related to HTML properties in the grid below:  (4)

```
S  Q  P  X  O  W  N  K  S
P  E  T  L  O  S  S  X  T
Y  F  O  N  T  Q  R  S  Y
W  P  B  O  O  T  I  O  L
A  L  I  G  N  U  S  E  E
R  O  T  N  O  R  T  O  N
B  O  R  D  E  R  T  E  S
M  A  L  W  A  R  E  R  E
```
Chapter 4 Tables, Links and Frames in HTML 5

1. Who am I? (5)
   a. I am the space between the cell contents and the cell border.
   b. I am a grid of rows and columns.
   c. I am the attribute of the URL of a web page to be displayed on the frame.
   d. I am the tag used to define an inline frame that displays a web page within a web page.
   e. I am the tag which defines which HTML document to put in which frame.

2. Unjumble the letters to form words using the hints given. (5)
   a. Narletin
      Hint: A link to the current page
   b. Bedme
      Hint: Tag used to add audio or video files in an HTML document.
   c. Roveh
      Hint: Colour of the link when mouse is pointed over it.
   d. Choran
      Hint: An HTML tag used to create a link.
   e. Loglab
      Hint: Link to a page on a different website

3. Search for any five HTML tags and attributes in the grid below: (5)

```
C O N T R O L S S U
X R T I T L O X T V
I E A U D I O S I I
N I D T H E P N K D
E H D E S I G N E E
W O H E I G H T W O
T M N I T O R E O C
A U T O P L A Y P R
```
Chapter 5  Audacity

1. **Who am I?** (5)
   a. I am the toolbar which has buttons for playback and recording.
   b. I am the toolbar which helps you control the volume levels of toolbar.
   c. I am a tool which helps you make smooth volume changes.
   d. I am the toolbar which helps you change speed of playback.
   e. I occur when the top or bottom of a waveform gets chipped off.

2. **Give three facts about the following:** (3 x 2 = 6)
   a. Stereo files
   b. Audacity

3. **Search for any four terms related to Audacity in the grid below:** (4)

<table>
<thead>
<tr>
<th>S</th>
<th>P</th>
<th>Q</th>
<th>A</th>
<th>N</th>
<th>I</th>
<th>T</th>
<th>Z</th>
<th>T</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>R</td>
<td>E</td>
<td>P</td>
<td>E</td>
<td>A</td>
<td>T</td>
<td>X</td>
<td>O</td>
</tr>
<tr>
<td>M</td>
<td>E</td>
<td>A</td>
<td>L</td>
<td>P</td>
<td>M</td>
<td>R</td>
<td>S</td>
<td>O</td>
</tr>
<tr>
<td>P</td>
<td>A</td>
<td>R</td>
<td>A</td>
<td>N</td>
<td>G</td>
<td>E</td>
<td>E</td>
<td>L</td>
</tr>
<tr>
<td>L</td>
<td>H</td>
<td>D</td>
<td>O</td>
<td>S</td>
<td>I</td>
<td>G</td>
<td>N</td>
<td>B</td>
</tr>
<tr>
<td>E</td>
<td>L</td>
<td>F</td>
<td>A</td>
<td>R</td>
<td>N</td>
<td>E</td>
<td>R</td>
<td>A</td>
</tr>
<tr>
<td>E</td>
<td>M</td>
<td>B</td>
<td>R</td>
<td>E</td>
<td>A</td>
<td>K</td>
<td>E</td>
<td>R</td>
</tr>
<tr>
<td>E</td>
<td>F</td>
<td>F</td>
<td>E</td>
<td>C</td>
<td>T</td>
<td>S</td>
<td>S</td>
<td>L</td>
</tr>
</tbody>
</table>
Chapter 6  Lightworks

1. **Who am I?** (5)
   a. I am a very popular video-editing software.
   b. I am a still, individual constituent of a movie.
   c. I am a place where you play and edit files.
   d. I am the place in a room where project components are kept.
   e. I am a place where you keep your audio and video clips that you want to use in making your movie.

2. **Give three facts about the following:** (3 x 2 = 6)
   a. Working with Audio
   b. Lightworks

3. **Search for any four words related to Lightworks in the grid below:** (4)

```
W A V E F O R M M
R I O L A M A W Y
O K O O E S C I S
C A S U H I K T P
K C L T S T G T A
T I M E L I N E C
G M B B E A K R E
P L A Y B A C K W
```
Chapter 7  Introduction to Photoshop CS3

1. **Who am I?**  
   a. I am a one-stop image editing application.  
   b. I am the topmost bar of the Photoshop window.  
   c. I am a tool used to making free selections as you go.  
   d. I am a tool used to draw freehand.  
   e. I am a tool used to lighten pixels in an image.

2. **Unjumble the letters to form words using the hints given.**
   a. Serera  
      Hint: Tool to rub out a part of an image  
   b. Regnichout  
      Hint: Tool to correct images.  
   c. Pereyeprod  
      Hint: Tool to select a colour  
   d. Lusoretion  
      Hint: The number of pixels per inch that make up an image.  
   e. Eramque  
      Hint: Tools used to select areas of an image

3. **Search for any five words related to Photoshop in the grid below:**

   | G | R | A | D | I | E | N | T | I | X | L | A | Y | C | U | B | S | Z |
   | R | E | C | T | A | N | G | L | E |
   | L | N | S | P | O | C | X | O | T |
   | W | B | V | D | C | T | U | E | O |
   | C | L | N | T | R | C | A | R | G |
   | Q | U | R | Z | O | O | M | L | M |
   | T | R | A | N | P | F | O | R | M |
Chapter 8 Tools used in Photoshop CS3

1. Who am I? (5)
   a. I am a family of tools engaged in changing the pixel arrangements in an image.
   b. I am a tool used to rub out portions of an image.
   c. I am a tool used to soften the whole or part of an image.
   d. I am the layer that you select to work with.
   e. I am the process of reducing the file size by merging all visible layers into the background.

2. Give three facts about the following: (3 x 2 = 6)
   a. Filters
   b. Eraser Tool

3. Search for any four words related to Photoshop tools in the grid below: (4)

    G  S  M  U  D  G  E  T  I
    B  D  L  A  Y  H  E  M  B
    D  E  A  Y  O  U  T  O  U
    O  V  S  T  A  G  E  U  R
    D  E  V  D  A  T  A  E  N
    G  L  S  O  U  N  D  T  T
    E  A  T  T  Y  P  E  L  M
    A  N  I  M  A  T  I  O  N
Chapter 9  Introduction to Dreamweaver CS3

1.  Who am I?  
   a.  I am a popular software for creating websites. 
   b.  I show the various properties of the selected Dreamweaver element(s).  
   c.  I am the folder on the computer where the web server software is running. 
   d.  I am the attribute which refers to the hyperlink of an image in a web page. 
   e.  I am a set of linked web pages, related to a particular topic. 

2.  Give three facts about the following:  
   a.  Dreamweaver 
   b.  Hyperlink 

3.  Search for any four words related to Dreamweaver in the grid below:
Chapter 10 Images and Framesets in Dreamweaver CS3

1. Who am I? (5)
   a. I am usually displayed on top of websites.
   b. I provide the table with a title which is displayed outside the table.
   c. I provide the table description.
   d. I am a clickable region which an image map is divided into.
   e. I am the property who specifies if a scrollbar appears in a frame.

2. Give three facts about the following: (3 x 2 = 6)
   a. Rollover Image
   b. Tables in Dreamweaver

3. Search for any four words related to Dreamweaver in the grid below: (4)

   | FRAMESET | B PROPERTY |
   | FRAMESET | B PROPERTY |
   | ELSBORDER | COMMENTOR |
   | IMAGESET | B |
   | HORIZONTA | ROLLERD |
   | POWDERY | ROY |
Worksheet Answers

Chapter 1  Introduction to Access 2013

1. a. DBMS            b. Database        c. Module
   d. Ribbon          e. Datasheet

2. a. Report         b. Macro          c. Relational
   d. Fields         e. Currency

3.

<table>
<thead>
<tr>
<th>W</th>
<th>F</th>
<th>I</th>
<th>L</th>
<th>T</th>
<th>E</th>
<th>R</th>
<th>K</th>
<th>V</th>
</tr>
</thead>
<tbody>
<tr>
<td>K</td>
<td>E</td>
<td>T</td>
<td>L</td>
<td>O</td>
<td>S</td>
<td>S</td>
<td>X</td>
<td>A</td>
</tr>
<tr>
<td>T</td>
<td>A</td>
<td>L</td>
<td>U</td>
<td>E</td>
<td>S</td>
<td>R</td>
<td>S</td>
<td>L</td>
</tr>
<tr>
<td>A</td>
<td>P</td>
<td>Q</td>
<td>U</td>
<td>E</td>
<td>R</td>
<td>Y</td>
<td>O</td>
<td>U</td>
</tr>
<tr>
<td>B</td>
<td>M</td>
<td>I</td>
<td>X</td>
<td>E</td>
<td>D</td>
<td>S</td>
<td>E</td>
<td>E</td>
</tr>
<tr>
<td>L</td>
<td>O</td>
<td>T</td>
<td>E</td>
<td>M</td>
<td>M</td>
<td>A</td>
<td>R</td>
<td>U</td>
</tr>
<tr>
<td>E</td>
<td>T</td>
<td>K</td>
<td>P</td>
<td>E</td>
<td>C</td>
<td>T</td>
<td>E</td>
<td>T</td>
</tr>
<tr>
<td>T</td>
<td>O</td>
<td>F</td>
<td>O</td>
<td>R</td>
<td>M</td>
<td>Y</td>
<td>R</td>
<td>E</td>
</tr>
</tbody>
</table>

Chapter 2  Access 2013: Design View, Queries, Forms and Reports

1. a. Query            b. Primary        c. Form
   d. Design          e. Report

2. a. • An Access Query is a method of getting answers to questions about data
      • The query can involve a single table or multiple tables
      • Access saves each query as a new query in the database

   b. • Forms provide an easy way to enter, edit, delete, and view data in a table
      • There are three ways to create a form in Access
      • The Forms group in the Create tab has Forms wizard which can be used to create forms

3.

<table>
<thead>
<tr>
<th>W</th>
<th>I</th>
<th>N</th>
<th>H</th>
<th>O</th>
<th>M</th>
<th>E</th>
<th>K</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>E</td>
<td>T</td>
<td>L</td>
<td>O</td>
<td>S</td>
<td>S</td>
<td>X</td>
<td>O</td>
</tr>
<tr>
<td>R</td>
<td>E</td>
<td>R</td>
<td>T</td>
<td>A</td>
<td>P</td>
<td>G</td>
<td>E</td>
<td>R</td>
</tr>
<tr>
<td>E</td>
<td>P</td>
<td>B</td>
<td>C</td>
<td>R</td>
<td>M</td>
<td>I</td>
<td>O</td>
<td>M</td>
</tr>
<tr>
<td>A</td>
<td>R</td>
<td>R</td>
<td>M</td>
<td>O</td>
<td>U</td>
<td>S</td>
<td>E</td>
<td>A</td>
</tr>
<tr>
<td>T</td>
<td>O</td>
<td>T</td>
<td>E</td>
<td>M</td>
<td>M</td>
<td>A</td>
<td>R</td>
<td>T</td>
</tr>
<tr>
<td>E</td>
<td>M</td>
<td>O</td>
<td>J</td>
<td>E</td>
<td>C</td>
<td>T</td>
<td>E</td>
<td>N</td>
</tr>
<tr>
<td>M</td>
<td>A</td>
<td>D</td>
<td>E</td>
<td>S</td>
<td>I</td>
<td>G</td>
<td>N</td>
<td>E</td>
</tr>
</tbody>
</table>
Chapter 3  Lists and Images in HTML 5

1. a. `<img>`  
   b. unordered  
   c. description  
   d. `.html`  
   e. `<ol>`  

2. a. • An unordered list is used for items where order is not important  
    • An unordered list is also called a bulleted list  
    • The start/end tags of an unordered list are `<ol>` and `</ol>`  
   b. • `<img>` tag specifies the image to be displayed in an HTML document  
    • GIF, PNG, and JPEG are widely used image formats supported in HTML  
    • Src attribute of the `<img>` tag specifies the URL of an image  

3. 

```
S Q P X O W N K S
P E T L O S S X T
Y F O N T Q R S Y
W P B O O T I O L
A L I G N U S E E
R O T N O R T O N
B O R D E R T E S
M A L W A R E R E
```

Chapter 4  Tables, Links and Frames in HTML 5

1. a. padding  
   b. table  
   c. src  
   d. `<iframe>`  
   e. `<frame>`  

2. a. Internal  
   b. Embed  
   c. Hover  
   d. Anchor  
   e. Global  

3. 

```
C O N T R O L S S U
X R T I T L O X T V
I E A U D I O S I I
N I D T H E P N K D
E H D E S I G N E E
W O H E I G H T W O
T M N I T O R E O C
A U T O P L A Y P R
```
Chapter 5  Audacity

1. a. Transport  b. Mixer  c. Envelop  d. Transcription  e. Chipping

2. a. • In a Stereo file there are two mics
   • In a Stereo file there are two channels, namely the left and right
   • In a Stereo file the sound seems to come from multiple directions, thus giving a richer feel to the sound or music.

   b. • Audacity is a popular and free software used for editing and recording sound
   • This software can be used for recording or playing back music or sounds, and removing or adding tracks.
   • Audacity supports the recording of both stereo and mono files.

3.

<table>
<thead>
<tr>
<th>S</th>
<th>P</th>
<th>Q</th>
<th>A</th>
<th>N</th>
<th>I</th>
<th>T</th>
<th>Z</th>
<th>T</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>R</td>
<td>E</td>
<td>P</td>
<td>E</td>
<td>A</td>
<td>T</td>
<td>X</td>
<td>O</td>
</tr>
<tr>
<td>M</td>
<td>E</td>
<td>A</td>
<td>L</td>
<td>P</td>
<td>M</td>
<td>R</td>
<td>S</td>
<td>O</td>
</tr>
<tr>
<td>P</td>
<td>A</td>
<td>R</td>
<td>A</td>
<td>N</td>
<td>G</td>
<td>E</td>
<td>E</td>
<td>L</td>
</tr>
<tr>
<td>L</td>
<td>H</td>
<td>D</td>
<td>O</td>
<td>S</td>
<td>I</td>
<td>G</td>
<td>N</td>
<td>B</td>
</tr>
<tr>
<td>E</td>
<td>L</td>
<td>F</td>
<td>A</td>
<td>R</td>
<td>N</td>
<td>E</td>
<td>R</td>
<td>A</td>
</tr>
<tr>
<td>E</td>
<td>M</td>
<td>B</td>
<td>R</td>
<td>E</td>
<td>A</td>
<td>K</td>
<td>E</td>
<td>R</td>
</tr>
<tr>
<td>E</td>
<td>F</td>
<td>F</td>
<td>E</td>
<td>C</td>
<td>T</td>
<td>S</td>
<td>S</td>
<td>L</td>
</tr>
</tbody>
</table>

Chapter 6  Lightworks

1. a. Lightworks  b. Image  c. Room  d. Window  e. Bin

2. a. • While working with audio, you can display the audio waveforms
   • You can also manually boost or lower sound levels
   • You can also add soundtracks at specific positions

   b. • Lightworks is a very popular, free video editing tool.
   • Many Hollywood movies have been edited using Lightworks.
   • Lightworks has many tools which students can use in order to focus on learning the art of editing videos.

3.

<table>
<thead>
<tr>
<th>W</th>
<th>A</th>
<th>V</th>
<th>E</th>
<th>F</th>
<th>O</th>
<th>R</th>
<th>M</th>
<th>M</th>
</tr>
</thead>
<tbody>
<tr>
<td>R</td>
<td>I</td>
<td>O</td>
<td>L</td>
<td>A</td>
<td>M</td>
<td>A</td>
<td>W</td>
<td>Y</td>
</tr>
<tr>
<td>O</td>
<td>K</td>
<td>O</td>
<td>O</td>
<td>E</td>
<td>S</td>
<td>C</td>
<td>I</td>
<td>S</td>
</tr>
<tr>
<td>C</td>
<td>A</td>
<td>S</td>
<td>U</td>
<td>H</td>
<td>I</td>
<td>K</td>
<td>T</td>
<td>P</td>
</tr>
<tr>
<td>K</td>
<td>C</td>
<td>L</td>
<td>T</td>
<td>S</td>
<td>T</td>
<td>G</td>
<td>T</td>
<td>A</td>
</tr>
<tr>
<td>T</td>
<td>I</td>
<td>M</td>
<td>E</td>
<td>L</td>
<td>I</td>
<td>N</td>
<td>E</td>
<td>C</td>
</tr>
<tr>
<td>G</td>
<td>M</td>
<td>B</td>
<td>B</td>
<td>E</td>
<td>A</td>
<td>K</td>
<td>R</td>
<td>E</td>
</tr>
<tr>
<td>P</td>
<td>L</td>
<td>A</td>
<td>Y</td>
<td>B</td>
<td>A</td>
<td>C</td>
<td>K</td>
<td>W</td>
</tr>
</tbody>
</table>
Chapter 7  Introduction to Photoshop CS3

1. a. Photoshop   b. Title   c. Lasso   d. Brush   e. Dodge
2. a. Eraser   b. Retouching   c. Eyedropper   d. Resolution   e. Marquee
3.

```
G R A D I E N T I
X L A Y C U B S Z
R E C T A N G L E
L N S P O C X O T
W B V D C T U E O
C L N T R C A R G
Q U R Z O O M L M
T R A N P F O R M
```

Chapter 8  Tools used in Photoshop CS3

1. a. Retouching   b. Eraser   c. Blur   d. active   e. Flattening
2. a. Filters are used to change the appearance of an image, selection, or layer
   • Filters can be applied more than once and also incrementally
   • You can view thumbnail pictures of what each filter does
b. The Eraser tool can erase parts of an image
   • Eraser tool has three options
   • The shape of eraser tool changes according to the selection of the eraser mode in the options bar
3.

```
G S M U D G E T I
B D L A Y H E M B
D E A Y O U T O U
O V S T A G E U R
D E V D A T A E N
G L S O U N D T T
E A T T Y P E L M
A N I M A T I O N
```
Chapter 9  Introduction to Dreamweaver CS3


2. a. • Dreamweaver is used to create individual web pages and complete websites
   • Dreamweaver supports a WYSIWYG editor
   • Dreamweaver is software created by Adobe

b. • A hyperlink is a word, phrase, or image that you can click on to move to a new document or a new section within the current document.
   • Nearly all web pages have hyperlinks allowing user to move from one web page to another
   • Hyperlinks can also point to locations in the same web page.

3. 

<table>
<thead>
<tr>
<th>H</th>
<th>Y</th>
<th>P</th>
<th>E</th>
<th>R</th>
<th>L</th>
<th>I</th>
<th>N</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>Q</td>
<td>Y</td>
<td>S</td>
<td>T</td>
<td>W</td>
<td>N</td>
<td>G</td>
<td>D</td>
</tr>
<tr>
<td>T</td>
<td>L</td>
<td>A</td>
<td>W</td>
<td>O</td>
<td>U</td>
<td>T</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>S</td>
<td>N</td>
<td>S</td>
<td>Y</td>
<td>T</td>
<td>E</td>
<td>E</td>
<td>O</td>
<td>N</td>
</tr>
<tr>
<td>P</td>
<td>L</td>
<td>E</td>
<td>S</td>
<td>E</td>
<td>N</td>
<td>T</td>
<td>E</td>
<td>C</td>
</tr>
<tr>
<td>O</td>
<td>I</td>
<td>S</td>
<td>I</td>
<td>U</td>
<td>N</td>
<td>D</td>
<td>R</td>
<td>H</td>
</tr>
<tr>
<td>T</td>
<td>E</td>
<td>R</td>
<td>W</td>
<td>I</td>
<td>T</td>
<td>L</td>
<td>E</td>
<td>O</td>
</tr>
<tr>
<td>A</td>
<td>N</td>
<td>I</td>
<td>Y</td>
<td>A</td>
<td>T</td>
<td>I</td>
<td>O</td>
<td>R</td>
</tr>
<tr>
<td>K</td>
<td>U</td>
<td>P</td>
<td>G</td>
<td>Q</td>
<td>A</td>
<td>V</td>
<td>L</td>
<td>G</td>
</tr>
</tbody>
</table>
Chapter 10  Images and Framesets in Dreamweaver CS3

1. a. Banner  
   b. Caption  
   c. Summary  
   d. Hotspot  
   e. Scroll

2. a. • Rollover image changes in a browser when the cursor moves over it  
    • We have two images for a rollover image  
    • The primary image is one that is displayed when web page is loaded, secondary image is displayed when pointer moves over primary image  
   b. • A table in Dreamweaver consists of rows and columns  
    • The heading of the table is provided by the caption property  
    • The Insert bar or the Insert menu is used to create a table

3. 

<table>
<thead>
<tr>
<th>F</th>
<th>R</th>
<th>A</th>
<th>M</th>
<th>E</th>
<th>S</th>
<th>E</th>
<th>T</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>P</td>
<td>R</td>
<td>O</td>
<td>P</td>
<td>E</td>
<td>R</td>
<td>T</td>
<td>Y</td>
</tr>
<tr>
<td>E</td>
<td>L</td>
<td>S</td>
<td>B</td>
<td>O</td>
<td>R</td>
<td>D</td>
<td>E</td>
<td>R</td>
</tr>
<tr>
<td>C</td>
<td>O</td>
<td>M</td>
<td>M</td>
<td>E</td>
<td>N</td>
<td>T</td>
<td>O</td>
<td>R</td>
</tr>
<tr>
<td>I</td>
<td>M</td>
<td>A</td>
<td>G</td>
<td>E</td>
<td>S</td>
<td>E</td>
<td>T</td>
<td>B</td>
</tr>
<tr>
<td>H</td>
<td>O</td>
<td>R</td>
<td>I</td>
<td>Z</td>
<td>O</td>
<td>N</td>
<td>T</td>
<td>A</td>
</tr>
<tr>
<td>R</td>
<td>O</td>
<td>L</td>
<td>L</td>
<td>O</td>
<td>V</td>
<td>E</td>
<td>R</td>
<td>D</td>
</tr>
<tr>
<td>R</td>
<td>P</td>
<td>O</td>
<td>W</td>
<td>D</td>
<td>Y</td>
<td>R</td>
<td>O</td>
<td>Y</td>
</tr>
</tbody>
</table>
TEST PAPERS

- Test papers have been provided for all the chapters of the course book.
- Each test paper is of **25 marks** and has both theory (20) and practical (5) components.
- The test papers may be used for pen and paper assessment or the questions in them could be used to create your own assessment papers.
- They are also available as printable documents in digital resources.
Chapter 1  Introduction to Access 2013

1. Fill in the blanks  
   a. ...................................... is a popular database management application.  
   b. A ...................................... is an organised collection of data.  
   c. A specific piece of information in a table is called a ......................................  
   d. The ...................................... key uniquely identifies every row in a table.  
   e. The ...................................... view is used to enter data into a table.

2. Write T for the true statement and F for the false one.  
   a. A table organises data into rows and columns.  
   b. The primary key of a table can consist of only one column.  
   c. In Access 2013, the title bar appears at the top of the window.  
   d. The Short Text data type can store text up to 65,535 characters long.  
   e. The database object Report lets you enter and display data in a customised format.

3. Very Short Answer Questions  
   a. In which form does a relational database store data?  
   b. Which tab in Access 2013 has commands to help manage Access and Access databases?  
   c. Which feature in Access 2013 helps to find out the sum, count, average etc. on the data?  
   d. By default, which is the first field created in a new table in Access 2013?

4. Short Answer Questions  
   a. What are the elements of a relational database?  
   b. What is the meaning of data redundancy?  
   c. For which purpose is the database object Query used?

5. Lab Exercise  
   Sahil has been given a task by his teacher to create a table named STUDENTS, using the data given below and perform the tasks given below, on the data. Can you help him in this task?

<table>
<thead>
<tr>
<th>RollNo</th>
<th>Name</th>
<th>Gender</th>
<th>Marks</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>Faraz Khan</td>
<td>F</td>
<td>277</td>
</tr>
<tr>
<td>1</td>
<td>Sarah Shafeeq</td>
<td>F</td>
<td>229</td>
</tr>
<tr>
<td>2</td>
<td>Amani Afridi</td>
<td>M</td>
<td>248</td>
</tr>
<tr>
<td>9</td>
<td>Natasha Abbas</td>
<td>M</td>
<td>290</td>
</tr>
<tr>
<td>10</td>
<td>Tariq Nabeel</td>
<td>M</td>
<td>290</td>
</tr>
<tr>
<td>4</td>
<td>Nabeela Mohsin</td>
<td>F</td>
<td>267</td>
</tr>
</tbody>
</table>
a. Rename the field “Name” to “StName”.
b. Sort the table in the ascending order of RollNo.
c. Filter all the records where marks are greater than 250.
Chapter 2  Access 2013: Design View, Queries, Forms and Reports

1. Fill in the blanks  
   a. ..................................... give us data in a printer friendly format. 
   b. The ..................................... group of the CREATE tab has the option to create a table in the Design view. 
   c. ..................................... provide an easy-to-use method for entering and editing data in a database. 
   d. A ..................................... is a field with a list of values from which a user can choose the desired value. 
   e. The ................................. property is used to control what the user enters in a table field. 

2. Write T for the true statement and F for the false one.  
   a. Data can be added in a table in the Design view as well as the Datasheet view. 
   b. The Field Properties Pane of the Table Design screen allows us to specify field names and data types for the table. 
   c. If we save a table without creating a primary key, Access automatically creates a primary key field. 
   d. We can query for data from multiple tables at the same time. 
   e. The default value of the Required property of a field is No. 

3. Very Short Answer Questions  
   a. Name the field property that is used to limit the value that a field will accept. 
   b. Which tab in Access 2013 has commands for creating queries? 
   c. Which view in Access 2013 lets you modify the structure of a table? 
   d. At which place in the Field Definition Grid is the Primary Key icon displayed? 

4. Short Answer Questions  
   a. Which are the three ways to create a form in Access? 
   b. What does the Format property of a field do? 
   c. If the validation rule for a field is >20, what does it mean? 

5. Lab Exercise  
   Ushna has been given a task by her teacher to create a table named PRODUCTS, with the fields as given below. She also has to create a query to display the product name and price in ascending order. Can you help her do the task? 

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Data type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProdId</td>
<td>Short Text</td>
<td>Product ID as primary key</td>
</tr>
<tr>
<td>ProdName</td>
<td>Short Text</td>
<td>Name of the product</td>
</tr>
<tr>
<td>ProdPrice</td>
<td>Number</td>
<td>Price of the product</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Required — Yes</td>
</tr>
</tbody>
</table>
Chapter 3  Lists and Images in HTML 5

1. Fill in the blanks  
   a. The <li> tag is a .................................. item tag.  
   b. An ........................................ list is also called a numbered list.  
   c. An ........................................ list is specified using the <ul> tag.  
   d. The list-style-image property is used to specify the ......................... of the image which is to be used as the list-item marker.  
   e. The ........................................ attribute of the <img> tag specifies an alternate text for an image.  

2. Write T for the true statement and F for the false one.  
   a. An unordered list is used for items in which the ordering of items is not important.  
   b. An ordered list uses bullets as the list item marker.  
   c. In HTML, a list can be nested inside any other list.  
   d. The tag <dt> is used to give the definition list description.  
   e. The full form of GIF is Graphics Interchange Feature.  

3. Very Short Answer Questions  
   a. Which property can be used to set all list properties in one declaration?  
   b. What is the default bullet style used as a list–item marker in an unordered list?  
   c. Name the tag that is used to build a list of definitions.  
   d. Which attribute of the image tag specifies the URL of an image?  

4. Short Answer Questions  
   a. Name the three list types that can be created in an HTML document.  
   b. What are the different values that the list-style-type property of an ordered list can have?  
   c. Why is the <img> element called an empty element?  

5. Lab Exercise  
   Salma has been given a task by her teacher to create a web page giving a list of five important social networking sites. Can you help her write the HTML code for creating this web page?
Chapter 4  Tables, Links and Frames in HTML 5

1. Fill in the blanks
   a. The web pages of a website are linked to each other using ....................................
   b. The .................................. property specifies the space between the border and content in a table.
   c. An ................................. link provides a link to a point on the current web page.
   d. The HTML tag which is used to create a link is the ............................... tag.
   e. The ............................... option specifies the colour of the hyperlink when the mouse pointer is over it.

2. Write T for the true statement and F for the false one.  (5)
   a. <th> is the table tag used to define a table in HTML.
   b. The text-align property is used to set the horizontal alignment of text in a table.
   c. An image cannot be inserted in a table cell.
   d. Video cannot be inserted in a web page.
   e. The <iframe> tag is used to display a web page within a web page.

3. Very Short Answer Questions  (4)
   a. Which tag is used to define a horizontal row of cells?
   b. Which table property specifies the placement of a table caption?
   c. Which attribute of the anchor tag specifies the destination page?
   d. Name the attribute of the audio tag that is used for replaying the audio file once it has finished.

4. Short Answer Questions  (6)
   a. What is the difference between a local and a global hyperlink?
   b. What are frames used for?
   c. What is the use of the table property **empty-cells**?

5. Lab Exercise  (5)
   Nabeela has been given a task to create an HTML document to show a table giving the names of countries and their capitals. Can you help her do the task?
Chapter 5 Audacity

1. Fill in the blanks with the correct words (5)
   a. ............................................ is a software meant for editing and recording sound.
   b. The ........................................ toolbar of the Audacity window has various tools for selection, volume adjustment etc.
   c. The ........................................ toolbar gives you quick access to functions for editing the audio tracks like cut, copy, paste etc.
   d. A unit of the audio data is called .....................................
   e. The noise removal option is available in the ........................................... menu of the Audacity window.

2. Write T for the true statement and F for the false one. (5)
   a. The higher the value of the Default Sample Rate, the larger is the size of the audio file.
   b. The playback and record meters on the Meter toolbar display the length of an audio track.
   c. The loudness of the audio is directly proportional to the waveform size.
   d. A stereo file has only one channel.
   e. You cannot record multiple tracks in a single project in Audacity.

3. Very Short Answer Questions (4)
   a. Name two audio file formats that can be opened in Audacity.
   b. Which toolbar in the Audacity window is used to change the speed of the playback?
   c. What is the keyboard shortcut used to create a copy of the selected audio on a new track?
   d. Which key can be used to listen to the selected audio?

4. Short Answer Questions (6)
   a. What is the use of the Mixer toolbar?
   b. What does clipping of a waveform result in?
   c. What is the use of the ruler above the audio waveform?

5. Lab Exercise (5)
   Rashid has been given a task by his teacher to record a song in his own voice in Audacity. Can you help him complete the task?
Chapter 6  Lightworks

1. Fill in the blanks  
   a. The number of images that are run per second is known as the .............................. rate.  
   b. The options required for editing or making a video are present in the .......................... view.  
   c. A ................................ consists of many related bins.  
   d. To lock the viewer on the screen, click the ............................... button.  
   e. The ............................... command helps to add a new clip between two clips.

2. Write T for the true statement and F for the false one.  
   a. The menu bar is present on the top right corner of the Project view.  
   b. A bin in a rack can have files of different types.  
   c. In Lightworks, you can export the files that have been edited, to the desired location.  
   d. You can resize a viewer window even after it has been pinned.  
   e. The edit viewer has a white border.

3. Very Short Answer Questions  
   a. In Lightworks, what is the process of marking the In point and Out point on a clip called?  
   b. What is a simple view of a clip or edit called?  
   c. Which editing functions are used to include pictures and sound into the file being edited?  
   d. Name the button that is used to close a bin.

4. Short Answer Questions  
   a. What do you mean by bins?  
   b. What is the difference between the Delete and Remove options?  
   c. What is the meaning of Slip a Shot?

5. Lab Exercise  
   Sabeen wants to join some video clips taken during her holidays, using Lightworks. Can you help her with the task?
Chapter 7 Introduction to Photoshop CS3

1. Fill in the blanks (5)
   a. The ................................ bar is the topmost bar of the Photoshop window.
   b. The ................................ tool is used to draw freehand.
   c. The ................................ tool is used to select adjacent areas of the same colour in an image.
   d. The ................................ bar displays information about the image opened in Photoshop.
   e. ................................... is the number of pixels per inch that make up an image.

2. Write T for the true statement and F for the false one. (5)
   a. The Dodge tool is used to lighten pixels in an image.
   b. The status bar is located at the top of every document window.
   c. An image with low resolution is sharper than an image with high resolution.
   d. The default foreground colour is black.
   e. The single row marquee tool is used to select a single column of one pixel width.

3. Very Short Answer Questions (4)
   a. Name the tool that is used to make a free hand selection in an image.
   b. What is the default unit of the width and height of an image?
   c. What is the default extension of a Photoshop file?
   d. Which tool is used for moving an image, or part of an image, from one location to another?

4. Short Answer Questions (6)
   a. What are Marquee tools used for?
   b. While creating a new file, what does the option Color Mode specify?
   c. What is the use of the Crop tool?

5. Lab Exercise (5)
   Laiba has been asked by her teacher to create a picture showing nature, in Photoshop. Can you help her with this task?
Chapter 8 Tools used in Photoshop CS3

1. Fill in the blanks (5)
   a. The ......................... tools help to change or edit the pixel arrangements in an image.
   b. ......................... are transparent sheets stacked one on top of the other.
   c. The ......................... tool is used to remove blemishes, scars, spots, and other imperfections in a photograph.
   d. ......................... refers to distorting text into a variety of shapes.
   e. The ......................... tool softens an image or part of an image.

2. Write T for the true statement and F for the false one. (5)
   a. The Burn tool is used to lighten the pixels in an image.
   b. The contents of the Background layer cannot be moved.
   c. To apply filter to a layer, that layer need not be an active layer.
   d. A new layer is always added below the selected layer.
   e. The Magic Eraser Tool erases pixels from similarly-coloured areas.

3. Very Short Answer Questions (4)
   a. Name the tool that is used to clone or duplicate the selected areas of an image.
   b. How many layers does a new Photoshop image have?
   c. Which tool helps in erasing parts of an image?
   d. Which feature of Photoshop is used to add special effects to an image?

4. Short Answer Questions (6)
   a. What is the use of the Smudge tool?
   b. What is Type Layer?
   c. What is the use of flattening the layers?

5. Lab Exercise (5)
   Taimoor wants to create a collage of pictures taken of his friends while they were on a holiday. Can you help him accomplish the task?
Chapter 9  Introduction to Dreamweaver CS3

1. Fill in the blanks (5)
   a. The ................................ folder is a folder on the computer where the web server software is running.
   b. A ................................ is a local or remote storage location for documents that belong to a website.
   c. A ................................ is a word, phrase, or image that you can click on to move to a new document or a new section within the current document.
   d. The button to create hyperlink is present on the COMMON tab of the .............................. bar.
   e. The .............................. bar displays the page title with the file path and filename.

2. Write T for the true statement and F for the false one. (5)
   a. You cannot change the location of the Property Inspector panel.
   b. The status bar is at the bottom of the document window.
   c. The _parent target option loads the linked file in a new unnamed browser window.
   d. The Files panel lets you manage files and folders both on the local machine and on the remote server.
   e. In order to resize an image, you have to drag the corner handles of the image.

3. Very Short Answer Questions (4)
   a. Give the full form of WYSIWYG.
   b. Which view displays the HTML code for the web page?
   c. What is the name given to images that can be hyperlinked?
   d. Which button of the Document window toolbar needs to be clicked in order to make the changes in Code view appear in the Design view?

4. Short Answer Questions (6)
   a. What are the two ways to create a new website in Dreamweaver?
   b. What is the function of a Named Anchor?
   c. What does the Crop property of an image do?

5. Lab Exercise (5)
   Naushad has been given a task to create a web page on “Elements of Nature” having some text and an image. Can you help him create the web page?
Chapter 10 Images and Framesets in Dreamweaver CS3

1. Fill in the blanks (5)
   a. The ................................ bar has the option to insert a table in the web page.
   b. An image ................................ is a graphic you use until the final image to be added to a web page is decided.
   c. Each ................................ displays an HTML document independently.
   d. The ................................ property of frameset specifies if borders will be visible.
   e. An image map is an image divided into clickable regions called ............................... .

2. Write T for the true statement and F for the false one. (5)
   a. In a rollover image, the primary and secondary image should be of the same size.
   b. A Word or Excel document cannot be linked to a web page.
   c. When a frame is selected in the Document window, its borders are outlined with a dotted line.
   d. A frame name is not case sensitive.
   e. The No Resize option of the frame property prevents visitors from dragging the frame borders to resize the frame.

3. Very Short Answer Questions (4)
   a. Which object in Dreamweaver helps to insert the current date?
   b. What is the HTML file called that defines the layout and properties of a set of frames?
   c. In a rollover image, which image is displayed when the web page is first loaded?
   d. Which properties of an image placeholder are required properties?

4. Short Answer Questions (6)
   a. What is a rollover image?
   b. Name the three graphic file formats supported by most browsers.
   c. Which three shapes are used to define a hotspot?

5. Lab Exercise (5)
   Javeria has been asked by her teacher to create a web page showing an image of the solar system. The image acts as a hotspot. When the user clicks on the image, a web page with information about the solar system should appear. Can you help her with the task?
Test Paper Answers

Chapter 1  Introduction to Access 2013

1.  a. Access 2013  b. Database  c. Value  d. Primary  e. Datasheet
2.  a. T  b. F  c. T  d. F  e. F
3.  a. A relational database stores data in the form of tables.
   b. The FILE tab in Access 2013 has commands to help manage Access and Access databases.
   c. The Totals feature in Access 2013 helps to find out the sum, count, average etc. on the data.
   d. The first field created by default in a new table in Access 2013 is the ID field.
4.  a. The elements of a relational database are tables, fields, and records.
   b. Data redundancy means duplication of data.
   c. The database object Query is used to retrieve data from one or more tables.
5.  Open a blank database and create the table with the contents as given above.
   a. To rename the field Name:
      i. Double-click the Field header and type in the new name — StName.
   b. To sort the table in the ascending order of RollNo:
      i. Click the arrow to the right of the RollNo column header.
      ii. Click Sort A to Z in the drop-down menu to sort the data in ascending order.
   c. To filter all the records where marks are greater than 250:
      i. Click the arrow to the right of the Marks column header, click Number Filters, and click Greater Than in the submenu.
      ii. The Custom Filter dialog box appears. Type 250 and click OK.

Chapter 2  Access 2013: Design View, Queries, Forms and Reports

1.  a. Reports  b. Tables  c. Forms  d. Lookup field  e. Input mask
2.  a. F  b. F  c. T  d. T  e. T
3.  a. The Validation rule property is used to limit the value that the field will accept.
   b. The CREATE tab in Access 2013 has commands for creating queries.
   c. In Design view we can modify the structure of a table.
   d. The Primary Key icon is displayed in the Field Selector box.
4.  a. The three ways to create a form in Access are:
    i. Using the Form command
    ii. Using Split Form
    iii. Using the Form Wizard
   b. The Format property of a field specifies how data will be displayed.
   c. If the validation rule for a field is >20, it means that the field can only contain values greater than 20.
5.  a. Create a new database. The new database will open with one table, Table1, in Datasheet View. Now click the View drop-down menu arrow and select Design View.
b. Access will prompt you to save the table. Enter the Table Name as Products and click OK.
c. This will open the table in Design View. Type in the field names, select the required data types and enter the descriptions. Select the ProdId field and click the Primary Key button in the Tools group on the DESIGN tab, to make it the primary key field.
d. Click the drop-down menu arrow of the View button in the Views group on the DESIGN tab, and switch back to the Datasheet View.
e. Enter some records. Use the TAB key to move from one column to the next.
f. To create the query:
   i. Click Query Design in the Queries group on the CREATE tab.
   ii. The Show Table dialog box appears. Select the Products table. Click on Add and then click on Close.
   iii. Drag the ProdName and ProdPrice fields from the table to the Query Design Grid.
   iv. Select the Ascending option in the Sort menu of the ProdPrice field.
   v. Click Run in the Results group on the DESIGN tab to run the query.
   vi. Save the query.

Chapter 3 Lists and Images in HTML 5

1. a. List  b. Ordered  c. Unordered  d. Address  e. Alt
2. a. T  b. F  c. T  d. F  e. F
3. a. The property list-style is used to set all list properties in one declaration.
   b. The default bullet style used as a list-item marker in an unordered list is a disc.
   c. The description list tag is used to build a list of definitions.
   d. The image attribute src specifies the URL of an image.
4. a. The three types of lists that can be created in an HTML document are:
   i. Unordered lists
   ii. Ordered lists
   iii. Description lists
   b. The different values that the list-style-type property of an ordered list can have are: decimal, lower-roman, upper-roman, lower-alpha, or upper-alpha.
   c. The <img> element is called an empty element because it does not have a closing tag.
5. a. Start notepad.
   b. Type the following HTML code:

```html
<!DOCTYPE html>
<html>
<head>
<style type="text/css">
ol {list-style-type: upper-alpha}
</style>
</head>
<body>
<title>Social Networking Sites</title>
</body>
</html>
```
<h2>List of Social Networking Sites</h2>

- Facebook
- Twitter
- LinkedIn
- Ibibo
- Flickr

---

c. Select File ▶ Save and save the file as List.html.
d. To view the document, open a web browser, say, Internet Explorer.
e. Open the file List.html in the web browser.

---

Chapter 4 Tables, Links and Frames in HTML 5

1. a. Hyperlinks  
   b. Padding  
   c. Internal  
   d. Anchor  
   e. Hover  

2. a. F  
   b. T  
   c. F  
   d. F  
   e. T  

3. a. The <tr> tag is used to define a horizontal row of cells.
   b. The property <caption-side> is used to specify the placement of a table caption.
   c. The HREF (Hypertext Reference) attribute of the anchor tag specifies the destination page.
   d. The attribute <loop> is used for replaying the audio file once it has finished.

4. a. A local link provides a link to another page on the same website whereas a global link provides a link to a page on a different website.
   b. Frames are used to open more than one web page simultaneously in a browser window.
   c. The table property <empty-cells> specifies whether or not to display borders and background for empty cells in a table.

5. a. Start Notepad.
   b. Type the following HTML code:

```html
<!DOCTYPE html>
<html>
<head>
<title>Capitals</title>
<style type="text/css">
  table {border: 2px solid blue; empty-cells:hide; border-spacing: 2px 5px; caption-side: bottom}
  th, td, tr {border: 2px solid red}
  td {padding: 8px}
</style>
</head>
<body>
<table>
  <caption><h2>Countries and Capitals</h2></caption>
  <tr><th>Countries</th><th>Capitals</th></tr>
  <tr><td>Pakistan</td><td>Islamabad</td></tr>
</table>
</body>
</html>
```
c. Select File ► Save and save the file as Capitals.html.

d. To view the document, open a web browser, say, Internet Explorer.

e. Open the file Capitals.html in the web browser.

Chapter 5 Audacity

2. a. T  b. F  c. T  d. F  e. F
3. a. Two audio file formats that can be opened in Audacity are: WAV, MP3 etc.
   b. The Transcription toolbar in the Audacity window is used to change the speed of the playback.
   c. The keyboard shortcut Ctrl + D is used to create a copy of the selected audio on a new track.
   d. The spacebar key can be used to listen to the selected audio.
4. a. The mixer toolbar helps to control the volume levels for playback and record for the audio devices selected
    in the Devices toolbar.
   b. Clipping of a waveform results in sudden harshness during playback at the points where clipping has
      occurred.
   c. The ruler above the waveform is used to measure the duration of the audio in minutes and seconds.
5. To record a song in Audacity, follow the steps given below:
   a. Start Audacity.
   b. Select Speakers as the output device and Microphone as the input device in the Device toolbar.
   c. Select the Input Channel as Mono.
   d. Click on the downward arrow next to the microphone symbol in the Meter Toolbar.
   e. Click on Start Monitoring so that you can hear your recording.
   f. Adjust the recording volume using the Input Volume slider in the Mixer Toolbar.
   g. Click the Record button in the Transport Toolbar and start recording the song.
   h. After recording, click the Stop button.

Chapter 6 Lightworks

2. a. F  b. F  c. T  d. T  e. F
3. a. In Lightworks, the process of marking the In point and Out point on a clip is called mark and park.
   b. A simple view of a clip or edit is called the Timeline.
c. The editing functions Replace and Insert are used to include pictures and sound into the file being edited.

d. The Shrink button is used to close a bin.

4. a. Bins are the containers in which we organise and work with our material in Lightworks.
   b. The Delete option takes out both the audio and video portions of the clip, while Remove takes out either the audio or the video portions depending on the selection.
   c. Slip a Shot refers to increasing or decreasing the duration of the first clip, without changing the duration of the middle clip.

5. a. Start Lightworks.
   b. In the Projects Browser window, type the name of the project. Select the Frame rate as Auto and click Create. This opens the Project View window with Select Files to Import dialog box.
   c. Click on Places in the Select Files to Import dialog box. From the menu that opens, navigate to the directory containing the files you wish to import. Select the files and click Import.
   d. To store the clips in a bin, click the Bin icon. Drag the files in the Imports dialog box to the bin. To make it permanent, click the Cogs icon and select as Permanent. Permanence.
   e. Click the Edit icon on the toolbar. An edit viewer and Timeline open.
   f. Double-click a tile in the bin to load it onto the source viewer. The clip has a blue border. You can also pin the source viewer, edit viewer, and Timeline.
   g. Mark the source viewer using the mark and park procedure and click the Replace button.
   h. Double-click another tile in the bin to load it onto the source viewer. Mark the source viewer using the mark and park procedure and click the Replace button.
   i. Add other clips in the same way.

Chapter 7  Introduction to Photoshop CS3


2. a. T  b. F  c. F  d. T  e. F

3. a. The Lasso tool is used to make a free hand selection in an image.
   b. The default unit of the width and height of an image is pixels.
   c. The default extension of a Photoshop file is .psd.
   d. The Move tool is used for moving an image, or part of an image, from one location to another.

4. a. The Marquee Tools are used to select areas of an image in rectangular, square, elliptical, or circular shapes.
   b. While creating a new file, the option Color Mode specifies the number of colours that can appear in an image.
   c. The Crop Tool is used to remove unwanted areas of an image.

5. a. Start Adobe Photoshop CS3.
   b. To insert the different shapes depicting nature, like flowers, leaves etc., do the following:
      i. Select the Custom Shape Tool.
      ii. Click the arrow beside the Shape option in the Options bar and select the required shape.
      iii. Click and drag the mouse to draw the shape.
      iv. Change the colour of the shapes as desired.
   c. Change the foreground and background colour as desired as follows:
i. Click the **Foreground** or **Background** color selection box in the tools panel.

ii. The **Color Picker** dialog box appears.

iii. Drag the colour slider.

iv. Click in the **Color** Field and choose a colour.

v. Click OK.

---

**Chapter 8  Tools used in Photoshop CS3**

1.  
   a. Retouching  
   b. Layers  
   c. Spot Healing Brush  
   d. Warping  
   e. Blur

2.  
   a. F  
   b. T  
   c. F  
   d. F  
   e. T

3.  
   a. The **Clone Stamp tool** is used to clone or duplicate the selected areas of an image.  
   b. A new Photoshop image has a single layer.  
   c. The **Eraser** tool helps in erasing parts of an image.  
   d. **Filters** are used to add a variety of special effects to an image.

4.  
   a. The **Smudge** tool is used to create an effect like wet paint smudged with a finger.  
   b. When we type text in Photoshop, it is added to a separate layer called the **Type Layer**.  
   c. Flattening of layers helps in reducing the file size by merging all visible layers into the background.

5.  
   a. Start Photoshop CS3.  
   b. Create a new file.  
   c. To add a new layer:  
      i. Select **Layer ▶ New Layer**.  
      ii. Give the layer a name.  
      iii. Click OK. You will see a new blank layer in the Layers palette.  
   d. Copy the required image and paste it into this new layer.  
   e. To change the size of the image:  
      i. Select the layer.  
      ii. Select **Edit ▶ Transform ▶ Scale**. The scaling handles appear.  
      iii. Click and drag the scaling handle to resize the image.  
      iv. Double-click inside the image to apply this transformation.  
   f. To rotate the image:  
      i. Select the Layer or image.  
      ii. Select **Edit ▶ Transform ▶ Rotate**. The rotation handles appear.  
      iii. Click and drag the rotation handle.  
      iv. Double-click inside the image to apply the transformation.  
   g. Repeat steps (c) to (f) for more pictures.
Chapter 9  Introduction to Dreamweaver CS3

1. a. Remote   b. Site   c. Hyperlink   d. Insert   e. Title
2. a. F   b. T   c. F   d. T   e. T

3. a. The full form of WYSIWYG is What You See is What You Get.
   b. The Show Code view displays the HTML code for the web page.
   c. In Dreamweaver, the images that can be hyperlinked are called Flash buttons.
   d. The Refresh Design view button of the Document window toolbar needs to be clicked in order to make the changes in Code view appear in the Design view.

4. a. The two ways to create a new website in Dreamweaver are:
   In the opening page, under Create New, click Dreamweaver Site
   Or
   Click Site ► New Site to open a new website.
   b. By creating a Named Anchor, you can set a marker in the document and then you can create a link to the Named Anchor.
   c. The Crop property of an image trims the size of an image by removing unwanted areas.

5. a. Create a folder called NewWebsite on the desktop.
   b. Start Dreamweaver.
   c. Click Site ► New Site. The Site Definition for dialog box appears.
   d. Click on the Advanced tab. Type the site name as NewWebsite. Set the local root folder to the NewWebsite folder and click OK. Store the image file to be used on the web page in this folder.
   e. Right-click on the NewWebsite folder in the Files panel. Select New File from the context menu. Name it as “NaturalResources.html”.
   f. Double-click “NaturalResources.html” to open the page.
   g. Type the text to be written on the web page.
   h. Format the text as required by clicking on relevant properties in the Property Inspector.
   i. To add the image, select the image in the Files panel and drag it to the required position on the web page.
   j. To save the web page after making all these changes, press CTRL + S.
   k. Preview the web page by clicking the Preview/Debug in browser button.

Chapter 10  Images and Framesets in Dreamweaver CS3

2. a. T   b. F   c. T   d. F   e. T

3. a. The Date object in Dreamweaver helps to insert the current date.
   b. The HTML file that defines the layout and properties of a set of frames is called the Frameset.
   c. In a rollover image, the primary image is displayed when the web page is first loaded.
   d. The Width and the Height properties of an image placeholder are required properties.

4. a. A rollover image is an image which when viewed in a browser, changes as the pointer moves across it.
   c. The three graphic file formats supported by most browsers are: GIF, JPEG, and PNG.
   d. The three shapes which are used to define a hotspot are: rectangle, circle, and polygon.
5. a. Create a root folder for the website.
   b. Right-click the folder in the Files panel and select New Folder from the context menu.
   c. Rename the folder and call it “SolarSystemMap”.
   d. Right-click the folder and select New File from the context menu.
   e. Rename the file “SolarSystem.html”.
   f. Create another file and rename it as “SolarSystemInfo.html”.
   h. Insert the image of the solar system.
      i. Now, select the image in the Document window.
      ii. In the Property Inspector, select the Rectangle tool and click around the image of the Solar System to make a hotspot. Click the Arrow tool to close the shape.
      iii. After creating the hotspot, the Property Inspector displays the hotspot properties. Do the following:
          • In the Link box, drag Point to File to the required file in the Files panel.
          • In the Target popup menu, select _self so that the linked web page appears in the same window.
          • In the Alt box, type the alternative text for text-only browsers.
      i. After that, click the blank area in the document to change the Property Inspector.
   j. Double-click the file “SolarSystemInfo.html” in the Files panel and type the required content.
   k. At the end, insert a Flash button and link it to the file “SolarSystem.html”.
   l. Save the web page by clicking File ► Save.
   m. Now, double-click “SolarSystem.html” and press F12 to view it in a browser.
   n. Move the pointer over the image of the solar system. Click the image and the linked page will appear.
Notes