KEYBOARD
Computer Science With Application Software
THIRD EDITION

TEACHING GUIDE
About the Series

The computer in present-day society is an indispensable tool facilitating communication and work. From huge machines weighing several tons, the computer has evolved into light, sleek yet powerful tools that dominate today’s knowledge society. Many previously complex and time-consuming tasks have been reduced to the mere touch of a few buttons on the keyboard. Basic computing skills like word processing are an essential requirement in today’s job market. The Internet has revolutionised the way people communicate and interact. Geographical distances are no longer a constraint for effective business transactions, information dissemination, and interpersonal interactions, as distances have been overcome through extensive, intricately-designed communication networks.

Today computer science is an academic subject in its own right, governed by scientific and mathematical principles. It is an integral part of what is commonly called STEM (Science, Technology, Engineering, and Mathematics). Due to its increasing importance, computer classes have become an essential part of the education curriculum around the world.

However, the trend has been to favour Information and Communication Technology (ICT) rather than the science behind computers. ICT in schools usually focuses only on teaching how to use office productivity software, such as, word processors, presentation software, and spreadsheets. We, as teachers, should be careful that we teach not only ICT, but also computing, especially in the lower classes. This is an important distinction because ICT primarily involves simply understanding and memorising commands. As a consequence many students may get the impression that there is not much of creativity involved in using computers. This may possibly result in students losing interest in what they mistakenly believe to be computing. Students are not introduced to how computers work and are not provided with the opportunity to be creative through computing activities that challenge them to use their logical and analytical abilities along with being creative.

Computer science education should be such that children later on, if they choose to do so, would be capable of making a meaningful contribution either to further advance our digital society or use digital media optimally in their chosen field of study or work. Computer education in schools should equip every child with the basic understanding of how computers work and with the possibilities of information technology in a knowledge-based society and economy. This has been the rationale for developing this third edition of the Keyboard series—Keyboard: Computer Science with Application Software.
KEYBOARD: COMPUTER SCIENCE WITH APPLICATION SOFTWARE

Keyboard: Computer Science with application Software, third edition, a series of eight books for Classes 1 to 8, is a comprehensively revised edition of Keyboard: Computer Science with application Software, second edition, and carries forward the very same interesting and interactive approach that is a hallmark of the existing edition. The series aims to make the study of computer science engaging and interactive for students through a combination of interesting features.

The contents are based on the most recent feedback from teachers and incorporate the latest trends in computer education. We have taken particular care to update facts and figures, and to include the latest advancements in the field of information and communication technology. Thus, trendsetting topics such as social networking and cloud computing have been explained along with devices such as smartphones and tablets. Also, in keeping with the times, there is greater focus on animation and web-designing concepts.

The series introduces the subject in a language that is simple and direct. Technical jargon is used only where necessary and all such terms are defined at the end of each chapter. Comic strips, icons, cartoon characters, and illustrations make the learning process an enjoyable experience.

Keyboard: Computer Science with Application Software is an advanced course in computer science meant for those schools that wish to teach creative application software, such as Flash, HTML, Photoshop, and Dreamweaver, along with the basic concepts of computers, computer programming, and the Internet. In keeping with the times it also introduces students to sound (Audacity) and video-editing (Lightworks) software.

COURSE FEATURES AND HIGHLIGHTS

Each chapter in Keyboard: Computer Science with Application Software starts with an engaging introduction in comic strip format presenting a conversation between two characters, Goggle and Toggle. Goggle represents an average primary and middle school student, while Toggle is an animated laptop and an expert in computer science. Toggle helps Goggle understand all that is taught about computers and computer software in the series. The series has a hands-on approach to learning with text supported by relevant screenshots, and plenty of practical exercises. The MS Office screenshots are based on MS Office 2013, with the compact and user-friendly Windows 7 as the operating system.

Practice Time, Exercises, In the Lab, and Group Project

Practice Time is a feature that has been a part of all the computer science series we have written, and it has been found by teachers to be a very useful feature. We continue with it in Keyboard: Computer Science with Application Software also. The feature provides practical exercises after every major topic, in which the student applies the concept(s) learnt in the previous section to solve a practical problem. The detailed solution is given after the question, so that students are able to understand the practical application of a particular concept on their own. This frees the teacher from the process of trying to individually assess whether all the students have properly grasped the concept.

The Exercises and In the Lab questions in the series deserve particular mention, as they have been developed according to Bloom’s Taxonomy. The exercises in each chapter have sufficient theoretical and practical questions for concept application.

Application-Based Questions is a special analytical section within Exercises, aimed at encouraging students to evaluate a picture or a situation, and answer questions based on them.

The In the Lab questions are similar to those under Practice Time except that the solutions are not given. The questions too are more complex than those found under Practice Time. In both, however, the questions describe
a variety of situations across subjects. Thus, both attempt to integrate the use of computers with problem-solving in other subjects.

**Group Projects** encourage the students to work in collaboration with their peers and implement what they learnt in the lessons.

**Worksheets and Assessment Papers**

*Worksheets* have been introduced in Classes I to V, while for Classes VI to VIII *Assessment* and *Comprehensive Assessment* papers have been included.

**Teaching Resources**

The teacher’s resources for the *Keyboard: Computer Science with Application Software,* series have two components:

(a) **Teaching Guides** and (b) **Teacher’s Digital Resources.**

**Teaching Guides**

The Teaching Guides accompanying each of the coursebooks is carefully structured to provide useful support to teachers.

Each Teaching guide contains the following:

- A **Lesson Plan** that details the periods recommended for a particular chapter, the topics therein, the expected learning outcomes at the end of each topic, and the digital support available for each chapter. This is intended to assist teachers in respect of overall planning. Teachers may go through the lesson plan before stepping into the class or may use the recommendations for creating their own.

- A set of **chapter-wise Worksheets** follows the lesson plans, and has questions in the form of Crossword Puzzles, Word Searches, Jumbled Words, etc. designed to reinforce conceptual understanding.

- In addition to the *Worksheets,* a set of **chapter-wise test papers** has also been provided, which may be used by teachers to create their own assessment papers, or may be used as they are for classroom tests.

- The complete **Answer Key** to the Coursebook Exercises has been given in the teaching guide, including that for the In the Lab questions, Group Project, Worksheets-Assessment papers, Revision Questions, and the Cyber Olympiad Questions.

**Digital Resources**

The teacher’s digital support for the series is accompanied by a **Test Generator.**

This comprehensive and easy-to-use **Test Generator** is an effective assessment tool designed to benefit teachers by enabling them to create a variety of test papers.

It has two sections: (a) Coursebook questions (b) Questions beyond the coursebook.

Both include an extensive pool of questions, such as multiple choice, true or false, fill in the blanks, short answer, and long answer questions, as well as lab exercises wherever relevant. Answers have been provided to enable efficient and effective evaluation. The **Test Generator** allows the teacher to create test papers for one or more chapters, with a mix of questions from both the sections. The Student’s Books, and the accompanying Teaching Guides and teacher’s digital support, together form a complete package enabling one to teach the subject effectively.
Continuous and Comprehensive Evaluation

Learning takes place in a variety of ways — through experience, making and doing things, experimentation, reading, discussion, asking, listening, thinking and reflecting, and expressing oneself in speech, movement or writing. All these modes of learning are possible both individually and in groups. It would thus be advantageous for children to be given the opportunity to involve themselves in as many of these activities as possible.

CONTINUOUS AND COMPREHENSIVE EVALUATION (CCE)

The primary objectives of this system are (1) to maintain continuity in evaluation and (2) to reliably assess broad-based learning and behavioural outcomes.

In this system the term ‘continuous’ is meant to emphasize that evaluation of a student’s progress is a continuous process rather than an event. It is spread over the entire span of an academic session, and means regularity of assessment and unit-testing. It also includes a diagnosis of learning gaps, the use of corrective measures, retesting, as well as self-evaluation.

The term ‘comprehensive’ suggests that the system should cover both scholastic and co-scholastic aspects of a student’s growth and development.

This system expects assessment to be both formative and summative. Formative assessment is a tool used by the teacher to continuously monitor student progress in a supportive environment. It involves regular descriptive feedback, a chance for the student to reflect on the performance, take advice and improve upon it. If used effectively it can improve student performance tremendously.

Summative assessment is carried out at the end of a course of learning. It measures or ‘sums-up’ how much a student has learned from the course. It is usually a graded test, i.e., it is marked according to a scale or set of grades.

It has been found that assessment that is predominantly of a summative nature will not by itself be able to yield a valid measure of the growth and development of the child. It, at best, certifies the level of achievement only at a given point of time.

The paper-pencil tests are basically a one-time mode of assessment and to exclusively rely on it to decide about the development of a child is both unfair and unscientific. Over-emphasis on examination marks makes children assume that assessment is different from learning. Besides encouraging unhealthy competition, the reliance on a summative assessment system also results in great stress and anxiety among learners.

The Keyboard: Computer Science with Application Software, series, comprising of Student’s Books, Teaching Guides, and Digital Resources, has a number of features that aid both continuous and comprehensive evaluation.

CONTINUOUS EVALUATION

Coursebooks

Beginning of Instruction (Formative Assessment)

• The introductory dialogue at the beginning of each chapter between Goggle and Toggle is a starter to the chapter topic and can be employed to test the prior knowledge of students by using the dialogue to ask for possible solutions or an answer to Goggle’s question. For example, in the following dialogue you can also ask them what is the alternative to clicking the Run button.
Now, that’s the reason the turtle is not obeying you.

Hi, Toggle! I’ve been waiting for you.

At your service, Sir. How can I help you?

This turtle is giving me trouble. It doesn’t obey my commands!

Umm… let me see… did you click the Run button after typing your command?

No!

During Instruction (Formative Assessment)

- The conceptual grasp of students can be assessed during instruction through Practice Time, which has been placed after every major topic in the Student’s Book, by observing how fast they carry out the task as given. A couple of questions may also be added to test their understanding of the concept. For example, in the question below students may be asked if they can use the tl command in the solution to this question instead of the tr command.

### PRACTICE TIME

Tina wants to draw a rectangle of breadth 40 steps and length 60 steps in KTurtle using the `turnright (tr)` command. Can you help her out?

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Tina should type the code given alongside in the KTurtle Editor pane.</td>
</tr>
<tr>
<td>2.</td>
<td>After typing the code, she should click the Run button.</td>
</tr>
<tr>
<td>3.</td>
<td>The output will appear as given here.</td>
</tr>
</tbody>
</table>

**SOLUTION**

1. Tina should type the code given alongside in the KTurtle Editor pane.
2. After typing the code, she should click the **Run** button.
3. The output will appear as given here.

Note: Try doing the same using the tl command also.
End-of-Chapter (Summative Assessment)

- At the end of the chapter the student can be tested on acquired knowledge through the objective and descriptive questions of the **Exercises**, the **Application-Based Questions**, and on the practical application of concepts through **In the Lab** questions, and **Group Project**.

**IN THE LAB**

1. Amir has designed a New Year greeting card in Paint as shown below. Make a New Year greeting card of your own, using the various tools in Paint, for your teacher.

**Application-Based Questions**

a. Observe the given figure on the right and answer the following questions:
   i. Which tool is selected in the figure?
   ii. Name the modifier that has been used to draw line A.
   iii. Name the modifier that has been used to draw line B.
   iv. Which modifier will you use to draw lines without any modifications?

**End-of-Unit and Term** (Formative as well as Summative Assessment)

- Assessment at the end of a unit, or a set of three or four chapters, is facilitated through **Worksheets** in classes I to V.

**TEACHING GUIDES**

The Teaching guides provide the following support for *formative* and *summative* assessment:

- **Worksheets, one for each chapter**, have questions in the form of Crossword Puzzles, Word Searches, Jumbled Words, etc. designed to reinforce conceptual understanding.

- **Test papers, one for each chapter**, which may be used by teachers by photocopying them in a larger format for classroom tests.

**DIGITAL RESOURCES**

The downloadable digital resources are for the series provided accompanied with **Test Generator**.

The Digital resource for *Keyboard: Computer Science with Application Software*, includes:

- **Animations** for the theoretical chapters such as that on operating systems, history of computers, input and output devices, etc. that offer an interesting audio-visual element to technically complex or difficult concepts. There are one or more modules for each such chapter which may be paused at relevant points and feedback taken on what the children have seen, heard, and understood.

- **Demo Videos** that are linked to one of the Practice Times in software chapters (those chapters that describe the features and commands available in a software), and present a step-by-step audio-visual guide to solving the problem described in that particular Practice Time question. One or more objective type question(s) has (have) been introduced at (a) strategic point(s) under the feature **Rapid Round** during the demo to encourage children to participate in the solution to the problem. These questions could be also be used as a formative assessment tool.

- **Interactive Exercises** The **objective type questions** have been made interactive in the form of pop-up screens in which the right answer can be typed in or clicked. Clicking **Submit** will give you feedback, hence these can be used as a formative assessment tool for quick evaluation.
• **Printable documents** for every chapter in the form of soft copies of the worksheets and test papers given in the Teaching Guides. The teacher is free to use either version of the worksheets and test papers as formative assessment tools.

• Additional projects, Cyber Olympiad questions for practice, revision questions, and sample assessment papers (in classes 6 to 8).

The **Test Generator** accompanying **digital resources** is an effective assessment tool designed to benefit teachers by enabling them to create a variety of test papers.

It has two sections: (a) Coursebook questions (b) Questions beyond the coursebook.

Both have an extensive pool of questions including multiple choice, true or false, fill in the blanks, very short answer, and short answer questions, as well as lab exercises wherever relevant. The Test Generator can be used to create test papers for one or more chapters, with a mix of questions from both the sections. The wide variety of objective and descriptive type of questions makes the tool flexible enough for teachers to employ it either for formative or for summative assessment. Answers have also been provided for these questions to aid efficient and effective evaluation by teachers.

---

**COMPREHENSIVE EVALUATION**

Comprehensive evaluation involves, as explained above, both the scholastic and co-scholastic aspects of a student’s growth and development. It aims to assess the student not only in the area of pure knowledge but also in the areas of their analytical and creative ability, as well as in their general attitudes and aptitudes.

The key features in *Keyboard: Computer Science with Application Software*, have been designed to provide both scholastic and co-scholastic development.

**Scholastic**

• The features such as Did You Know?, Fast Forward, Top Tip, Tricky Terms, and Memory Bytes, enhance and reinforce conceptual knowledge.

<table>
<thead>
<tr>
<th>Did you Know?</th>
<th>Fast Forward</th>
<th>Top Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>One point equals 1/72&lt;sup&gt;th&lt;/sup&gt; of an inch.</strong></td>
<td><strong>Font dialog box Ctrl + D</strong></td>
<td><strong>Starter images are backgrounds with outlines of images, or 3D photographs, that you can use in Tux Paint.</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Memory Bytes</th>
</tr>
</thead>
<tbody>
<tr>
<td>• The AutoFill feature lets you quickly enter a predefined series of data.</td>
</tr>
<tr>
<td>• There are two ways to create custom lists: by importing the list or by entering the list in the Custom Lists dialog box.</td>
</tr>
<tr>
<td>• Filtering selectively displays rows/columns that meet the criteria specified by the user.</td>
</tr>
<tr>
<td>• Conditional formatting allows you to set a cell’s format according to the conditions you specify.</td>
</tr>
</tbody>
</table>
Co-Scholastic

- The features such as Computer Manners, Projects, and the design of the practical exercises focus both on scholastic and co-scholastic areas by creating awareness on ethical and correct use of computers, as well as the use of computers as a tool for applying their creativity and enhancing their problem-solving skills.

## Application-Based Questions

a. Observe the given figure on the right and answer the following questions:

i. Which tool is selected in the figure?

ii. Name the modifier that has been used to draw line A.

iii. Name the modifier that has been used to draw line B.

iv. Which modifier will you use to draw lines without any modifications?

b. Danya has to create a cartoon character using tools available in Flash CS3. Which tool will she use for the following purposes?

i. Paint freely on the stage

ii. Draw a square

iii. Fill with gradient inside the shape

Find out how many rectangles there are in the figure.

## Projects

### KTURTLE

Type the following commands and execute it in KTurtle. Draw the figure you see on the canvas in the space provided.

Note: Read and enter the commands column-wise.

- `reset`
- `canvascolor 255,0,0`
- `pencolor 0,255,0`
- `penwidth 5`
- `go 150,250`
- `fw 120`
- `tr 90`
- `fw 100`
- `tr 90`
- `fw 120`
- `tr 90`
- `fw 100`
- `bw 40`
- `tr 90`
- `fw 50`
- `tr 90`
- `fw 20`
- `tr 90`
- `fw 50`
- `tr 90`
- `fw 60`
- `tr 90`
- `fw 120`
- `tr 45`
- `fw 70`
- `tr 90`
- `fw 70`
- `tl 135`
- `go 60,250`
- `fontsize 40`
- `pencolor 0,0,255`
- `print "This is my house"`

### TUX PAINT

In Tux Paint you can draw and color lines, curves, and geometrical figures. You can also add magical effects to your drawing, and you can write text in the drawing area. Do the following:

a. Fill a starter image as the one given here with colors of your choice.

### IN THE LAB

1. Amir has designed a New Year greeting card in Paint as shown below. Make a New Year greeting card of your own, using the various tools in Paint, for your teacher.
SCHEME OF WORK AND LESSON PLANS

- A **Scheme of work** and **Lesson Plan** have been devised for each chapter which details the number of periods recommended for that chapter, the topics covered in that chapter, the recommended topic-wise allocation of periods, the learning outcomes, and the **downloadable digital resources** available for that chapter.

- The total number of periods in a year for Computer Science has been taken at 36 assuming one period in a week for the subject.

- Teachers may go through the lesson plan before stepping into the class. However, this is a proposed lesson plan, and teachers are free to modify it as per their teaching styles or teaching sequence in respect of the chapters.
# SCHEME OF WORK*

<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise allocation of periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
</table>
| 1. Formulas in Excel 2013 | Cell and Range References | 1 | The student should be able to:  
• define formula and reference.  
• write formulas in Excel 2013.  
• describe the concept of cell reference. |
| | Using Formulas | 3 | • demonstrate how and where to enter a formula.  
• find the sum of values.  
• define pointing.  
• explain relative, absolute, mixed, and circular references.  
• explain concatenation.  
• define arithmetic operators and recall their precedence in formulas. |
| | Error Results | 0.5 | • interpret common formula error messages in Excel 2013. |
| | AutoSum Feature | 1.5 | • use the AutoSum feature.  
• list the additional functions available in the AutoSum drop-down menu.  
• calculate total, average, count, and find maximum and minimum values using the AutoSum feature. |
| | Functions Library | 2 | • define a function.  
• provide an overview of the various functions available in the Function Library group on the Formulas tab.  
• find GCD and LCM.  
• create a formula using the Insert Function command. |
| 2. Creating Charts in Excel 2013 | Types of Charts | 2 | The student should be able to:  
• define a chart.  
• explain the need to create a chart.  
• describe various charts and their significance. |
| | Components of a Chart | 1 | • identify and list the various components of a chart. |
| | Creating a Chart | 4 | • create a chart by following all the necessary steps.  
• change or add chart components.  
• to modify the chart style and layout.  
• to use the chart formatting options under the Format tab of the Chart Tools.  
• to create a combo chart. |
| | Sparklines | 1 | • define a sparkline and explain its uses.  
• to create a sparkline. |
| 3. Computer Viruses | What Does a Computer Virus Do? | 1 | The student should be able to:  
• define a computer virus  
• explain what a computer virus can do and what it cannot.  
• understand the various warning signals.  
• explain how a computer virus spreads. |
| | Types of Computer Viruses | 1 | • explain the different types of viruses. |

* The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise allocation of periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Malware</td>
<td></td>
<td>0.5</td>
<td>• define the terms: malware, worms, Trojan horses, spyware, and spam.</td>
</tr>
<tr>
<td>Preventing Virus Infections</td>
<td></td>
<td>0.5</td>
<td>• list some basic rules to avoid virus infections.</td>
</tr>
<tr>
<td>Antivirus Software</td>
<td></td>
<td>1</td>
<td>• describe the various antivirus software available.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• scan their system using the Quick Heal Antivirus software.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the components of the Quick Heal main window.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• update virus definitions.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• discuss free antivirus software.</td>
</tr>
<tr>
<td>4. Loops and Graphics in Small Basic</td>
<td>For...EndFor</td>
<td>2</td>
<td>The student should be able to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the working of the For...EndFor loop.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• describe the use of the Step command.</td>
</tr>
<tr>
<td></td>
<td>While...EndWhile</td>
<td>2</td>
<td>• explain the working of the While...EndWhile statement.</td>
</tr>
<tr>
<td>Graphics Window</td>
<td></td>
<td>1</td>
<td>• describe the GraphicsWindow object.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain its various properties and methods.</td>
</tr>
<tr>
<td>5. Introduction to Visual Basic</td>
<td>Graphical User Interface</td>
<td>0.5</td>
<td>The student should be able to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• describe what Visual Basic is.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain GUI and event-driven programming.</td>
</tr>
<tr>
<td>Getting Started with Visual Basic</td>
<td></td>
<td>0.5</td>
<td>• start Visual Basic.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the acronym IDE.</td>
</tr>
<tr>
<td>Visual Basic Window</td>
<td></td>
<td>2</td>
<td>• identify and describe the various components of the Visual Basic window.</td>
</tr>
<tr>
<td>Developing an Application</td>
<td></td>
<td>2</td>
<td>• develop an application.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate how to place and delete controls on the Form</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• create and execute an application in Visual Basic.</td>
</tr>
<tr>
<td>Working with Variables</td>
<td></td>
<td>2</td>
<td>• define a variable.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• name a variable correctly.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• declare a variable and assign a value to it.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• list the arithmetic operators used in Visual Basic.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• create an application using variables.</td>
</tr>
<tr>
<td>6. Communication on the Internet</td>
<td>Chat, Instant Messaging and Newsgroups</td>
<td>1</td>
<td>The student should be able to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• define Chat, Instant messaging, Newsgroups, and Chat Rooms.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• demonstrate how to use the chat program Yahoo! Messenger.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the do’s and do nots of Chat.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the different categories of Newsgroups.</td>
</tr>
<tr>
<td>Blogs and Web Feeds</td>
<td></td>
<td>1</td>
<td>• define Blog and Web Feeds.</td>
</tr>
<tr>
<td>Social Networking</td>
<td></td>
<td>1</td>
<td>• define social networking.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• describe the various social networking services—Facebook, MySpace, and Twitter — in brief.</td>
</tr>
</tbody>
</table>

* The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise allocation of periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Other Services</td>
<td></td>
<td>2</td>
<td>• to send greeting cards on the Internet.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• define online gaming and online telephony.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• recall what the FTP stands for and explain how it works.</td>
</tr>
<tr>
<td>Cloud Computing and Online Sharing</td>
<td></td>
<td>1</td>
<td>• define cloud computing and online sharing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain what SkyDrive, Picasa, and YouTube help us do.</td>
</tr>
<tr>
<td>7. More Tools in Flash</td>
<td>Pen Tool</td>
<td>0.5</td>
<td>The student should be able to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• use the Pen Tool.</td>
</tr>
<tr>
<td></td>
<td>Eyedropper Tool</td>
<td>0.5</td>
<td>• use the Eyedropper Tool.</td>
</tr>
<tr>
<td></td>
<td>Importing a Picture</td>
<td>1</td>
<td>• import pictures to the Stage.</td>
</tr>
<tr>
<td></td>
<td>Transforming Objects</td>
<td>4</td>
<td>• use the Free Transform Tool.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• move and rotate the selected object.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• scale an object.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• use the Gradient Transform Tool.</td>
</tr>
<tr>
<td></td>
<td>Working with Text</td>
<td>3</td>
<td>• differentiate between linear gradient and radial gradient.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• change the gradient fill.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• change the colour or transparency of an instance of a symbol.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• group outlines and fills.</td>
</tr>
<tr>
<td>8. Animations in Flash</td>
<td>The Timeline and Layers</td>
<td>2</td>
<td>The student should be able to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the use of the Timeline.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• explain the concept of layers.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• insert a layer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• rename a layer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• change the order of layers.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• delete a layer.</td>
</tr>
<tr>
<td></td>
<td>Animation with Motion and Shape Tweening</td>
<td>2</td>
<td>• animate an object using motion and shape tweening.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• use the Onion skin feature.</td>
</tr>
<tr>
<td></td>
<td>Using a Masking Layer</td>
<td>0.5</td>
<td>• explain the concept of the Mask Layer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• use the Mask layer.</td>
</tr>
<tr>
<td></td>
<td>Animation using a Motion Guide</td>
<td>0.5</td>
<td>• animate objects using a Motion Guide.</td>
</tr>
<tr>
<td></td>
<td>Applying Filters</td>
<td>1</td>
<td>• apply filters to an object.</td>
</tr>
<tr>
<td></td>
<td>Applying Timeline Effects</td>
<td>0.5</td>
<td>• apply Timeline effects to an animation.</td>
</tr>
<tr>
<td></td>
<td>Working with Sound</td>
<td>0.5</td>
<td>• import a sound file into Flash and add sound to an animation.</td>
</tr>
</tbody>
</table>

* The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>In this Chapter</th>
<th>Topic-wise allocation of periods</th>
<th>Learning Outcomes</th>
</tr>
</thead>
</table>
| 9. Introduction to HTML 5 | Structure of a Website | 0.5 | The student should be able to:  
• explain the structure of a Website. |
| | What is HTML? | 0.5 | • explain what HTML is. |
| | HTML Editors | 1.5 | • explain the types of HTML Editors.  
• create an HTML document, save it, and view it in a Web browser. |
| | HTML Coding | 2.5 | • explain what HTML elements and tags are.  
• differentiate between container elements and empty elements.  
• define HTML attributes.  
• recall the rules for writing an HTML document. |
| | Structure of an HTML document | 1 | • explain the structure of an HTML document.  
• explain the purpose of the <!DOCTYPE>, <html>, <head>, <title>, and <body> tags. |
| | Line Break Element | 1 | • explain the use of the BR tag. |
| | Cascading Style Sheets | 1 | • explain what cascading style sheets are and how to include them in an HTML document.  
• write the syntax of a CSS rule. |
| | Background Properties | 1 | • describe and use the various background properties.  
• set the background colour.  
• set an image as a background. |
| 10. Basic HTML 5 Commands | HTML elements | 2 | The student should be able to:  
• explain what deprecated elements are  
• effectively use the <p> tag, the <hr> tag, the <hn> tag. |
| | Text Properties | 3 | • describe the different text properties and use them.  
• use the comment tag appropriately.  
• use the bold and italics tags. |
| | Font Properties | 2 | • explain and use the various font properties. |
| | Setting Margins | 0.5 | • set margins in an HTML page. |
| | Setting Borders | 0.5 | • specify the border width, style, and colour in an HTML page. |
| | Inline Styles | 1 | • use inline styles |

* The topic-wise allocation of periods for each chapter may vary, as per the individual class requirements.
LESSON PLANS*

Chapter 1: Formulas in Excel 2013

Time for each lesson: 40 minutes

Resources: a laptop, a projector, computer lab, sample table of students’ results saved in an Excel Sheet on your laptop

Introduction (7 minutes)
You may begin the session by having students recall what they have learnt in the previous class (in Keyboard Book 6). Initiate a general discussion of all the functions that they have previously studied, as this will help set the foundation for this chapter.

Explanation (25 minutes)
This lesson must be taught in the computer lab. It is important that students are allowed to practice all the formulas that they learn in class. Explain to students the different types of formulas that can be used in Excel 2013. Ensure that they are aware of the differences between Absolute, Mixed, and Relative cell references. Describe to them the concept of text formulas, mathematical formulas, and the use of the Functions Library.

You may teach your students the text formula and AutoSum Function together by conducting an activity. Create a table on your excel sheet, with Name, Surname, Full Name, Marks in English, Marks in Mathematics, Marks in Science, and Total marks as column headings. Enter 4 to 5 records, however do not fill in the Full Name and the Total marks columns. Next, you can ask your students to copy the table on their excel sheets, and also fill in the remaining two columns of the table. (You can create your table beforehand at home to save time and simply present students the incomplete table, by using a projector.)

Once the students have completed this activity, you can then explain how filling in the Full Name and Total Marks column can be made easier by using the Text Formula and the AutoSum Feature. Have students practice that by deleting the data in both those columns and filling them again using the formulas this time.

It is recommended that you have students perform Practice Time questions as part of their classwork. This will allow them to practice what they have learnt during the lesson.

You can assign any of the following tasks for classwork.

- Exercises
- In the Lab
- Group Project
- Worksheets

Assessment
Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- define formula and reference.
- write formulas in Excel 2013.
- describe the concept of cell reference.
- demonstrate how and where to enter a formula.
- find the sum of values.
- define pointing.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
• explain relative, absolute, mixed, and circular references.
• explain concatenation.
• define arithmetic operators and recall their precedence in formulas.
• interpret common formula error messages in Excel 2013.
• use the AutoSum feature.
• list the additional functions available in the AutoSum drop-down menu.
• calculate total, average, count, and find maximum and minimum values using the AutoSum feature.
• define a function.
• provide an overview of the various functions available in the Functions Library group on the Formulas Tab.
• find GCD and LCM.
• create a formula using the Insert Function command.

Conclusion (8 minutes)
Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 2: Creating charts in Excel 2013

Time for each lesson: 40 minutes

Resources: a laptop, projector, computer lab

Introduction (5 minutes)
You may start off the lesson by asking students to briefly recap all the important points of the previous lesson. This will help ensure that students remain engaged in this discussion. Encourage them to share any other information that they have come across regarding Excel 2013.

Explanation (25 minutes)
Start off the lesson by asking students to name the different types of charts that they have come across in their Mathematics class. Ask them if they are aware of when to use the charts that they have named. Briefly describe to them the uses of all the charts. Then you may take them to the computer lab and demonstrate how charts are created on Excel. Give them ample time to practice creating charts. Describe to them the different chart elements, chart styles, and the chart layout feature. Finally explain to them how to create combo charts and the concept of sparklines and how they are created.

It is recommended that you have students perform Practice Time questions as part of their classwork. You can also select relevant questions from ‘In the Lab’, ‘Application based questions’, and ‘Group Project’ to help them practice what they have learnt during the lesson.

Assessment
Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:
• define a chart.
• explain the need to create a chart.
• describe various charts and their significance.
• identify and list the various components of a chart.
• create a chart by following all the necessary steps.
• change or add chart components.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
• to modify the chart style and layout.
• to use the chart formatting options under the Format tab of the Chart Tools.
• to create a combo chart.
• define a sparkline and explain its uses.
• to create a sparkline.

Conclusion (10 minutes)
Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 3: Computer Viruses

Time for each lesson: 40 minutes

Resources: a laptop, projector, computer lab

Introduction (5 minutes)
Start off your lesson by asking students if they are aware of what a computer virus is. Elicit responses from them regarding what they think computer viruses are and how it affects computers in general.

Explanation (25 minutes)
Describe to students how a computer virus affects our computers and how to detect that a virus has infiltrated our computer. Explain to them the different types of computer viruses and how each of them functions. Finally explain what an antivirus software is and how it is helpful in detecting and removing computer viruses. You may take them to the computer lab to demonstrate how to conduct an antivirus scan.

It is recommended that you have students perform the Group Project as part of their classwork. This way they will be able to clarify any doubts that they may have regarding the given research work.

Assessment
Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:
• define a computer virus.
• explain what a computer virus can do and what it cannot.
• understand the various warning signals.
• explain how a computer virus spreads.
• explain the different types of viruses.
• define the terms: malware, worms, Trojan horses, spyware, and spam.
• list some basic rules to avoid virus infections.
• describe the various antivirus software available.
• scan their system using the Quick Heal main window.
• update virus definitions.
• discuss free antivirus software.

Conclusion (10 minutes)
Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
Chapter 4: Loops and Graphics in Small Basic

**Time for each lesson:** 40 minutes

**Resources:** a laptop, projector, computer lab

**Introduction (5 minutes)**
You may begin the session by having students recall whatever they have learnt about MS Small Basic in their past year (in Keyboard Book 6). A general discussion of all the functions that they have previously studied will help set the foundation for this chapter.

**Explanation (25 minutes)**
This lesson deals with two looping statements: For … EndFor, and While … EndWhile. Ensure that students are aware of when to use each of them and the differences between them. Also, demonstrate how to use the graphics window to draw lines, shapes etc. Make sure they are given ample time to practice all the examples given in the chapter.

It is recommended that you have students perform Practice Time questions as part of their classwork. You can also have them conduct the research work required for Group Project in the class, so as to clarify any doubts that they may have regarding the given task.

**Assessment**
Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- explain the working of the For … EndFor loop.
- describe the use of the Step command.
- explain the working of the While … EndWhile statement.
- describe the GraphicsWindow object.
- explain its various properties and methods.

**Conclusion (10 minutes)**
Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 5: Introduction to Visual Basic

**Time for each lesson:** 40 minutes

**Resources:** a laptop, a projector, computer lab

**Introduction (5 minutes)**
You may begin this session by introducing students to Visual Basic as a software that is similar to MS Small Basic but is also user friendly at the same time. Elicit responses from them regarding what the term ‘user friendly’ means before explaining it to them.

**Explanation (25 minutes)**
You may take your students to the computer lab to allow them to get them accustomed to using Visual Basic. Help them identify and retain in memory all the components of the Visual Basic window. Demonstrate how to create an application on Visual Basic and execute it, how to place controls on a Form and delete it. Make sure students

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
given ample time to practice the example application given on page 74-76. Variables are also an important part of this lesson. Ensure students know how to declare variables and assign values to them.

It is recommended that you have students perform Practice Time questions as part of their classwork. This will allow them to practice what they have learnt during the lesson.

You can assign any of the following tasks for classwork.
- Exercises
- In the Lab
- Group Project
- Worksheets

**Assessment**

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:
- describe what Visual Basic is.
- explain GUI and event-driven programming.
- start Visual Basic.
- explain the acronym IDE.
- identify and describe the various components of the Visual Basic window.
- develop an application.
- demonstrate how to place and delete controls on the Form.
- create and execute an application in Visual Basic.
- define a variable.
- name a variable correctly.
- declare a variable and assign a value to it.
- list the arithmetic operators used in Visual Basic.
- create an application using variables.

**Conclusion** (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one of the topics mentioned in the teacher’s notes, given at the end of the chapter.

**Chapter 6: Communication on the Internet**

**Time for each lesson:** 40 minutes

**Resources:** a laptop, projector, computer lab

**Introduction** (5 minutes)

You may begin the session by asking students the various activities they carry out on the Internet. You may also ask them if they have got family members living abroad, and how do they communicate with them. This will help engage students in a discussion regarding the many uses of the Internet.

**Explanation** (25 minutes)

Explain to students the various ways in which they can communicate over the internet including chat rooms, instant messaging, and Newsgroups. Describe how Blogs and social networking help people voice out their thoughts and also keep in touch with friends and family. For cloud computing, you can provide students with the following example to help them understand its concept: If the students are assigned some research work at

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
school and are asked to complete it at home, then students can save the MS Word document they made in class on cloud and later access it from their homes and continue where they left. This will help them save time, no duplication of work etc.

It is recommended that you have students perform ‘Group Project’ and a few other relevant questions from ‘In the Lab’ and ‘Application based Questions’ to help them practice what they have learnt during the lesson.

**Assessment**

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- define Chat, Instant messaging, Newsgroups, and Chat Rooms.
- demonstrate how to use the chat program Yahoo! Messenger.
- explain the do’s and don’ts of Chat.
- explain the different categories of Newsgroups.
- define Blog and Web Feeds.
- define Social Networking and describe its various services.
- to send greeting cards on the Internet.
- define online gaming and online telephony.
- recall what the FTP stands for and explain how it works.
- define cloud computing and online sharing.
- explain what SkyDrive, Picasa, and YouTube help us do.

**Conclusion** (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

---

**Chapter 7: More Tools in Flash**

**Time for each lesson**: 40 minutes

**Resources**: a laptop, projector, computer lab

**Introduction** (5 minutes)

You may begin the session by having students recall what they have learnt about Flash CS 3 in their past year (in Keyboard Book 6). A general discussion of all the functions that they have previously studied will help set the foundation for this chapter.

**Explanation** (25 minutes)

For this lesson you will need to introduce your students to the various features of Flash discussed in this chapter. It is recommended that you take your students to the computer lab when teaching this chapter. Have them practice importing pictures, transforming objects, dealing with gradients and colours, animating text, shape tweening, etc. Make sure they are given ample time to practice all the examples given in the chapter.

It is also recommended that you have students perform Practice Time questions as part of their classwork. This will again allow them to practice what they have learnt during the lesson.

**Assessment**

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
• use the Pen Tool and Eyedropper Tool.
• import pictures to the Stage.
• use the Free Transform Tool.
• move, rotate, and scale a selected object.
• use the Gradient Transform Tool.
• differentiate between linear gradient and radial gradient.
• change the gradient fill.
• change the colour or transparency of an instance of a symbol.
• group outlines and fills.
• use the Text Tool.
• format text using the Property Inspector.
• convert text into basic shapes.
• animate text with the Timeline Effects and shape tweening.

Conclusion (10 minutes)
Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 8: Animations in Flash

Time for each lesson: 40 minutes

Resources: a laptop, projector, computer lab

Introduction (5 minutes)
You may start off the lesson by asking students to briefly recap all the important points of the previous lesson. This will help ensure that students remain engaged in this discussion. Encourage them to share any other information that they have come across regarding Flash.

Explanation (25 minutes)
Explain to students the concepts of Timeline and Layers. Ensure that they are able to differentiate between motion tweening and shape tweening. Demonstrate to them how to apply filters and timeline effects, use masking layers to create special effects, and how to import audio in Flash.

It is recommended that you take your students to the computer lab so that they are able to practice all the examples given in the chapter. They should also be given ample time to perform Practice Time Questions as part of their classwork.

You can assign any of the following tasks for classwork.
• Exercises
• In the Lab
• Group Project
• Worksheets

Assessment
Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:
• explain the use of the Timeline.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
• explain the concept of layers.
• insert a layer.
• rename a layer.
• change the order of layers.
• delete a layer.
• animate an object using motion and shape tweening.
• use the Onion skin feature.
• explain the concept of the Mask Layer.
• use the Mask Layer.
• animate objects using a Motion Guide.
• apply filters to an object.
• apply Timeline effects to an animation.
• import a sound file into Flash and add sound to an animation.

**Conclusion** (10 minutes)

Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

### Chapter 9: Introduction to HTML 5

**Time for each lesson:** 40 minutes

**Resources:** a laptop, a projector, a computer lab

**Introduction** (5 minutes)

Start of the lesson by asking students about their favourite websites. It could any website, be it a gaming website, an educational website, a video streaming website etc. From there you can lead the discussion to the creation of websites and its structure.

**Explanation** (25 minutes)

Explain to students what HTML is and its types, how to write codes in HTML, the different attributes of an HTML document, HTML tags, HTML rules, line break element, background properties etc. It is recommended that students be allowed to practice all the different features individually so as to remember the different commands of HTML. To this end, they can practice all the examples given in the chapter.

It is also recommended that you have students perform Practice Time questions as part of their classwork. This will again allow them to practice what they have learnt during the lesson.

You can assign any of the following tasks for classwork.

• Exercises
• In the Lab
• Group Project
• Worksheets

**Assessment**

Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

• explain the structure of a website.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
• explain what HTML is.
• explain the types of HTML Editors.
• create an HTML document, save it, and view it in a web browser.
• explain what HTML elements and tags are.
• differentiate between container elements and empty elements.
• define HTML attributes.
• recall the rules for writing an HTML document.
• explain the structure for an HTML document.
• explain the purpose of the <!DOCTYPE>, <html>, <head>, <title>, and <body> tags.
• explain the use of the BR tag.
• explain what cascading style sheets are and how to include them in an HTML document.
• write the syntax of a CSS rule.
• describe and use the various background properties.
• set the background colour.
• set an image as a background.

Conclusion (10 minutes)
Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

Chapter 10: Basic HTML 5 Commands

Time for each lesson: 40 minutes

Resources: a laptop, a projector, a computer lab

Introduction (5 minutes)
You may start off the lesson by asking students to briefly recap all the important points of the previous lesson. This will help ensure that students remain engaged in this discussion. Encourage them to share any other information that they have come across regarding HTML 5.

Explanation (25 minutes)
In this lesson, it is important that you explain to students the different text properties, font properties, and margin properties. You may conduct an activity where you ask students to write a code to design the outline of a website.

It is recommended that you take your students to the computer lab so that they are able to practice all the examples given in the chapter. They should also be given ample time to perform Practice Time Questions as part of their classwork.

You can assign any of the following tasks for classwork.

• Exercises
• In the Lab
• Group Project
• Worksheets

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
Assessment
Students’ learning should be assessed on Bloom’s taxonomy model, as well as on their class participation, enthusiasm, inquiry, and team work. At the end of the lesson, students will be able to:

- explain what deprecated elements are.
- effectively use the `<p>` tag, the `<hr>` tag, and the `<hn>` tag.
- describe the different text properties and use them.
- use the comment tag appropriately.
- use the bold and italics tags.
- explain and use the various font properties.
- set margins in an HTML page.
- specify the border width, style, and colour in an HTML page.
- use inline styles.

Conclusion (10 minutes)
Encourage students to give you a recap of the main points they have learnt in the lesson. Conduct a discussion on any one on the topics mentioned in the teacher’s notes, given at the end of the chapter.

* The lesson plan for each chapter has a flexible structure. It can be split up into daily lesson plans to suit various classroom needs.
ANSWER KEY TO THE COURSEBOOK

• The complete Answer Key to the Coursebook Exercises has been given here including that for the In the Lab questions, Group Project, Worksheets/Assessment papers, Revision Questions, and the Cyber Olympiad Questions.

• These are only suggested answers, and variations are possible especially for the open-ended questions, such as the descriptive questions, and those of In the Lab Group Project. Teachers may use their discretion while checking the answers provided by the students, and give them marks based on conceptual accuracy and conceptual clarity.

• Teachers should consider the following, while conducting the Group Work activity:
  i. Groups should not be larger than five members; pair work obviously means two people working together; it is always a good idea to make groups of mixed ability.
  ii. Be very clear in your expectations from the group, this means telling them clearly what the assignment is about and what you expect to be submitted.
  iii. Make it clear to the students that part of their marks will depend on how well they work with each other and that you expect all of them to be involved in the project.
  iv. Get the students to select their own group leader; if you see that a group is reluctant to do so, you could assign one; also remind the students that they need to listen to the group leader.
  v. Let the group leader divide the tasks that need to be accomplished.
  vi. As a teacher your role should be to observe what each group is doing, how well they are collaborating with each other and offer advice if needed; the focus should be to encourage the students to work without too much input teacher.
Chapter 1  Formulas in Excel 2013

DESCRIPTIVE TYPE QUESTIONS

1. a. A reference in which a formula refers to its own value is called a circular reference. For example, if we enter the formula =A1+A2+A3 in cell A1, every time it calculates the formula in cell A1, it must be calculated again because A1 has changed. So, in such a case, the calculation would go on forever.

b. To find the LCM of three numbers:
   - Type three numbers in cells A1, A2, and A3. Select cell A4 where you want the LCM of the three numbers. Click Math & Trig and then select LCM from the drop-down menu.
   - The Function Arguments dialog box appears. Type A1, A2, and A3 in the Number1, Number2, and Number3 text boxes, respectively.
   - Click OK. The output will appear in cell A4.

c. The difference between the two methods is that in (a) we select a cell and enter the formula in the cell or in the Formula Bar and press Enter once we are done entering the formula whereas in (b) we select a cell and type `=` and instead of typing the rest of the formula we click on the cell to which the reference has to be made. This method is quicker than the first one. For example, to enter a formula =A1+B2 in cell B3, by the second method, type `=` and then click on cell A1. Now type `+` and click on cell B2. Now press enter.

d. To see the formula we have to select the cell in which the formula is entered. The formula is displayed in the Formula Bar when the cell is selected.

e. Multiplication, exponent, subtraction, addition, and division are the arithmetic operators used in Excel formulas.

f. The two ways of creating a sheet like this include either using the formula bar or using the Autosum feature. The student should be able to explain that in using the formula bar, the user has to type in the cell numbers to which the formula applies.

By using the Autosum feature, the user does not have to type in the cell numbers individually but can drag the selection box to include as many cells in the range for which the calculation is being carried out.

The better and more efficient method to be used is the Autosum as it reduces the chance of any omission of cells; also it is a much faster way of calculating totals which is essential if dealing with a large number of cells.

g. | Relative | Mixed | Absolute |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>It makes calculations easier especially for the same calculation being done for a number of cells, because it replaces the references, i.e. the values on which calculations are to be made automatically.</td>
<td>This allows the user to define absolute reference for both a column and a row.</td>
<td>This allows the user to fix a row or column reference; so if in a formula one number is used over and over again, it can be defined as an absolute reference; the advantage being that the same one number does not need typing repeatedly.</td>
</tr>
</tbody>
</table>

h. The students will collect marks for all their subjects from the class teacher; or the teacher could have a printout of the marks of each student and hand them out at the beginning of the class; this lesson should
be planned for the lab. Responses can be assessed on the following:

- formatting of the Table–this includes the use of the font type, size, bold, italic
- correct entry of the data
- the correct use of formulas, and referencing techniques as taught in the chapter

### APPLICATION-BASED QUESTIONS

a. i. The formula entered by Mehak does not have an ‘=’ sign at its beginning. The correct formula is =A1+A2+A3. To correct the formula, select the cell A4 and press F2.

ii. Yes. This is because it will change the total summation of the values and hence the output in cell A4 will change accordingly.

b. i. 3

ii. The formula will be =C2+D1 and the resultant value will be 7.

iii. Relative referencing

c. i. 36

ii. C2 = 54, C3 = 27, C4 = 72

iii. $B$1 is absolute referencing and A1 is relative referencing.

d. i. C2 = 0.08*B2 D2 = B2-C2

ii. To copy the formula in cell C2,

- Select cell C2. On the bottom-right corner a + sign appears. This is the Autofill handle
- While pressing the left mouse button, drag the Autofill handle to the desired location. The formula in cell C2 will automatically get copied in the given cell range. Do the same for cell D2.

### IN THE LAB

1. To calculate the area and the circumference of a circle students should the following step:

   a. Create a worksheet as shown in the given figure.
   
   b. In the cell B2, type the formula =$F$1*A2*A2 and press Enter. The value 3.14 will appear in the cell.
   
   c. To get the area for other radius values, select cell B2. A + sign appears. This is called the AutoFill handle. Drag the AutoFill handle to cell B11. The resulting area values will be displayed in the corresponding cells.
   
   d. In the cell C2, type the formula =2*$F$1*A2 and press Enter. The value 6.28 will appear in the cell.
   
   e. To get the circumference for other radius values, select cell C2. A + sign appears. This is called the AutoFill handle. Drag the AutoFill handle to cell C11. The resulting circumference values will be displayed in the corresponding cells.
2. To print the multiples of 11 to 20:
   a. Create a worksheet as shown in the figure.
   b. In the cell B2, type the formula =A2*$B$1 and press Enter. The value 11 will appear in the cell.
   c. To get the multiples of other numbers, select cell B2. A + sign appears. This is called the AutoFill handle.
      Drag the AutoFill handle to cell K11. The first 10 multiples of 11 to 20 will be displayed.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>3.14</td>
<td>6.28</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>12.56</td>
<td>12.56</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>4</td>
<td>28.26</td>
<td>18.84</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>5</td>
<td>50.24</td>
<td>25.12</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>6</td>
<td>78.5</td>
<td>31.4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>7</td>
<td>113.04</td>
<td>37.68</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>8</td>
<td>153.86</td>
<td>43.96</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>9</td>
<td>200.96</td>
<td>50.24</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>10</td>
<td>254.34</td>
<td>56.52</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>11</td>
<td>314</td>
<td>62.8</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

3. To calculate the commission, total, average, maximum, and minimum:
   a. Create a worksheet as shown in the figure.
   b. In the cell D2, type the formula =0.10*C2 and press Enter. The value 100000 will be displayed.
   c. Select cell D2. Now, using the Autofill handle that appears, fill in the values for cells D3:D6.
   d. To calculate the total, select cell C8 and click AutoSum in the Editing group on the HOME tab. Excel will create a formula with the Sum function along with cell range C2:C7. Correct the range to C2:C6 and press ENTER.
   e. Similarly calculate the total for Commission.
   f. To calculate the average, select cell C9 and click AutoSum in the Editing group on the HOME tab. In the drop-down menu that appears, select Average. Excel will create a formula with the Average function along with cell range C2:C8. Correct the range to C2:C6 and press ENTER. Similarly calculate the average for Commission.
   g. To calculate the maximum, select cell C10 and click AutoSum in the Editing group on the HOME tab. In the drop-down menu that appears, select Maximum. Excel will create a formula with the Maximum function along with cell range C2:C9. Correct the range to C2:C6 and press ENTER. Similarly calculate the maximum for Commission.
h. To calculate the minimum, select cell C11 and click AutoSum in the Editing group on the HOME tab. In the drop-down menu that appears, select Minimum. Excel will create a formula with the Minimum function along with cell range C2:C10. Correct the range to C2:C6 and press ENTER. Similarly calculate the minimum for Commission.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Salesperson No.</td>
<td>Salesperson Name</td>
<td>Sales Amount</td>
<td>Commission (10%)</td>
</tr>
<tr>
<td>2</td>
<td>S101</td>
<td>Tahir Ansar</td>
<td>1000000</td>
<td>100000</td>
</tr>
<tr>
<td>3</td>
<td>S102</td>
<td>Arman Virani</td>
<td>1245000</td>
<td>124500</td>
</tr>
<tr>
<td>4</td>
<td>S103</td>
<td>Sumeera Jamil</td>
<td>2555000</td>
<td>255500</td>
</tr>
<tr>
<td>5</td>
<td>S104</td>
<td>Afifa Iqbal</td>
<td>2548800</td>
<td>254880</td>
</tr>
<tr>
<td>6</td>
<td>S105</td>
<td>Deena Choudhary</td>
<td>3550000</td>
<td>355000</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Total</th>
<th>10898800</th>
<th>1089880</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>Average</td>
<td>2179760</td>
<td>217976</td>
</tr>
<tr>
<td>9</td>
<td>Maximum</td>
<td>3550000</td>
<td>355000</td>
</tr>
<tr>
<td>10</td>
<td>Minimum</td>
<td>1000000</td>
<td>100000</td>
</tr>
</tbody>
</table>

4. To create a worksheet to calculate the total and grand total:
   a. Create a worksheet as shown in the figure.
   b. To calculate the total, select the cell E2 and type the formula =C2*D2 and press ENTER. The value 2500 will be displayed.
   c. To get the total values for all the other items, select cell E2 and drag the AutoFill handle to cell E11.
   d. To calculate the grand total, select cell E13 and click AutoSum in the Editing group on the HOME tab. Excel will create a formula with the Sum function along with cell range E2:E12. Correct the range to E2:E11 and press ENTER.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Item No.</td>
<td>Item Name</td>
<td>Quantity</td>
<td>Price</td>
<td>Total</td>
</tr>
<tr>
<td>2</td>
<td>S01</td>
<td>A4 paper</td>
<td>10</td>
<td>250</td>
<td>2500</td>
</tr>
<tr>
<td>3</td>
<td>S02</td>
<td>Mouse</td>
<td>20</td>
<td>350</td>
<td>7000</td>
</tr>
<tr>
<td>4</td>
<td>S03</td>
<td>Keyboard</td>
<td>13</td>
<td>520</td>
<td>6760</td>
</tr>
<tr>
<td>5</td>
<td>S04</td>
<td>Hard Disk (1 TB)</td>
<td>5</td>
<td>5350</td>
<td>26750</td>
</tr>
<tr>
<td>6</td>
<td>S05</td>
<td>Hard Disk (750 GB)</td>
<td>4</td>
<td>4950</td>
<td>19800</td>
</tr>
<tr>
<td>7</td>
<td>S06</td>
<td>Hard Disk (500 GB)</td>
<td>6</td>
<td>4000</td>
<td>24000</td>
</tr>
<tr>
<td>8</td>
<td>S07</td>
<td>USB (8 GB)</td>
<td>10</td>
<td>800</td>
<td>8000</td>
</tr>
<tr>
<td>9</td>
<td>S08</td>
<td>USB (4 GB)</td>
<td>9</td>
<td>600</td>
<td>5400</td>
</tr>
<tr>
<td>10</td>
<td>S09</td>
<td>USB (2 GB)</td>
<td>10</td>
<td>400</td>
<td>4000</td>
</tr>
<tr>
<td>11</td>
<td>S10</td>
<td>USB (1 GB)</td>
<td>5</td>
<td>300</td>
<td>1500</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>Grand Total</td>
<td></td>
<td></td>
<td>105710</td>
</tr>
</tbody>
</table>

**GROUP PROJECT**

This answer could be spread over two class periods. In the first, the groups should be formed and the duties of each member be decided; the students will be required to use the Internet to conduct basic research during the first lesson only.

In the second lesson, the students could compile the data they have collected into the table format, and perform their assigned tasks. Teachers can be available to guide students but try to refrain from giving answers.
Chapter 2  Creating Charts in Excel 2013

OBJECTIVE TYPE QUESTIONS

1. a. ii. Pie Chart  
   b. ii. Data label  
   c. iv. both i and ii  
   d. iii. Location  
   e. iv. all of the above

DESCRIPTIVE TYPE QUESTIONS

1. a. The components of a chart are:
   - **Data Table** It refers to the set of data values from which a chart is derived.
   - **X-Axis** It is the horizontal axis of the chart. It is also known as the category axis.
   - **Y-Axis** It is the vertical axis of the chart. It is also known as the value axis. The value of each data point is plotted on this axis.
   - **Chart Title** It is usually placed at the top of the chart and helps the user understand what the chart represents.
   - **Axis Title** It is the title given to an axis. A 2-D graph has two axes (x and y) and a 3-D graph has three (x, y, and z).
   - **Chart Area** It refers to the area within which all chart components are found. Often it is surrounded by a border.
   - **Plot Area** It is the rectangular area bounded by the two axes. The x-axis and the y-axis define the two sides of the rectangular plot area.
   - **Legend** It identifies the data series. A unique colour or pattern is assigned to each data series to make it easier to distinguish it visually.
   - **Gridlines** These are the lines that run across the plot area from each category on the x-axis and from each value on the y-axis. You can choose whether to display them or not. They make it easier to identify the value of each data point on the chart.
   - **Data Label** A label that provides additional information about a data point on a chart.

b. A combination chart is a single chart that consists of a series which uses different chart types. It may include a second value axis. For example, you may have a chart that shows both columns and lines with two value axes. The value axis for the column chart may be on the left, while for the line chart it may be on the right.

The steps to create a combo chart are as follows:
   i. Select the data range.
   ii. Click the INSERT tab. In the Charts group, click Recommended Charts. The Insert Chart dialog box appears.
   iii. Click the All Charts tab.
   iv. In the list of chart types, click Combo.
   v. For the weight, select Clustered Column as the chart type.
   vi. For the height, select Line as the chart type and click the Secondary Axis check box.
   vii. Click OK to insert the chart. Give appropriate names to the chart title and the axis titles.
c. A sparkline is a miniature chart embedded in a single worksheet cell. It provides a visual representation of data. It is different from a chart in that it is a miniature version of a chart embedded in a single cell. For example, line and column sparklines are compact versions of the standard line and column charts.

d. To delete sparklines, do the following:
   i. Select the sparklines.
   ii. Under SPARKLINES TOOLS, click the DESIGN tab.
   iii. In the Group group, click the arrow next to Clear.
   iv. Click Clear Selected Sparklines.

e. The Quick Analysis tool appears at the bottom-right corner of a selection of range and helps in creating a chart or sparklines. To create a chart using Quick Analysis tool:
   i. Select the range of cells for which a chart has to be created.
   ii. Click the Quick Analysis button.
   iii. Click the CHARTS tab.
   iv. Click the Insert Chart button. The Insert Chart dialog box appears.
   v. Select bar chart and click OK.

f. i. Line chart and column chart. Both charts are useful in seeing the changes in values over a period of time and therefore since they are looking at the number of students over a period of five years these two charts would give a clear depiction.
   ii. Since here we are looking at a single item, ice cream, and what has happened to its price over 3 years, a bar chart would be the correct choice.
   iii. We would use the pie chart; we will take 24 hours as a whole and then take averages from that whole.

g. The answer can vary, some students might agree with the statement while others might disagree–as a teacher you are looking for a logical thought process.

<table>
<thead>
<tr>
<th>Agree</th>
<th>Disagree</th>
</tr>
</thead>
<tbody>
<tr>
<td>A large number of options makes it easier to represent data in creative ways.</td>
<td>Too many options make it difficult to decide what to use.</td>
</tr>
<tr>
<td>We can add important details to charts.</td>
<td>Charts should be simple and adding too many details can be confusing for the person reading them.</td>
</tr>
<tr>
<td>Formatting options make it possible to break the monotony of seeing so much data in one place.</td>
<td></td>
</tr>
<tr>
<td>Options also allow for in-depth analysis of the chart.</td>
<td></td>
</tr>
</tbody>
</table>

h. This activity could be completed over two lessons; in the first lesson, have the students collect the data from their classmates. Students can decide which charts to make but once completed ask them to justify why they chose a particular chart. Preferable charts to be made include–line, column, bar, and pie charts.

APPLICATION-BASED QUESTIONS

a. i. Recommended charts
   ii. To create a suitable chart he should take the following steps:
      1. Create an Excel worksheet and enter the data shown in the figure. Select the desired range of cells.
2. Click the **INSERT** tab. In the **Charts** group, click the **Column** drop-down menu.
3. Click **Clustered Column** in the list.
4. A column chart is created in the centre of the worksheet.

![Column Chart](image)

**Pass Percentage**

Year 1 | Year 2 | Year 3
---|---|---
97 | 99 | 99.5
98 | 98.5 |
97.5 |
99 |
99.5 |

b. i. 13 years ii. Years 8-10 and 17-22.

c. i. To change the chart type, click the **Change Chart Type** button in the **Type** group. The **Change Chart Type** dialog box appears. Select a new chart type and a layout and click OK.

ii. To move the chart to a new worksheet:
1. Click **Move Chart** in the **Location** group. The **Move Chart** dialog box appears.
2. Click **New sheet** and type a name for the new sheet. The chart is moved to a new sheet in the workbook.

The chart is automatically scaled to fill the entire page in landscape orientation.

![Chart Comparison](image)

Column Chart

The Column chart changed to a Line chart

d. i. The shortcut method of creating a chart is to use the **Quick Analysis** button. The **Quick Analysis** button appears at the bottom-right corner of a selection of range and helps in creating a chart or sparklines.

ii. To create a chart using the **Quick Analysis** tool:
1. Select the range of cells for which the chart has to be created.
2. Click the **Quick Analysis** button.
3. Click the **CHARTS** tab.
4. Click the **Insert Chart** button. The **Insert Chart** dialog box appears.
5. Select pie chart and the desired layout for it and then click OK.
IN THE LAB

1. To create a pie chart:
   a. Enter the relevant data in a worksheet as shown in the figure.
   b. To create a pie chart, select the desired cell range.
   c. Click the INSERT tab. In the Charts group, click the Pie chart drop-down menu arrow.
   d. Select the pie chart of your choice. It will be inserted in the worksheet.
   To format the layout of the chart:
   a. In the DESIGN tab, under the Quick Layout group select a layout of your choice.
   b. To change the style of the chart, in the Chart Styles group, select a chart style of your choice.
   c. The desired changes will take place in the chart that has already been created.

2. To create a bar chart:
   a. Enter the relevant data in a worksheet as shown in the figure.
   b. Select the desired cell range.
   c. Click the INSERT tab. In the Charts group, click the Insert Bar Chart drop-down menu arrow.
   d. Select a chart of your choice. It will be inserted in the worksheet.
To change the chart type to Column chart first select the bar chart just drawn. On the Design tab that appears, click the **Change Chart Type** button in the **Type** group. The **Change Chart Type** dialog box appears. Select a new chart type, i.e. **column chart** and a layout and click **OK**.

3. a. To create a combo chart:
   i. Select the data range.
   ii. Click the **INSERT** tab. In the **Charts** group, click **Recommended Charts**. The **Insert Chart** dialog box appears.
   iii. Click the **All Charts** tab.
   iv. In the list of chart types, click **Combo**.
   v. For the weight, select **Clustered Column** as the chart type.
   vi. For the height, select **Line** as the chart type and click the **Secondary Axis** check box.
   vii. Click **OK** to insert the chart.

b. To add the axis titles:
   i. To add an X-axis title, click **Axis Title ▶ Primary Horizontal**. The X-axis title text box will appear.
   ii. To add a Y-axis title, click **Axis Title ▶ Primary Vertical**. The Y-axis title text box will appear.
   iii. To change the position of **Chart title** and **legend**, click on the respective buttons at the right of the chart and make the required changes.

c. To apply **Text Fill** and **Shape Fill**:
   i. Click on the chart title to select it. Click **Text Fill** in the **WordArt Styles** group and select a colour from the drop-down colour palette. Similarly, change the colour of the axis title.
   ii. Select the chart as a whole by clicking it. Click **Shape Fill** in the **Shape Styles** group and select a colour from the drop-down colour palette.
4. To create a **Column sparkline**:

   a. Select the data (not column headings) of a single row or, if you are creating multiple sparklines, select all the data.

   b. Click the **INSERT** tab. In the **Sparklines** group, click one of the three sparkline types—Line, Column or Win/Loss (here we will chose column type).

   c. The **Create Sparklines** dialog box appears.

   d. Specify **Location Range** as F3:F9 either by typing or selecting the required cell range. Click **OK**.

   e. Excel creates the Sparklines graphics of the type you specified. The **DESIGN** tab appears under **SPARKLINE TOOLS**.

   f. You can change the sparklines colour by clicking the **Sparkline Color** drop-down menu arrow. A list of colours appears. Select the colour of your choice.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Name</td>
<td>Quarter I</td>
<td>Quarter II</td>
<td>Quarter III</td>
<td>Quarter IV</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Safdar</td>
<td>13</td>
<td>18</td>
<td>25</td>
<td>20</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Anoosha</td>
<td>15</td>
<td>20</td>
<td>19</td>
<td>21</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Naufil</td>
<td>22</td>
<td>25</td>
<td>29</td>
<td>31</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Deena</td>
<td>21</td>
<td>17</td>
<td>24</td>
<td>22</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Waqar</td>
<td>28</td>
<td>25</td>
<td>21</td>
<td>18</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Naael</td>
<td>30</td>
<td>32</td>
<td>25</td>
<td>28</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Darwish</td>
<td>27</td>
<td>30</td>
<td>32</td>
<td>29</td>
<td></td>
</tr>
</tbody>
</table>

**GROUP PROJECT**

Please follow the guidelines on group work given on page 1 of this teaching guide. This activity could be spread over at least two lessons.

**Resources:** The students will require access to the Internet to conduct research on the uses of the different types of charts.
**Chapter 3  Computer Viruses**

### OBJECTIVE TYPE QUESTIONS

1. Choose the correct option.
   
   a. iii. both i and ii  
   b. iv. all of the above  
   c. iii. both i and ii  
   d. iv. all of these  
   e. i. Michelangelo  
   f. iii. Data files  
   g. ii. Spyware  
   h. i. Spam

### DESCRIPTIVE TYPE QUESTIONS

1. a. Macro virus  
   
   b. Virus definitions is the name given to a database of viruses that an antivirus software scans for.  
   
   c. A computer virus is a software program that has the ability to make copies of itself, and to attach itself to other programs or files.
   
   Different viruses do different things. A computer virus could be capable of any of the following:
   
   • It can infect executable program files such as word processors, spreadsheets, and operating systems.
   
   • It can infect disks by attaching itself to special programs on the hard disk, called boot records.
   
   These are the programs that the computer uses to start itself up.
   
   • It can infect files that are attached to email messages or copied to disks and pen drives. In this manner, it can spread from one computer to another.
   
   d. To protect your computer from virus infections:
   
   • Restrict access to your system, both offline and online.
   
   • Allow only trustworthy users to use the system.
   
   • Install and use antivirus software and keep it updated.
   
   e. Computer viruses spread from one computer to another by the transfer of infected data through emails, pen drives, or other sources.
   
   f. The first part of the answer will include how each virus works, as highlighted in the table below:

<table>
<thead>
<tr>
<th>Boot Viruses</th>
<th>Macro Viruses</th>
<th>Program Viruses</th>
</tr>
</thead>
<tbody>
<tr>
<td>infect the boot records of both hard disks and floppy disks—they become active when the computer is ‘booted’, i.e. turned on</td>
<td>are written in the same language in which common programs are written such as MS Excel or MS Word—they become active once the application is opened</td>
<td>infect program files and become active when the program is executed</td>
</tr>
</tbody>
</table>

The second part of the question really has no clear cut right answer, as all viruses are harmful in their own way. What you are looking for is that the justifications provided by students must be logical.
g. The first part of the answer should include a list of the features of both. See the table below:

<table>
<thead>
<tr>
<th>McAfee Virus Scan</th>
<th>Microsoft Security Essentials</th>
</tr>
</thead>
<tbody>
<tr>
<td>Freeware</td>
<td>Freeware</td>
</tr>
<tr>
<td>scans PC for viruses/spyware/malware</td>
<td>scans PC for viruses/spyware/malware</td>
</tr>
<tr>
<td>works in background</td>
<td>works in background</td>
</tr>
<tr>
<td>scans can be scheduled</td>
<td>scans can be scheduled</td>
</tr>
<tr>
<td>three alert options: immediate scan, cancel prescheduled scan, reschedule scan for later time</td>
<td>automatic updates which run every 24 hours; might need manual rescheduling if computer usually off at time of updates</td>
</tr>
<tr>
<td>1MB in size</td>
<td>7MB in size</td>
</tr>
<tr>
<td>does not clean malware</td>
<td>does not clean malware</td>
</tr>
</tbody>
</table>

There might be other features that the students list. As for the second part of the question, you should look for the logic behind the answer.

h. The students should include the list of measures mentioned on Page 45 of textbook. Let the students express themselves freely and give marks for creativity.
(Resources: Chart paper/coloured markers or pencils.)

**APPLICATION-BASED QUESTIONS**

a. i. Spam
   ii. Spam mails may carry advertisements or serve as a means of spreading malware like viruses and worms.
   iii. To avoid such mails:
      • Delete spam mails without reading them.
      • Do not give your email address to unknown people.

b. i. His computer must have been infected by a computer virus.
   ii. Other signs of a virus attack are:
      • change in file size.
      • when computer restarts on its own.
   iii. To avoid virus infections:
      • install an antivirus software and keep it updated.
      • restrict access to your computer, both offline and online.

c. i. Antivirus software
   ii. QuickHeal Antivirus and Kaspersky Antivirus
   iii. To keep an antivirus program effective:
      • It should be updated regularly.
      • The user should run full disk scans periodically.

d. i. Program virus ii. Macro virus iii. Boot viruses
IN THE LAB

1. Students should be encouraged to install an antivirus program and keep it regularly updated. They must also be asked to scan their computers periodically so as to keep them safe from virus attacks.
   Examples of antivirus programs that may be installed are: QuickHeal Antivirus, Kaspersky antivirus, Norton antivirus, Microsoft security essentials, etc.

2. a. To start PowerPoint 2013:
   i. Click Start ➤ All Programs ➤ Microsoft Office 2013 ➤ PowerPoint 2013.
   ii. The Start screen will appear. From here, you can create a new presentation, choose a template, or access your recently edited presentation.
   iii. Click Blank Presentation. A new presentation will appear.

   b. To insert a new slide, do as follows:
   i. Click the HOME tab. Click the New Slide drop-down menu in the Slides group.
   ii. Select the desired slide layout from the menu that appears.

   c. To apply a theme to a blank presentation:
   i. Click the DESIGN tab.
   ii. In the Themes group, click the More drop-down menu arrow.
   iii. More themes will appear on the screen. Select the required theme.
   iv. Right-click the selected theme to view the different ways of applying the theme. Otherwise, the theme will be applied to the entire presentation.

   d. To add text to a placeholder, click inside it and start typing.

   e. To save the changes:
   i. Click the FILE tab.
   ii. Click the Save As button. The Save As dialog box appears.
   iii. In this dialog box, select the location in which the file is to be saved. Write the name of the file and click Save.

3. Examples of antivirus programs that may be installed are: QuickHeal Antivirus, Kaspersky antivirus, Norton antivirus, Microsoft security essentials, etc.
   To search for more antivirus software, the students should be encouraged to take help of the Internet under the guidance of an adult.
   To create a PowerPoint presentation on at least five different antivirus software the steps are similar to those in Question 2 above.

4. Open a Word document and type the following:
   A computer virus is a software program that has the ability to make copies of itself, and to attach itself to other programs or files.
   Computer viruses spread from one computer to another by the transfer of infected data through emails, pen drives, or other sources.
   To protect your computer from virus infections:
   a. restrict access to your system, both offline and online.
   b. allow only trustworthy users to use the system.
   c. install and use antivirus software and keep it updated.
   d. save the document.
GROUP PROJECT

Please follow the guidelines on group work given in the beginning of this Teaching guide.

Key pieces of information to be included:

- Malware—stands for malicious software and can take form of Trojan horses, ransomware, spyware, adware, scareware, and other harmful programs.
- These programs can seriously affect your privacy and your computer’s security.
- Results of malware activity: Disrupts operations; theft of sensitive information, allows unauthorised access to system resources; slows computer or web browser speeds; problems connecting to networks; frequent freezing or crashing of the computer.

Chapter 4  Loops and Graphics in Small Basic

OBJECTIVE TYPE QUESTIONS

1. a. i. While…EndWhile b. i. 20 13 6 c. iv. GraphicsWindow.PenWidth = 5
   d. ii. GraphicsWindow.BrushColour= “Yellow” e. ii. DrawRectangle()

DESCRIPTIVE TYPE QUESTIONS

1. a. The four properties of font in GraphicsWindow are: **FontName**, **FontSize**, **FontBold**, and **FontItalic**.
   b. The While…EndWhile loop is used when the loop count is not known beforehand. The condition after While evaluates to either true or false. The statements between While and EndWhile are repeatedly executed until the condition becomes false.

   For example:
   
   ```plaintext
   Number = 0
   While Number <= 20
       TextWindow.Write(Number)
       Number = Number + 4
   EndWhile
   ```

   The output will be: 0, 4, 8, 12, 16, 20
   
   c. The PenColor property sets the colour of the pen used to draw shapes on the graphics window to the set colour. The BrushColor property sets the colour of the brush which is used to fill shapes drawn on the graphics window to the set colour.

   d. GraphicsWindow.FontName = “Times New Roman”
      GraphicsWindow.FontSize = 22
      GraphicsWindow.FontBold = “true”
      GraphicsWindow.FontItalic = “true”
   
   e. **Title**: This property sets the title of the graphics window to the desired text. For example, GraphicsWindow.
Title = “Example program” sets the title of the graphics window to “Example program”.

**Height**: This property sets the height of the graphics window to the desired pixels. For example, `GraphicsWindow.Height = 600` sets the height of the graphics window to 600 pixels.

**Width**: This property sets the width of the graphics window to the desired pixels. For example, `GraphicsWindow.Width = 600` sets the width of the graphics window to 600 pixels.

**BackgroundColour**: This property sets the background colour of the graphics window to the desired colour. For example, `GraphicsWindow.BackgroundColour = “Yellow”` sets the background colour of the graphics window to yellow.

f. The two loops introduced in this chapter are ‘For… Endfor’ and ‘While Endwhile’. ‘The For… Endfor’ loop allows the program to run as long as a condition is met–so the number of repetitions the program has to execute is known. The ‘While…Endwhile’ loop is for when the number of repetitions that the program has to execute is unknown.

If a program needs to be executed over and over again, the ‘While…Endwhile’ would be the more appropriate one to use.

g. Here you are looking for how well the student comprehends the concept of looping. They should be able to explain that looping allows the program to check for certain conditions that need to be met in order to execute it. Basically looping provides the logical framework for programming.

h. This is a lab based activity. Teachers can mark the students for the use of different features which they have learnt in class.

**APPLICATION-BASED QUESTIONS**

a. i. 20
   16
   12
   8

ii. `Number = 20
    While Number >= 5
    TextWindow.WriteLine(Number)
    Number = Number - 4
    EndWhile`

b. `GraphicsWindow.Height = 490
   GraphicsWindow.Width = 400
   GraphicsWindow.BackgroundColour = “Gold”
   GraphicsWindow.PenWidth = 5
   GraphicsWindow.DrawEllipse(100,250,200,200)
   GraphicsWindow.BrushColor = “Lime”
   GraphicsWindow.FillEllipse(100,20,200,200)}`
c. GraphicsWindow.BrushColour = “Blue”
   GraphicsWindow.FillTriangle(200,100,300,300,100,300)
d. GraphicsWindow.Height = 400
   GraphicsWindow.Width = 200
   GraphicsWindow.BackgroundColor = “OrangeRed”
   GraphicsWindow.PenWidth = 8
   GraphicsWindow.Title = “Draw Lines”
   GraphicsWindow.PenColor = “Blue”
   GraphicsWindow.DrawLine(50,75,150,350)
   GraphicsWindow.PenColor = “Green”
   GraphicsWindow.DrawLine(125,75,50,350)

IN THE LAB

1. TextWindow.Write(“Enter the number whose table you want”)
   Number = TextWindow.ReadNumber()
   For I = 1 to 10
      Product = Number * I
      TextWindow.WriteLine(Number + “X” + I + “=” + Product)
   EndFor

2. TextWindow.Write(“Enter the number of days in
   the month excluding holidays”)
   TextWindow.Write(“ ”)
   Number = TextWindow.ReadNumber()
   start:
   While Number >=1
      TextWindow.Write(“Enter the number of days
      the student is present”)
      TextWindow.Write(“ ”)
      Present = TextWindow.ReadNumber()
      If(Present = -1) Then
         Goto start
      EndIf
      Attendance = Present/Number*100
      TextWindow.WriteLine(“Percentage of Attendance”)
   EndWhile

3. TextWindow.Write(“Enter the lower limit of
   temp. in Fahrenheit ”)
   Temp1 = TextWindow.ReadNumber()
   TextWindow.Write(“Enter the upper limit of
   temp. in Fahrenheit ”)
   Temp2 = TextWindow.ReadNumber()
TextWindow.WriteLine( "Fahrenheit    Celsius")
For I= Temp1 to Temp2
Celsius = (I-32)* 5/9
TextWindow.Write(I)
TextWindow.Write("    ")
TextWindow.WriteLine(Celsius)
EndFor

GraphicsWindow.Penwidth = 5
GraphicsWindow.FontSize= 24
GraphicsWindow.PenColor = “Yellow”
GraphicsWindow.DrawRectangle(10,20, 300, 200)
GraphicsWindow.BrushColor = “Red”
GraphicsWindow.FillRectangle(10,20,300,200)
GraphicsWindow.FontBold = “true”
GraphicsWindow.FontItalic = “true”
GraphicsWindow.DrawText(110,230,”Rectangle”)

5.

GROUP PROJECT

This is an open-ended question and the final presentation will be deciding factor for the marks given.
It could require two lessons for this group work.
(Resources required: Access to the Internet for research purposes; computer lab for the designing of presentation.)
Chapter 5  Introduction to Visual Basic

OBJECTIVE TYPE QUESTIONS

1. a. iv. all of these b. ii. Button c. iii. Form Design d. ii. TextBox e. ii. Solution Explorer

DESCRIPTIVE TYPE QUESTIONS

1. a. Title Bar: The title bar at the top of the window displays the title of the project.
   Menu Bar: The menu bar consists of many drop-down menus. Clicking on any option of the menu bar makes it active.
   Form Window: The Form window is the primary work area that forms the background of the application. The user can place objects on the form.
   Toolbox: The Toolbox contains the controls. Controls are GUI components that can be added to the form.

b. The four steps in developing an application are:
   i. Create a form.
   ii. Place controls on the form.
   iii. Set properties for the controls.
   iv. Add code to the controls to handle the events.

c. The two methods of placing controls on a form are given below:
   First Method:
   i. Double-click on the control in the Toolbox. Here the control chosen is a button. By default, buttons are named Button1, Button2, etc.
   ii. The control appears at the top-left corner of the form. To change the position of the control, click on it, hold down the left mouse button, and drag it to the new location.
   iii. To resize the control, drag the resize pointers on its edges or corners.
   iv. Drag the edges pointer for changing the size either horizontally or vertically.
   v. Drag the corner pointers for changing the size diagonally.
   Second Method:
   i. Click on the control in the Toolbox, and with the left mouse button pressed down, drag and drop it onto the form.
   ii. Reposition the control by holding down the left mouse button and dragging it to a new location. To resize the control, drag one of its edges or corners.

d. After declaring a variable using the Dim statement, one can assign a value to it using an assignment statement. The general format of an assignment statement is:
   Variable = Expression or Constant
   For example:
   A = 100 or
   A = B * C

e. The arithmetic operators used in Visual Basic are: Addition (+), Subtraction (-), Multiplication (*), Exponent (^), Division (/), Integer Division (\), and Modulus (Mod).
f. Below are a few points that show the usefulness of event driven programming:
   • Programmes can be put written and altered easily
   • Tools can be selected from the tool bar directly
   • Makes programming easier through its predictive feature—the software predicts what the programme is going to type

g. Differences between MS Small and Visual Basic

<table>
<thead>
<tr>
<th>MS Small Basic</th>
<th>Visual Basic</th>
</tr>
</thead>
<tbody>
<tr>
<td>creates Windows programmes</td>
<td>event driven programming</td>
</tr>
<tr>
<td>programmes can be shared even if someone does not have Small Basic on computer</td>
<td></td>
</tr>
<tr>
<td>uses loops</td>
<td>code written between Private Sub and End Sub</td>
</tr>
<tr>
<td>uses WriteLine() and Write()</td>
<td></td>
</tr>
<tr>
<td>easy to manipulate graphics</td>
<td></td>
</tr>
</tbody>
</table>

h. You will be able to assess the program for being written in the correct syntax.

**APPLICATION-BASED QUESTIONS**

a. i. Text property in the Properties window
   ii. BackColor

b. i. 5.333  ii. 5  iii. 1  iv. 125

c. i. Dim a, b, c as Integer
   ii. Dim a as Integer, b as String, c as Single

d. i. Label  ii. TextBox  iii. Button

e. i. Dim Num as Integer
     Num = TextBox1.Text
   ii. Dim MyName as String
     MyName = “XYZ”

**IN THE LAB**

1. To create the required form:
   Start Microsoft Visual Studio 2013 Express and create a Windows Forms Application named “Square and Cube”.
   Place four labels, three Textboxes and one button in the form as given in the figure. Set the properties according to the following table:
Controls | Properties
--- | ---
Label1 | Text: Square and Cube Font: Bold, 14
Label2 | Text: Enter a number Font: Bold, 12
Label 3 | Text: Square of the number Font: Bold, 12
Label4 | Text: Cube of the number Font: Bold, 12
TextBox1 | BorderStyle: FixedSingle
TextBox2 | BorderStyle: FixedSingle, Enabled: False
TextBox3 | BorderStyle: FixedSingle, Enabled: False
Button1 | Text: Calculate Font: Bold, 14

3. To create a form as shown in the figure:
   a. Start Microsoft Visual Studio 2013 Express and create a Windows Forms Application named “Area of Rectangle”.
   b. Place five labels, four textboxes and two buttons in the form as given in the figure. Set the properties according to the following table:

<table>
<thead>
<tr>
<th>Controls</th>
<th>Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label1</td>
<td>Text: Area of Rectangle, Font: Bold, 14</td>
</tr>
<tr>
<td>Label2</td>
<td>Text: Enter Length</td>
</tr>
<tr>
<td>Label 3</td>
<td>Text: Enter Breadth</td>
</tr>
<tr>
<td>Label4</td>
<td>Text: Area of the Rectangle</td>
</tr>
<tr>
<td>Label5</td>
<td>Text: Perimeter of the Rectangle</td>
</tr>
<tr>
<td>TextBox1</td>
<td>BorderStyle: FixedSingle</td>
</tr>
<tr>
<td>TextBox2</td>
<td>BorderStyle: FixedSingle, Enabled: False</td>
</tr>
<tr>
<td>TextBox3</td>
<td>BorderStyle: FixedSingle, Enabled: False</td>
</tr>
<tr>
<td>TextBox4</td>
<td>BorderStyle: FixedSingle, Enabled: False</td>
</tr>
<tr>
<td>TextBox5</td>
<td>BorderStyle: FixedSingle, Enabled: False</td>
</tr>
<tr>
<td>Button1</td>
<td>Text: Area</td>
</tr>
<tr>
<td>Button2</td>
<td>Text: Perimeter</td>
</tr>
</tbody>
</table>

c. Double-click the Area button. In the window that appears, type the following code:
   
   ```c
   TextBox4.Text = Val (TextBox1.Text) * Val (TextBox2.Text)
   TextBox5.Text = Val (TextBox1.Text) + Val (TextBox2.Text)
   ```

d. Select File > Save All to save the project.

e. Press F5 to run the program.
c. Double click the **Area** button. In the window that appears, type the following code:

```
TextBox3.Text = Val(TextBox1.Text) * Val(TextBox2.Text)
```

d. Double click the **Perimeter** button. In the window that appears, type the following:

```
TextBox4.Text = 2 * (Val(TextBox1.Text) + Val(TextBox2.Text))
```

e. Select **File ▶ Save All** to save the project.

f. Press F5 to run the program.

4. To create a form as shown in the figure:

a. Start Microsoft Visual Studio 2013 Express and create a Windows Forms Application named “Marks Calculator”.

b. Place six labels, five Textboxes and one button in the form as given in the figure. Set the properties according to the following table:

<table>
<thead>
<tr>
<th>Controls</th>
<th>Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label1</td>
<td>Text: Marks Calculator Font: Bold, 14</td>
</tr>
<tr>
<td>Label2</td>
<td>Text: Enter marks in Subject 1 Font: Bold, 12</td>
</tr>
<tr>
<td>Label 3</td>
<td>Text: Enter marks in Subject 2 Font: Bold, 12</td>
</tr>
<tr>
<td>Label4</td>
<td>Text: Enter marks in Subject 3 Font: Bold, 12</td>
</tr>
<tr>
<td>Label5</td>
<td>Text: Total Font: Bold, 12</td>
</tr>
<tr>
<td>Label6</td>
<td>Text: Average Font: Bold, 12</td>
</tr>
<tr>
<td>TextBox1</td>
<td>BorderStyle: FixedSingle</td>
</tr>
<tr>
<td>TextBox2</td>
<td>BorderStyle: FixedSingle</td>
</tr>
<tr>
<td>TextBox3</td>
<td>BorderStyle: FixedSingle</td>
</tr>
<tr>
<td>TextBox4</td>
<td>BorderStyle: FixedSingle, Enabled: False</td>
</tr>
<tr>
<td>TextBox5</td>
<td>BorderStyle: FixedSingle, Enabled: False</td>
</tr>
<tr>
<td>Button1</td>
<td>Text: Calculate Font: Bold, 14</td>
</tr>
</tbody>
</table>

c. Double click the **Calculate** button. In the window that appears, type the following code:

```
TextBox4.Text = Val(TextBox1.Text) + Val(TextBox2.Text) + Val(TextBox3.Text)
TextBox5.Text = Val(TextBox4.Text) / 3
```

d. Select **File ▶ Save All** to save the project.
e. Press F5 to run the program.

5. To create a form as shown in the figure:
   a. Start Microsoft Visual Studio 2013 Express and create a Windows Forms Application named “Convertor”.
   b. Place four labels, three Textboxes and one button in the form as given in the figure. Set the properties according to the following table:

<table>
<thead>
<tr>
<th>Controls</th>
<th>Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label1</td>
<td>Text: Convertor Font: Bold, 14</td>
</tr>
<tr>
<td>Label2</td>
<td>Text: Enter height in centimetres Font: Bold, 12</td>
</tr>
<tr>
<td>Label 3</td>
<td>Text: Height in feet Font: Bold, 12</td>
</tr>
<tr>
<td>Label4</td>
<td>Text: Height in inches Font: Bold, 12</td>
</tr>
<tr>
<td>TextBox1</td>
<td>BorderStyle: FixedSingle</td>
</tr>
<tr>
<td>TextBox2</td>
<td>BorderStyle: FixedSingle, Enabled: False</td>
</tr>
<tr>
<td>TextBox3</td>
<td>BorderStyle: FixedSingle, Enabled: False</td>
</tr>
<tr>
<td>Button1</td>
<td>Text: Convert Font: Bold, 14</td>
</tr>
</tbody>
</table>

c. Double click the **Convert** button. In the window that appears, type the following code:
   
   ```csharp
   TextBox2.Text = Val (TextBox1.Text) /30.48
   TextBox3.Text = Val (TextBox1.Text) /2.54
   ```

d. Select **File ▶ Save All** to save the project.
e. Press F5 to run the program.

## GROUP PROJECT

You will be marking students on the basis of their research, the creativity of the poster, and also the cooperation amongst them as a group. Two lessons should be ideal for this activity. In the first lesson, the students should be allowed access to the Internet to conduct research about the different languages. In the second lesson, they should work on designing the poster using MS Publisher or PowerPoint.

(Resources: access to the Internet, and computer lab.)

Below are some basics about each of the languages

<table>
<thead>
<tr>
<th>C#</th>
<th>Javascript</th>
<th>Python</th>
</tr>
</thead>
<tbody>
<tr>
<td>developed by Microsoft in 2002</td>
<td>created in 1995 by Brendan Eich</td>
<td>first implemented in 1989</td>
</tr>
<tr>
<td>used to develop apps for desktops, mobiles, and tablets</td>
<td>used in web pages</td>
<td>general purpose programming language</td>
</tr>
<tr>
<td></td>
<td></td>
<td>used for web programming, desktop application development</td>
</tr>
</tbody>
</table>
Chapter 6  Communication on the Internet

OBJECTIVE TYPE QUESTIONS

1. Choose the correct option.
   a. iii. both i and ii     b. i. SixDegrees     c. ii. Blog posts     d. iv. all of these
   e. iii. both i and ii     f. iv. all of these     g. ii. 2004     h. i. Jack Dorsey

DESCRIPTIVE TYPE QUESTIONS

1. a. The advantage of using an online sharing service is that you do not have to support and maintain the data and computers yourself.
    Information in an online file sharing service can be accessed from any device with an Internet connection, including smartphones and tablets, and by anyone who has data access rights.

b. Picasa is used to:
   • view and organise all the photos on your computer.
   • edit and add effects to your photos.
   • share the photos on web albums in the Picasa web albums site.

c. Call of Duty and Tomb Raider

d. ThinkFree, Google Apps

e. Online telephony is a technology that allows users to make telephone calls over the Internet.

f. Social networking is a service in which a website provides a virtual community for people to keep in touch with friends or share common interests. Facebook and Twitter are two popular social networking websites.

g. A program or a website that allows you to keep up with new content from websites of your interest is called a feed reader.

h. Two things to be kept in mind while chatting are:
   • Do not reveal any personal information.
   • Use decent language while talking.

i. This question will have a variety of responses in terms of the students’ three favourite communication choices on the Internet. They could list any one of the following:
   • Email
   • Facebook
   • Instagram
   • Snapchat
   • SMS
   • WhatsApp
   • Chatrooms

Advantages and disadvantages will also vary in terms of what each student thinks, but teachers are looking for a logical approach to both. Some common advantages/disadvantages are listed below but do not apply to any one form of communication on the Internet.
Advantages:
- It is quick—information can be shared quickly.
- It can communicate with people across the world easily.
- It is relatively cheap.

Disadvantages:
- It can be addictive and people want to just keep using it.
- It reduces physical interaction with people.
- Due to the slang language used, it may not be helpful for the development of correct language usage.

j. Some of the safety hazards for sharing personal information on the Internet include:
- People can hack into insecure sites and find out his physical address.
- He can be targeted for phishing scams.
- Hackers can hack his email and have access to all his personal correspondence.
- His computer could be attacked by malware.

k. For this question the answers will vary. What teachers are looking for is a well thought out piece of writing, which shows the student has spent some time thinking about and trying to grasp what it means to communicate wisely on the Internet. Some points that could be included in the blog are (there might be others just as good, or even better):
- Always double-check that the site which you are on is not a fake site.
- Always read the fine print when filling in information.
- Avoid giving critical information such credit card/debit card numbers.
- Do not share information about your family.
- Make sure your computer is protected by an appropriate antivirus.

**APPLICATION-BASED QUESTIONS**

a. The best way to share the files is via online file sharing services. She can make use of a cloud computing service such as Google Drive.

b. She can make use of Picasa.

c. He can send E-Greetings to wish his friend. For this purpose, he can use the website [www.123greetings.com](http://www.123greetings.com).

d. Online telephony, for example Skype.

**IN THE LAB**

1. The student can make use of Picasa for this task. The steps needed to upload the photos using Picasa are:
   a. Download the Picasa program from [picasa.google.com](http://picasa.google.com) and install it.
   b. Double-click the Picasa shortcut on the Windows Desktop to start Picasa.
   c. Picasa scans the computer and displays all the pictures it finds, organised by folder. Picasa saves these imported photos on your computer and displays them automatically.
   d. Use the **Upload** button to transfer photos to your Picasa Web albums account

2. To send a card via 123greetings.com:
   a. Open the Website [www.123greetings.com](http://www.123greetings.com).
   b. Type ‘New Year’ in the **Search** text box and click **Go**. You will see cards available in the selected category.
c. Click the card you wish to send. The card page shows you the full version of the e-card.
d. To send the card, click the **Send** button. Then follow the steps to select the friends and send the card.

3. Students should be encouraged to find out websites for the listed functions on the Internet (online gaming under the guidance of an adult).

4. Students may consider the following steps to create a blog:
   a. Select a blog host. A host is a website whose blogging platform is used for blogging. Wordpress selva, Blogger, Tumbir, etc. are a few blog hosts.
   b. Determine what exactly is your need. A free web hosting service would do, if you want your blog to be strictly personal, and are not interested in communicating with other bloggers. Otherwise, use a paid hosting service which helps create a blog with more advanced features.
   c. Familiarise yourself with the details of the hosting service you have chosen to use.
   d. Design the appearance of your blog. Choose, say, a simple background over a loud one. The background may contain:
      i. photographs of animals, plants, etc.
      ii. a simple background in your favorite colour
      iii. pictures of books or any other objects of your choice

---

**GROUP PROJECT**

Students need to be divided into teams (following the guidelines mentioned on page 1 of this teaching guide). They will then have to conduct a mini-research project on how to create blogs, whether it’s on WordPress or Blogger. Once they know the steps required to create them, groups will have to decide on their topics and make their blogs accordingly. This task can be broken into two lessons, the research work and the actual creation.

---

**Chapter 7 More Tools in Flash**

**OBJECTIVE TYPE QUESTIONS**

1. a. Library b. instance c. corner d. Property e. animations
2. a. i. Modify b. iv. All of these c. i. Timeline Effects d. ii Ctrl + B e. iii. both i and ii f. i. Alpha g. iv. all of these h. i. File

**DESCRIPTIVE TYPE QUESTIONS**

1. a. The **Pen** tool is used for drawing precise paths such as straight lines or smooth curves.
   b. To import clip art or any other image from your computer:
      i. Select **File ▶ Import ▶ Import to Stage**.
      ii. The **Import** dialog box appears.
      iii. Select the drive and the folder. Select the picture you want to insert and click **Open**.
c. Free transform tool is used to rotate an object.

d. To move an object from one position to another:
   i. Select the object and click the **Free Transform** tool.
   ii. Position the pointer over the object such that the pointer changes to a cross.
   iii. Drag the object to a new position with the left mouse button pressed.

e. To scale an object in a single direction, select the object and click the **Free Transform** tool. Drag one of the side handles in the desired direction.

f. Symbols are stored in a folder called Library.

g. To group the outline and the fill of an object:
   i. Using the **Arrow** tool, select both the outline and the fill.
   ii. Select **Modify ▶ Group**.

h. Yes, text can be converted into basic shapes. The steps are:
   i. Select the text.
   ii. Select **Modify ▶ Break Apart**. This breaks the single text block into multiple text blocks.
   iii. Select **Modify ▶ Break Apart** once more. The characters can now be converted into shapes. They cannot be considered text any more. You can no longer change the font, font size, etc.
   iv. Click outside the converted text to deselect the shapes. Now you can manipulate these shapes like any other shape. Move the pointer to the edge of one of the characters and drag to reshape it. You can use the **Paint Bucket** tool to fill this reshaped character with another colour or gradient.
   
   i. The reason is that by converting them to basic shapes they can be manipulated more easily. This means it makes it easier to add colour to them, alter the way they look to add the effects that you would want in an animation.

j. Flash is essentially a software which is used for animations and it is because of this fact that it relies heavily on the visual aspect. This is why it needs to be able to give gradients or fill colour into different shapes.

k. The teacher should look out for the correct use of the different tools. Students could be asked which tools they used by randomly picking on parts of the finished document; or they could be asked to explain why they used a certain tool. Teachers are looking for the student’s ability to demonstrate a learned skill set.

**APPLICATION-BASED QUESTIONS**

a. i. Text tool
   ii. Yes. The **Modify** menu and the **Break Apart** option.
   iii. **Selection** tool

b. i. **Timeline effects**
   ii. The **Insert** menu and the **Timeline Effects** option.
   iii. Explode and fade in.

c. i. When we draw an object in Flash it creates two objects corresponding to it: the **outline** and the **fill**. To move the object to a new position, we need to select both the **fill** and the **outline**. If we do not select both, only the selected part will move. Ummayma is selecting only the outline, and so she is not able to move the whole object
   ii. This problem can be solved by grouping the two objects together.
iii. To group the outline and the fill of an object:
   • Using the Arrow tool, select both the outline and the fill.
   • Select Modify ▶ Group.

d.  
i. The File menu and the Import option.
   ii. Free Transform tool.
   iii. To rotate an object:
       • Select the object and click the Free Transform tool.
       • Now position the pointer over one of the four corner handles of the object.
       • When the pointer changes to a curved arrow, click and drag to rotate the object.

**IN THE LAB**

1. To create a new flash document and animate it using the Timeline effects:
   a. Create a new Flash document.
   b. Use the Text tool to write Amir on the stage.
   c. Right-click the text. From the context menu that appears, select Timeline Effects ▶ Effects. Then select the desired effect from the list. Or select Insert ▶ Timeline Effects and then select the desired effect from the list.
   d. Choose an animation, for example, Effects ▶ Explode. The Explode dialog box appears. On the right, it shows a preview of the animation with default settings. Change the settings if desired and click OK.
   e. Notice the change in the Timeline window. It now has frames and animation.
   f. Save the file. Press ENTER to play the movie.

To change Amir’s name to another name by applying shape tweening
   a. Select frame 21 and insert a keyframe by pressing F6.
   b. Select Modify ▶ Break Apart twice.
   c. Select frame 40 and insert a keyframe by pressing F6.
   d. Delete the old text. Use the Text tool again and enter your own name
   e. With frame 40 still selected, select the text with the Arrow tool. As you did earlier, select Modify ▶ Break Apart twice.
   f. Select any frame between frame 21 and frame 40. In the Property inspector, click the dropdown menu arrow of the Tween option and select Shape.
   g. Save the file and play the movie

2. To create a flash animation:
   a. Create a new Flash document.
   b. Select frame 1. Use the Text tool to write “HAPPY” on the stage.
   c. Use the Arrow tool to select the text and select Modify ▶ Break Apart.
   d. Select Modify ▶ Break Apart again.
   e. Select frame 20 and insert a keyframe by pressing F6.
   f. Delete the old text. Use the Text tool again and enter the words “New Year”
   g. With frame 20 still selected, select the text with the Arrow tool. As you did earlier, select Modify ▶ Break Apart twice. Select any frame between frame 1 and frame 20. In Property inspector, click the dropdown menu arrow of the Tween option and select Shape.
h. Select frame 21 and insert a keyframe by pressing F6.

i. Right-click the text. From the context menu that appears, select Timeline Effects ▶ Effects. Then select the desired effect from the list. Or select Insert ▶ Timeline Effects and then select the desired effect from the list.

j. Choose an animation, for example, Effects ▶ Explode. The Explode dialog box appears. On the right, it shows a preview of the animation with default settings. Change the settings if desired and click OK.

k. Notice the change in the Timeline window. It now has frames and animation.

l. Save the file and play the movie.

3. The steps to convert an existing drawing into a symbol are:
   a. Select the Arrow (Selection) Tool.
   b. Draw a selection area around the object on the Stage to select it.
   c. Select Modify ▶ Convert to Symbol. The Convert to Symbol dialog box appears.
      i. Type a Name for the symbol.
      ii. Type of symbol can be a Movie clip, a Button, or a Graphic. Choose Graphic.
      iii. Click OK. The symbol now gets added to the Library panel.

4. To convert text into shape:
   a. Select the text.
   b. Select Modify ▶ Break Apart. This breaks the single text block into multiple text blocks.
   c. Select Modify ▶ Break Apart once more. The characters can now be converted into shapes. They cannot be considered text any more. You can no longer change the font, font size, etc.
   d. Click outside the converted text to deselect the shapes. Now you can manipulate these shapes like any other shape. Move the pointer to the edge of one of the characters and drag to reshape it. You can use the Paint Bucket tool to fill this reshaped character with another colour or gradient.

GROUP PROJECT

Teachers will need to assess the correct use of animating text using time line effects when the projects are completed. The rest of the questions will have a variety of responses as each group will present their view points in front of the class.

Chapter 8 Animations in Flash

OBJECTIVE TYPE QUESTIONS

1. a. i. Filters  
   b. ii. above  
   c. i. Onion skin  
   d. iii. Timeline window  
   e. i. Timeline  
   f. ii. fifth  
   g. iii. Timeline  
   h. i. Stage

DESCRIPTIVE TYPE QUESTIONS

1. a. To convert a layer into a mask layer, right-click the layer name and select Mask in the context menu.
   b. The Onion Skin feature lets you see the relative position of an object over several frames.
c. To change the order of layers, click the name of the layer you want to move and drag it to the required position.

d. Yes, we can. For this, click the name of the layer and click the Delete Layer icon at the bottom of the Timeline.

e. Keyframes are the frames with black dots.

f. To insert a keyframe: F6, To insert a frame: F5

g. To apply a filter to an object do the following:
   i. Open a new Flash document.
   ii. Select frame 1.
   iii. Select the Text Tool and type Having Fun! on the Stage.
   iv. To apply a Bevel filter to the text:
      • Select the text block using the Selection (Arrow) Tool.
      • Click the Filters panel in the Flash window.
      • Click Add Filter on the Filters panel.
      • Click Bevel in the menu that appears.

h. The steps for adding sound to an animation are:
   i. Open the Flash file in which you want to add sound.
   ii. To import the sound to the Library:
      • Select File ▶ Import ▶ Import to Library.
      • The Import to Library dialog box appears.
      • Select the file and click OK.
   iii. Notice that the sound file is added to the Library and has a Sound icon.
   iv. To add sound to the animation:
      • Create a new layer by clicking the Insert Layer button in the Timeline.
      • Rename this layer as Sound.
      • Select the first Keyframe in the Sound layer.
      • Notice in the Timeline that the Sound layer displays the sound waves of the sound file.

i. Layers are an important part of the Flash software because they allow the user flexibility to structure the animations the way they want. The fact that layers can be added or deleted and that changes made to any one layer does not affect other layers gives tremendous control to the animator in how the finished animation will look.

j. Masking layers can be used while animating in Flash. The user can apply to make it seem that something is appearing from behind a curtain to create an effect of being slowly revealed. Filters are built in visual effects, which allow the user to add a gradient glow or just a glow, bevel or add a drop shadow to the animation. Both masking layers and filters add to the quality of the animation. Masking layers affect how the animation runs while filters are more concerned with the visual aspect, such as colour and glow.

k. This type of question provides students with the opportunity to be creative. To check their knowledge of the commands and tools, ask students to explain how or why they used a certain tool.
APPLICATION-BASED QUESTIONS

a. i. Yes, we can. For this, double-click the old layer name (here Layer 3) and type the new name (here Polygon).
   ii. For this, click the Circle layer and drag it above the Rectangle layer.
   iii. The contents of the Circle layer are hidden. A cross mark indicates a hidden layer.

b. i. Frame 1 and Frame 35 are keyframes.
   ii. Frame 16
   iii. Select INSERT ► Timeline ► Layer. This will create a new layer at the bottom of the timeline. To bring it to the desired position, click on its name and drag it above the Balloon layer.

c. i. Shape tweening
   ii. The shape on which shape tweening is to be applied must not be converted into a symbol.
   iii. Yes she can add sound to a Flash animation. Flash supports sound formats such as, MP3, AIF, WAV, etc.

d. i. Show/Hide layer
   ii. Lock/Unlock layer
   iii. Insert Layer
   iv. Motion Guide button

IN THE LAB

1. To create a document using Mask the layer:
   a. Create a new Flash document.
   b. Select Modify ► Document to display the Document Properties dialog box and change the Background color to black.
   c. Rename Layer 1 to Hope (or any other meaningful name).
   d. Select the Text tool and choose your desired font, size, colour, etc., in the Property inspector. Type Nothing is Impossible! on the stage.
   e. Click Insert Layer at the bottom of the Timeline to insert a new layer. Rename the new layer Mask.
   f. Click Frame 1 of the new Mask layer. Use the Oval tool to draw a white-coloured oval that is bigger than the height of the text. Convert it into a symbol.
   g. Select the Hope layer. Click frame 50 and press F6 to insert a keyframe.
   h. Select the Mask layer. Click frame 50 and press F6 to insert a keyframe.
   i. With the Mask layer selected, drag the oval symbol to the far end of the text.
   j. Create motion tween in the Mask layer: With the Mask layer selected, click any frame between frames 1 and 50 and choose Motion in the Tween option of the Property inspector.
   k. To convert the layer named Mask into a Flash mask layer, right-click the layer name and select the Mask option in the context menu. This locks the Mask and the Hope layers together. The Mask layer hides most of the Hope layer. Notice the change in the layer icons.
   l. Save the file and play the movie. You will notice that as the oval moves across the screen, the text behind it becomes visible. The oval in the mask layer acts like a hole in a curtain.
To add sound to the animation:

a. Open the flash file in which you want to add animation.
b. To import the sound to the Library:
   i. Select File ▶ Import ▶ Import to Library.
   ii. The Import to Library dialog box appears.
   iii. Select the file and click OK.
c. Notice that the sound file is added to the Library and has a Sound icon.
d. To add sound to the animation:
   i. Create a new layer by clicking the Insert Layer button in the Timeline.
   ii. Rename this layer as Sound.
   iii. Select the first keyframe in the Sound layer.
   iv. Notice in the Timeline that the Sound layer displays the sound waves of the sound file.

2. To apply shape tweening:

a. Create a new Flash document.
b. Rename Layer 1 to Circle.
c. Click Frame 1. Select the Oval Primitive tool, set fill colour to orange, and draw a circle.
d. Select frame 20 in the Timeline and insert a blank keyframe by pressing F7 or by selecting Insert ▶ Timeline ▶ Blank Keyframe.
e. Draw a pentagon shape on the Stage.
f. Click on any frame between 1 and 20 in the Timeline. Right click and select the Create Shape Tween option from the context menu.
g. Select Frame 1 in the Timeline and press Enter to play the movie.

3. To apply animation using motion guide:

a. Create a new Flash document.
b. Rename Layer 1 and give it the name Plane.
c. Click Frame 1. Select File Import ▶ Import to Stage and import a picture of a paper plane.
d. Click Frame 50 and insert a keyframe by pressing F6.
e. To create a motion tween for the plane, click any frame between Frames 1 and 50 and choose Motion in the Tween menu of the Property inspector.
f. Click Add Motion Guide in the Timeline window. This creates a motion guide layer above the Plane layer. The name of this layer is Guide: Plane.
g. With the Guide: Plane layer selected, click the Pencil tool, and draw a path on the Stage.
h. Select the Plane layer. Click any frame between Frame 1 and Frame 50.
i. Click the Snap checkbox in the Property inspector. Selecting Snap will snap the registration point of the object to the motion path. Also select the Orient to Path option.
j. With the Plane layer still selected, click Frame 1.
k. Place the paper plane on the path such that the registration point of the paper plane is exactly above the start of the path.
l. Click Frame 50 of the Plane layer.
m. Now place the paper plane such that the registration point of the paper plane is exactly above the end of the path.

n. Hide the motion guide layer.

o. Save the file and play the movie.

4. To apply filters to text:
   a. Open a new Flash document.
   b. Select Frame 1.
   c. Select the Text tool and type Happy New Year on the Stage.
   d. To apply a Bevel filter to the text:
      i. Select the text block using the Selection (Arrow) tool.
      ii. Click the Filters panel in the Flash window.
      iii. Click Add Filter on the Filters panel.
      iv. Click Bevel in the menu that appears.
   e. The Filters panel will now show options for the Bevel filter.
      i. Click the drop-down menu arrow of the Type option and select Outer.
      ii. The Blur X and Blur Y options set the width and the height of the Bevel. Use the sliders and try different values.
      iii. Select the Shadow colour to Blue and the Highlight colour to green.
      iv. The Angle option specifies the angle of the shadow cast by the bevelled edge.
      v. The Distance option specifies the width of the bevel. Set the value to 11.
   f. Select Frame 40 in the Timeline and insert a keyframe by pressing F6.
   g. Apply a Glow filter to the text, following the same steps as with the Bevel filter.
   h. The Glow filter options appear in the Filters panel. Use Blur X and Blur Y to set the width and the height of the glow, and set the glow colour. You can also change the settings for Bevel filter in this frame.
   i. Save the file and play the movie.

To apply the Timeline effects:
   a. Open the last animation in which you applied a filter to the text Happy New Year!
   b. Select frames 41 and 42 and insert Keyframes.
   c. Select frame 43. Select Insert Timeline Effects Expand.
   d. A dialog box appears with options for the Expand effect.
   e. Specify the required options. You can preview the animation, i.e. the text expanding. Click OK.

To apply a masking layer:
   a. Select Modify ▶ Document to display the Document Properties dialog box and change Background colour to black.
   b. Click Insert Layer at the bottom of the Timeline to insert a new layer. Rename the new layer Mask.
   c. Click Frame 1 of the new Mask layer. Use the Oval tool to draw a white-coloured oval that is bigger than the height of the text. Convert it into a symbol.
   d. Select the Mask layer. Click frame 50 and press F6 to insert a keyframe.
   e. With the Mask layer selected, drag the oval symbol to the far end of the text.
   f. Create motion tween in the Mask layer: With the Mask layer selected, click any frame between frames 1 and 50 and choose Motion in the Tween option of the Property inspector.
g. To convert the layer named Mask into a Flash mask layer, right-click the layer name and select the Mask option in the context menu. This locks the Mask and the Layer 1 together. The Mask layer hides most of the Layer 1 layer. Notice the change in the layer icons.

Save the file and play the movie. You will notice that as the oval moves across the screen, the text behind it becomes visible. The oval in the mask layer acts like a hole in a curtain.

**GROUP PROJECT**

Please refer to the group work guidelines mentioned on page 1 of this teaching guide.

Two lessons could be allotted in the lab for this activity. Consider giving more marks to those groups who try more complicated animations.

---

**Chapter 9  Introduction to HTML 5**

**OBJECTIVE TYPE QUESTIONS**

1. a. iii. both i and ii  
   b. iv. all of these  
   c. iv. all of these  
   d. iii. <body>

   e. ii <br>  
   f. i. CSS  
   g. iv. all of these  
   h. ii. Background-attachment

**DESCRIPTIVE TYPE QUESTIONS**

1. a. The two main types of HTML editors are: WYSIWYG editors and Text editors. An example of WYSIWYG editors is Google Web Designer and that of Text editors is Notepad.

   b. HTML elements are the building blocks of HTML documents. They consist of opening and closing tags, and the content between them.

   c. The HTML elements that include both the ON and the OFF tags are called container elements while those which do not require an OFF tag are called empty elements.

   d. The values that the background-repeat property can take are repeat, repeat-x, repeat-y, and no-repeat.

   e. Cascading Style Sheets (CSS) is a style sheet that provides a set of style rules for displaying HTML elements in a Web page.

   f. This question deals with the interpretation of the functionality of the WYSIWYG model. WYSIWYG stands for What You See Is What You Get and is a good way to make people more comfortable with web designing because the results are what you think they will be. This model does not require the user to know a particular language such as HTML to design a web page and the process is quicker.

   g. Students should be able to identify the properties and mention at least one of the background properties, which are colour, image, position, attachment and repeat. Ask them to justify their answer.

   h. It may be best to split this exercise into two components. First have the students write the code in class and then allow them to execute it during the lab period. The written code should be submitted.
APPLICATION-BASED QUESTIONS

a. i. The background-image property was used to set the background image.
   ii. The background-position property, with the value centre bottom must be used so that the image appears as shown in the figure.

b. i. Property: background-position
    Value: center center
   ii. Property: background-repeat
    Value: no-repeat

c. <style type= ”text/css”>
   body { background-color: yellow}
   </style>

d. Among the HTML elements he has used any three are title, body, and head. Among the background properties he has used any two are background-repeat and background-image.

IN THE LAB

1. To create an HTML document:
   a. Start Notepad and type the following HTML code:
      ```html
      <!DOCTYPE html>
      <html>
      <title>Our National Bird</title>
      <style type = "text/css">
      body { background-image: url ('chakor.jpg');
      background attachment: fixed; background-repeat: no-repeat }
      </style>
      </head>
      </body>
      Chakor is the National bird of Pakistan.
      </body>
      </html>
      
   b. Select File ▶ Save and save the document as chakor.html.
   c. Open the Internet Explorer. Select File ▶ Open.
   d. Click Browse in the Open dialog box that appears.
   e. Select the file peacock.html and click Open.

2. To create an HTML document:
   a. Start Notepad and type the following HTML code:
      ```html
      <!DOCTYPE html>
      <html>
      <title>School Sports Activities</title>
      <style type = "text/css">
      body { background-color: pink}
      ```
Our school provides the following sports activities:

- Cricket
- Badminton
- Tennis
- Chess
- Football

<!--Students should be asked to write a short description for each of these sport facilities.-->

To create an HTML document:

1. Start Notepad and type the following HTML code:

```html
<!DOCTYPE html>
<html>
<title>School Sports Activities</title>
<body>
  <b>School Sports Activities</b>
  
  Our school provides the following sports activities:
  
  - Cricket
  - Badminton
  - Tennis
  - Chess
  - Football

<!--Students should be asked to write a short description for each of these sport facilities.-->

</body>
</html>
```

b. Select File ▶ Save and save the document as sports.html.

c. Open the Internet Explorer. Select File ▶ Open.

d. Click on Browse in the Open dialog box that appears.

e. Select the file sports.html and click Open.

2. To create an HTML document:

   a. Start Notepad and type the following HTML code:

   ```html
   <!DOCTYPE html>
   <html>
   <title>Historical Places that I like</title>
   <style type = "text/css">
   body
   </style>
   </head>
   <body>
     <b>Historical Places I like</b>
     
     Amongst the huge list of historical places in south-east Asia, I like Agra the most. It is well-known for the Taj Mahal, a striking specimen of the Mughal grandeur built by the Mughal emperor Shah Jahan in the loving memory of his wife Mumtaz Mahal. Agra is also famous for its beautiful fort.
   
   </body>
   </html>
   ```

   b. Select File ▶ Save and save the document as MyFavHistoricalPlace.html.

   c. Open the Internet Explorer. Select File ▶ Open.

   d. Click on Browse in the Open dialog box that appears.

   e. Select the file tajmahal.html and click Open.

3. To create an HTML document:

   a. Start Notepad and type the following HTML code:

   ```html
   <!DOCTYPE html>
   <html>
   <title>Historical Places that I like</title>
   <style type = "text/css">
   body
   </style>
   </head>
   <body>
     
     Amongst the huge list of historical places in south-east Asia, I like Agra the most. It is well-known for the Taj Mahal, a striking specimen of the Mughal grandeur built by the Mughal emperor Shah Jahan in the loving memory of his wife Mumtaz Mahal. Agra is also famous for its beautiful fort.
   
   </body>
   </html>
   ```

   b. Select File ▶ Save and save the document as MyFavHistoricalPlace.html.

   c. Open the Internet Explorer. Select File ▶ Open.

   d. Click on Browse in the Open dialog box that appears.

   e. Select the file tajmahal.html and click Open.
<title>My favourite game</title>
<style type = "text/css">
body { background-image:url("favouritegame.jpg");
background attachment: fixed; background-repeat: repeat }
</style>
</head>
<body>
<b>My Favourite Game</b>
<br>
My favourite game is football. It is a team game and a team usually consists of 11 players. Each team has to score goals by kicking the ball into the opposite team’s goal. The team that scores the most number of goals is declared the winner. It is generally a 90 minute game but can extend if there is a tie in the number of goals.
</body>
</html>

b. Select File ▶ Save and save the document as football.html.
c. Open the Internet Explorer. Select File ▶ Open.
d. Click on Browse in the Open dialog box that appears.
e. Select the file football.html and click Open.

GROUP PROJECT

Please refer to the group work guidelines given on page 1 of this teaching guide. Teachers should not only look at the technical aspects in terms of the correct syntax but also at the creativity. This activity could be split in two parts, one which is used to decide on the topic and how the pages could look and the second part when the students actually type in the code. Since this is a group activity, teachers are looking for teamwork rather than individual endeavour.

Chapter 10  Basic HTML 5 Commands

OBJECTIVE TYPE QUESTIONS

1. Choose the correct option.
   a. iii. <h6>     b. iv. all of these     c. iv. all of these     d. ii. 255
   e. iii. text-align     f. ii. text-shadow: 2px 2px aqua     g. iv. all of these     h. i. medium

DESCRIPTIVE TYPE QUESTIONS

1. a. Colours can be defined through Hexadecimal colour values and RGB colour values.
   b. Text-align is used to specify the horizontal alignment property. Its default value is ‘left’
   c. The text-transform property can be assigned the following values: none, capitalise, uppercase, and lowercase.
d. The comment tags <!-- and --> are used to add comments in an HTML document.

e. The font-family property specifies a list of font names to be applied to the text in the HTML element. For example, font-family: arial, “Times New Roman”

   The font-style property specifies the font style of text and can take the values, normal, italic or oblique.

f. The **margin** property is used to set all the margins (left, right, top and bottom) in one declaration.

   For example, consider this:
   ```html
   margin: 10px 5px 8px 12px
   ```

   Here the top margin is 10px, the right margin is 5px, the bottom margin is 8px, and the left margin is 12px.

   If we write the margin property as
   ```html
   margin: 20px 15px,
   ```

   then, the top and the bottom margins are 20px, the right and the left margins are 15px.

   If we specify the margin property as
   ```html
   margin: 15px,
   ```

   it means that all the four margins are set to 15px.

g. The text-shadow property specifies a list of shadow effects to be applied to text whereas text-decoration specifies the decorations that are added to text, such as underlining, line through .

h. The `<hr>` tag is the horizontal rule element. It defines a thematic break in an HTML page, i.e. it is used to separate content in an HTML page. It is an empty element.

i. The intuitive answer would be that HTML stands for Hyper Text Markup Language and is text based and follows the WYSIWYG model. Also, text is a major component of HTML.

j. This is an opinion question so there will be both positive and negative responses; in essence there is no definitive right answer. The purpose of the question is to assess how well the student has been able to comprehend how HTML works.

k. Divide this lesson into two or three parts. The first part could focus on allowing students to collect information about the school. They may require permission to meet with one or two of the senior teachers; the principal and perhaps a couple of the older staff members. The students could also be allowed to conduct research on the Internet to see how other schools have carried out their ‘About Us’ pages.

   After the students have gathered this information they should be able to write the code for the pages. You will be able to check the code for proper syntax and execution. Mark generously for creativity.

### APPLICATION-BASED QUESTIONS

a. i. He should use the Horizontal rule element `<hr>`.

   ii. The **colour** property can be used to change the colour of the horizontal line.

b. i. **Transform** is an incorrect command.

   ```html
   h1{text-align: centre; color: white; text-transform: uppercase}
   ```

   ii. For this, change the **text-transform** property to lowercase.

   iii. The other values that can be specified for the text-align property are left, right, and justify.

c. i. h1, h2, h3 {color: maroon}. ii. Six iii. colour and text-align

d. i. line-height ii. text-align iii. text-shadow
1. To create an HTML document:
   a. Start Notepad and type the following HTML code:
      ```html
      <!DOCTYPE html>
      <html>
      <title>Mangroves</title>
      <style type = "text/css">
      body { background-image: url( "mangrove.jpg");
      background attachment: fixed; background-repeat: no-repeat }
      p {Text-align: justify}
      h1 {text-align: centre}
      </style>
      </head>
      <body>
      <h1>Mangroves</h1>
      <p>Mangroves are tropical and sub-tropical plants that grow in swamps. They are of the genus Rhizophora.  
      The roots of Mangrove trees grow in the upward direction and can be seen protruding out of the ground. </p>
      </body>
      </html>
      
      b. Select File ► Save and save the document as mangrove.html.
      
      c. Open the Internet Explorer. Select File ► Open.
      
      d. Click on Browse in the Open dialog box that appears.
      e. Select the file mangrove.html and click Open.
      
2. To create an HTML document:
   a. Start Notepad and type the following HTML code:
      ```html
      <!DOCTYPE html>
      <html>
      <title>Quotations</title>
      <style type = "text/css">
      h1 {color: red; text-align: centre}
      h3 {color: blue; text-align: justify}
      </style>
      </head>
      <body>
      <h1>Great Quotations by Albert Einstein</h1>
      <h3>Not everything that counts can be counted and not everything that can be counted counts. </h3>
      <hr>
      <h3>imagination is more important than knowledge. </h3>
      <hr>
      <h3>The difference between stupidity and genius is that genius has its limits. </h3>
      ```
b. Select File ▶️ Save and save the document as quotes.html.

c. Open the Internet Explorer. Select File ▶️ Open.

d. Click on Browse in the Open dialog box that appears.

e. Select the file quotes.html and click Open.

3. To create an HTML document:
   a. Start Notepad and type the following HTML code:

   ```html
   <!DOCTYPE html>
   <html>
   <title>National Festivals of Pakistan</title>
   <style type = "text/css">
   body { background-color: yellow}
   p {color: red; font-family: arial; font-style: oblique; font-size: small; margin: 20px 20 px}
   </style>
   </head>
   <body> <h1> National Festivals of Pakistan </h1> <br>
   <p>Pakistan, being a land of many cultures celebrates a large number of festivals. But it is our national festivals, Independence Day and Pakistan Day, which bring the entire country together under a common belongingness. Independence Day marks Pakistan’s freedom from British rule gained on 14th August 1947. Pakistan Day honours the day when the Lahore resolution was passed on 23rd March 1940. </p> </body>
   </html>

   b. Select File ▶️ Save and save the document as festival.html.

c. Open the Internet Explorer. Select File ▶️ Open.

d. Click on Browse in the Open dialog box that appears.

e. Select the file festival.html and click Open.

4. To create an HTML document:
   a. Start Notepad and type the following HTML code:

   ```html
   <!DOCTYPE html>
   <html>
   <title>badminton</title>
   <style type = "text/css">
   body { background-color: black}
   p {color: red; font-family: arial; font-style: oblique; font-size: small; border: solid 4px blue}
   </style>
   </head>
   <body> <h1> Badminton </h1> <br>
   <p> Badminton is a game played using <b> Rackets</b> and a <b> shuttle cock</b>. It is generally a <b>21 point</b> match and can be played at a time between either 2 or 4 players.</p> </body>
   </html>

```
b. Select **File ▶ Save** and save the document as **badminton.html**.

c. Open the Internet Explorer. Select **File ▶ Open**.

d. Click on **Browse** in the **Open** dialog box that appears.

e. Select the file **badminton.html** and click **Open**.

---

**GROUP PROJECT**

Please follow the guidelines on Group Project given on page 1 of this teaching guide. This activity can be conducted in the lab making sure time is allowed for a short discussion session after seeing all the submissions. Students’ skill levels can be assessed by asking questions on how they went about incorporating the colour that they chose.

---

**ASSESSMENT 1**

**SECTION A (THEORY)**

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>2.</td>
<td>3.</td>
<td>4.</td>
<td>5.</td>
</tr>
<tr>
<td>chart</td>
<td>spyware</td>
<td>data label</td>
<td>spam</td>
<td>category</td>
</tr>
<tr>
<td>6.</td>
<td>7.</td>
<td>8.</td>
<td>9.</td>
<td>10.</td>
</tr>
<tr>
<td>legend</td>
<td>value</td>
<td>chart title</td>
<td>gridlines</td>
<td>pie</td>
</tr>
</tbody>
</table>

2. a. computer virus  
b. worm  
c. Trojan horse  
d. =  
e. $

3. a. A1:E6  
b. I Enjoy Reading  
c. 40  
d. 3  
e. 900

**SECTION B (PRACTICAL)**

1. a. Create a worksheet as shown in the given figure.

   b. In the cell C3, type the formula =$J$1*B3 and press **Enter**.

   c. To get 25% of Test I for other roll number values, select cell C3. A + sign appears. This is called the AutoFill handle. Drag the AutoFill handle to cell C12. The result values will be displayed in the corresponding cells.

   d. To find 25% of Test II repeat the process as followed in step c. Type the formula in cell E3 as =$J$1*D3. Repeat the rest of the process as followed in step c.

   e. In the cell G3, type the formula =$K$1*F3 and press **Enter**.

   f. To get the other values, select cell G3. A + sign appears. Drag the AutoFill handle to cell G12. The result values will be displayed in the corresponding cells.

   g. To calculate the total, select cell H3 and type the formula = C3+E3+G3 and click **ENTER**. Use the Autofill handle to find the result of other values as well.
**SECTION A (THEORY)**

1. \((x,y)\) represents the coordinates of the point where this method will draw an ellipse; \(w\) and \(h\) represent the width and height of the ellipse respectively.

   To draw a circle using this method we need to set \(w\) and \(h\) equal.

2. a. Dim A, B, C as Integer
   
   \[
   \begin{align*}
   &B = 0 \\
   &C = 0 \\
   &For\ A = 1\ to\ 10\ Step\ 3 \\
   &\quad B = B + 1 \\
   &\quad C = C + 5 \\
   &EndFor
   \end{align*}
   \]

   b. 4 times

   c. 20

3. a. For Number = 15 To 1 Step -4

   TextWindow.WriteLine(Number)

   b. 15

   11

   7

   4

   c. The cursor is not placed in the next line. The output will be 15 11 7 4

**SECTION B (PRACTICAL)**

1. To create a form as shown in the figure:

   a. Start Microsoft Visual Studio 2013 Express and create a Windows Forms Application named “Total and Average”.

   b. Place six labels, five Textboxes, and one button in the form as given in the figure. Set the properties according to the following table:

<table>
<thead>
<tr>
<th>Controls</th>
<th>Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label1</td>
<td>Text: Total and Average Font: Bold, 14</td>
</tr>
<tr>
<td>Label2</td>
<td>Text: First Number Font: Bold, 12</td>
</tr>
<tr>
<td>Label 3</td>
<td>Text: Second Number Font: Bold, 12</td>
</tr>
<tr>
<td>Label4</td>
<td>Text: Third Number Font: Bold, 12</td>
</tr>
<tr>
<td>Label5</td>
<td>Text: Total Font: Bold, 12</td>
</tr>
<tr>
<td>Label6</td>
<td>Text: Average Font: Bold, 12</td>
</tr>
</tbody>
</table>
c. Double click the **Calculate** button. In the window that appears, type the following code:

```vba
TextBox4.Text = Val(TextBox1.Text)+Val(TextBox2.Text)+Val(TextBox3.Text)
TextBox5.Text = Val(TextBox4.Text)/3
```

d. Select **File ▶ Save All** to save the project.
e. Press F5 to run the program.

---

### COMPREHENSIVE ASSESSMENT I

1. a. Excel 2013  
   b. $  
   c. $D4 + $E4  
   d. Install Anti-Virus software  
   e. For...EndFor and While...EndWhile  
   f. Kaspersky antivirus and QuickHeal Antivirus software  
   g. True  
   h. 1  
   i. ^  
   j. Pointing is a method of adding cell reference to a formula by clicking a cell or a range.

2. a. 
   ```vba
   A=1
   While A <=2
   TextWindow.WriteLine(A)
   A = A+0.2
   EndWhile
   ```
   b. To avoid spam mail:
   - Do not give your email id to unknown people.
   - Delete spam mails without reading them.

c. `GraphicsWindow.Width = 400`
   `GraphicsWindow.Height = 600`
d. `GraphicsWindow.DrawRectangle (75, 75, 100, 100)`
e. Axis title, legend, gridlines, and chart title.

3. a. F  
   b. F  
   c. F  
   d. T  
   e. T

4. Dim I, A as Integer
   ```vba
   I = 0
   For A = 1 To 25 Step 3
   I = I + A
   EndFor
   TextWindow.WriteLine(I)
   ```
5. TextBox2.Text = Val (TextBox1.Text)^2  
   TextBox3.Text = 4*Val (TextBox1.Text)

6. a. iii. =  b. iii. Absolute reference  c. iii. Pie chart  d. i. A1
    e. ii. Integrated Development Environment  f. iv. General window
    g. iii. Title Bar  h. ii. #REF!  i. iv. <=  j. iii. DrawEllipse

---

ASSESSMENT 3

SECTION A (THEORY)

1. a. news feed  b. SixDegrees  c. Twitter  
   d. Online telephony  e. Picasa

2. a.  i. Blog Posts are individual articles on a blog.
    ii. Cloud computing is a technology that uses the Internet and central remote servers (computers) to hold data and applications.
    b. Chat Rooms are Websites offering online chat facilities.
       Newsgroup is a group that posts messages on an online bulletin board where anyone can read them and respond to them.
    c. The Modify menu and the Group option.


SECTION B (PRACTICAL)

1. To apply shape tweening:
   i. Create a new Flash document.
   ii. Rename Layer 1 to Rectangle.
   iii. Click Frame 1. Select the Rectangle Primitive tool, set fill colour to orange, and draw a rectangle.
   iv. Select frame 20 in the Timeline and insert a Blank Keyframe by pressing F7 or by selecting Insert ▶ Timeline ▶ Blank Keyframe.
   v. Draw a circle on the Stage.
   vi. Click on any frame between 1 and 20 in the Timeline. Right click and select the Create Shape Tween option from the context menu.
   vii. Again select frame 40 in the Timeline and insert a blank keyframe by pressing F7.
   viii. Copy the rectangle shape from Frame 1 to Frame 40.
   ix. Right-click on any frame between 20 and 40 and select Create Shape Tween option from the context menu.
   x. Select Frame 1 in the Timeline and press Enter to play the movie.
ASSESSMENT 4

SECTION A (THEORY)

1. a. <p> b. <b> c. <br> d. <hr>
2. a. heading tag and paragraph tag  
   b. i. <h2> ii. <p> 
   c. i. colour ii. font-size 
3. Incorrect keywords are used in the code: size, style, font-colour, family. The correct code is given below:
   <style>
   p {font-size: xx-small; font-style: italic; font-family: arial}  
   h1 {color: red} 
   h2 {font-family: "Times New Roman"}
   </style>

SECTION B (PRACTICAL)

1. <!DOCTYPE html>  
   <html>  
   <head>  
   <title>School Activities</title>
   <style type = "text/css">  
   body{ background-color: black}  
   p {color: white; font-family: "Comic Sans MS" ; font-style: oblique; font-size: small}  
   h1 { text-align: centre ; color: orange; font-family: arial} 
   </style>  
   </head>  
   <body>  
   <h1>School activities</h1>  
   <p> We have a variety of activities which take place at our school. They vary from academic to cultural to sports.</p>  
   </body>  
   </html>

COMPREHENSIVE ASSESSMENT II

1. a. empty b. break tag c. container elements d. Timeline e. font
2. a. T b. F c. F d. T e. T
3. a. Six b. F6
c. Yahoo! Messenger
d. Authoring a blog, maintaining a blog, or adding an article to an existing blog is called blogging.
e. font-family
f. Facebook
g. <br>
h. <br>
i. Picasa
j. Free Transform tool

4. a. Comments are written using the comment tags <!-- and -->.
b. A Website that provides a virtual community for people to keep in touch with friends or share common interests is called a social networking site.
c. Modify menu and Break Apart option.
d. The text-align property specifies the position of the text on the Web browser. Two values that can be assigned to this property are: justify and centre.
e. “Me at Zoo” was the first video posted on YouTube on April 2005.

5. <!--DOCTYPE html-->
<html>
<head>
<title>Blogs</title>
<style type = "text/css">
body { background-color: white}
hl {color: pink; text-align: centre}
p {color: blue; text-align: justify}
</style>
</head>
<body>
<h1>BLOGS</h1>
<hr>
<p> A blog or a weblog is a website in which articles are posted regularly and displayed in reverse sequential order, i.e. with the most recent entry first</p>
</body>
</html>

6. a. i. Twitter
b. iii. LinkedIn
c. i. Windows Live SkyDrive
d. iii. Eyedropper tool
e. i. File
f. i. Symbols
g. iii. both i and ii
h. i. Timeline effects
i. iii. both i and ii
j. ii. text-transform
Cyber Olympiad Questions

1. b.  11. d.  21. d.  31. a.
2. a.  12. c.  22. d.  32. b.
3. c.  13. a.  23. a.  33. a.
5. b.  15. d.  25. c.  35. a.
7. b.  17. c.  27. b.  37. c.
8. d.  18. a.  28. a.  38. b.
10. a. 20. b  30. b.  40. a.

Revision Questions

1. A cell reference identifies a cell or a range of cells in a worksheet, and tells Excel where to look for the values or data one wants to use in a formula.
2. C:E
3. By pressing the Show Formulas button
4. A reference where a formula refers to its own value is called a circular reference.
5. Bar chart, pie chart, column chart, scatter chart, and line chart
6. Functions in Excel are predefined formulas that perform specific calculations, for example, sum, average, minimum, and maximum.
7. You can change the size of a chart by dragging its corners.
8. A sparkline is a miniature chart embedded in a single worksheet cell.
9. The Quick Analysis button helps in quickly creating a chart or a sparkline.
10. A combination chart is a single chart that consists of series which use different chart types. It may include a second value axis.
11. Different types of computer viruses are: program viruses, boot viruses, macro viruses, malware, worms etc.
12. Worms spread without any human action, and thus differ from viruses. Viruses spread only when the user does something, like running an infected program or attaching an infected file. A worm emails copies of itself to other computers, infects them, and then uses the address book of the infected computer to spread further.
13. • It can infect executable program files such as word processors, spreadsheets, and operating systems.
   • It can infect disks by attaching itself to special programs on the hard disk, called boot records. These are the programs that the computer uses to start itself up.
   • It can infect files that are attached to email messages or copied to disks and pen drives. In this manner, it can spread from one computer to another.
14. Program viruses infect program files, which have extensions like .COM, .EXE, .SYS, .DLL, .OVL, and .SCR. Boot viruses infect the boot records of hard disks and floppy disks.
15. Computer viruses spread from one computer to another through the transfer of infected data through emails, pen drives, or other sources.
16. Computer virus, Trojan horse, worms etc.
17. Virus definitions denotes the database of viruses that an antivirus software scans for detecting viruses. This database needs to be updated regularly, because new viruses are being developed and released all the time. If the virus definition file is not updated, antivirus software will not know about new viruses and will not be able to catch them.
18. The two ways to place controls on a form are: double-click the control in the Toolbox or click the control in the Toolbox and drag it to the form.
19. Sum
20. relative
21. FontName, FontSize, FontBold, and FontItalic
22. a. GraphicsWindow. PenWidth = 3
23. An empty form, the Toolbox tab, the Solution Explorer window, and the Properties window.
24. To run an application, do any of these:
   i. Click DEBUG ▶ Start Debugging
   ii. Press F5.
   iii. Click the Start button on the toolbar.
25. Cloud computing is a technology that uses the Internet and central remote servers (computers) to hold data and applications.
26. News, Comp
27. Online file sharing service provides a way to store and access information in the ‘cloud’ rather than locally on a hard drive.
28. Picasa Web Albums is a website where you can store and share photos.
29. A graphic image, animation, or button that is stored with a Flash movie is called a symbol.
30. The Eyedropper tool is used for acquiring colours and styles from existing lines, brush strokes, and fills and applying the same to other objects.
31. To convert text into basic shapes:
   i. Select the text.
   ii. Select Modify ▶ Break Apart. This breaks the single text block into multiple text blocks.
   iii. Select Modify ▶ Break Apart once more. The characters can now be converted into shapes. They cannot be considered text any more. You can no longer change the font, font size, etc.
32. To group outline and fill:
   i. Using the Arrow tool, select both the outline and the fill.
   ii. Select Modify ▶ Group.
33. To rename a layer, double-click the layer and type the new name.
34. To convert a layer into a mask layer, right-click the layer name and select Mask in the context menu.
35. You can control the number of frames by dragging the Start Onion Skin and End Onion Skin markers in the Timeline.
36. The two main types of HTML editors are: WYSIWYG editors and Text editors.
37. HTML elements that include both ON and OFF tags are called container elements, for example, head and body elements.
38. Head and Body
39. The paragraph element, <p> defines a paragraph in HTML.
40. <hr>: Horizontal rule element <u>: Underline tag
WORKSHEETS

- Worksheets have been provided for all the chapters of the course book.
- Each worksheet is of 15 marks and is recommended as a formative assessment paper.
- It is possible to use these worksheets as they are by photocopying them in magnified size (120% approx.) and distributing to the students.
- The questions in the worksheets may also be used as samples to create your own additional worksheets.
- They are also available as printable documents in digital resources.
Chapter 1  Formulas in Excel 2013

Max Marks 15

1. Who am I?  
   Identify what is being talked about from the hints given.
   a. I am the sign with which an Excel formula starts.
   b. I am a sequence of values, cell references, functions, and/or operators in a cell that produces a new value from existing values.
   c. I am a cell or a range of cells in a worksheet.
   d. I am the status in the status bar when nothing is being done.
   e. I am the moving dashed border on a cell.

2. Jumbled Words  
   Unjumble the letters to form words using the hints given.
   a. Niopgnit  
      Hint–Adding cell reference to a formula by clicking directly on the cell.
   b. Lativeer  
      Hint–A type of reference while using a cell or a range reference in formulas.
   c. Raluccir  
      Hint–The type of reference when a formula refers to its own value.
   d. Sonitcnuf  
      Hint–Predefined formulas
   e. Tomusua  
      Hint–The feature which automatically adds numbers in selected cells

3. Word Search  
   Search for five words related to Excel in the grid below:
   
   | P O I N T I N G L A |
   | Z E T L O S S X H B |
   | R E L A T I V E R S |
   | I P B C R M I O E O |
   | N M I X E D S E K L |
   | E O T E M M A R Q U |
   | P M O J E C T E Z T |
   | F O R M U L A R W E |
Chapter 2  Creating Charts in Excel 2013

Max Marks 15

1. Who am I? (5)
Identify what is being talked about from the hints given.
a. I am the pictorial representation of data.
b. I am a chart which usually compares trends of data at equal intervals.
c. I am a chart which shows trends of data over a period of time or illustrates comparisons between items.
d. I am a column chart drawn sideways.
e. I am a chart which plots each data point with a marker.

2. Jumbled Words (5)
Unjumble the letters to form words using the hints given.
a. Ghoudtun
   Hint: The type of chart which shows relationship of parts to a whole.
b. Darar
   Hint: This chart plots data in concentric circles.
c. Glende
   Hint: It displays a drop-down list with many options
d. Rtahc Lestys
   Hint: The chart option to make charts more attractive
e. Binamocniot
   Hint: A single chart that consists of a series that uses different chart types..

3. Word Search (5)
Search for five words related to Sparklines in the grid below:

```
  W I N R A M C K C
  Z E T S O M Y X O
  L E A L P Q R S L
  I P B L O S S O U
  N R R M O U S E M
  E O T E M M A R N
  P M O J E C T E H
  M I N I A T U R E
```
### Chapter 3  Computer Viruses

**Max Marks 15**

**1. Who am I?**

Identify what is being talked about from the hints given.

a. I am the extension of an executable file.

b. I am a software program that has the ability to make copies of itself, and to attach itself to other programs or files.

c. I am the boot record area of a computer.

d. I am a virus which infects program files which have extensions like .com and .sys

e. The kind of virus whose one example is Melissa.

**2. Jumbled Words**

Unjumble the letters to form words using the hints given.

a. Bostysp
   
   Hint: computer programs that secretly gather information about the user and relay it to advertisers or other interested parties

b. Maps
   
   Hint: Unsolicited, unwanted email

c. Survnita
   
   Hint: The software designed to remove viruses from the computer

d. Mosrw
   
   Hint: A program capable of reproducing and spreading itself to another computer system, usually by means of a computer network

e. Omrac
   
   Hint: A set of commands

**3. Word Search**

Search for five words related to computer viruses in the grid below:

| S | X | T | R | O | J | A | N | S |
|---|---|---|---|---|---|---|----|
| P | E | T | L | O | S | S | X | C |
| Y | E | A | L | P | Q | R | S | O |
| W | P | B | O | O | T | I | O | L |
| A | R | R | M | O | U | S | E | U |
| R | O | T | N | O | R | T | O | N |
| E | M | O | J | E | C | T | E | N |
| T | U | M | A | L | W | A | R | E |
Chapter 4  Loops and Graphics in Small Basic

Max Marks 15

1. Who am I? (5)
   Identify what is being talked about from the hints given.
   a. I am used to repeat a block of statements a number of times.
   b. I am the number of looping statements available in Small Basic.
   c. I am the command used to increment variables in the For loop.
   d. I am the Textwindow command for writing with newline at the end.
   e. I am the GraphicsWindow property used to make font bold.

2. Jumbled Words (5)
   Unjumble the letters to form words using the hints given.
   a. Dowgrawinphics
      Hint: The object used to draw lines and shapes
   b. Rushbroloc
      Hint: The property used for colouring
   c. ElwihnedElwih
      Hint: A looping statement in Small Basic
   d. Tardwetx
      Hint: A graphics window method
   e. Tnofcilati
      Hint: The property used for italicising

3. Word Search (5)
   Search for five words related to Small Basic in the grid below:

   P E N C O L O R S
   E R G Y U T B X L
   N E A L P Q R S I
   W I D T H E E N D
   I H D E S I G N E
   D O H E I G H T T
   T M N I T O R E R
   H E C T I T L E W
Chapter 5  Introduction to Visual Basic

Max Marks 15

1. Who am I?  (5)

Identify what is being talked about from the hints given.
   a. I am a named attribute of an object.
   b. I am also called an action.
   c. I am an environment where all the tools required for software development are available.
   d. I am the bar at the top of the window.
   e. I am an action that can be performed on a control

2. Word Search  (4)

Search for four words related to Visual Basic in the grid below:

```
T O O L B O X G S
X R E P E A T X C
I E A L P M R S O
D A S W R I L E N
E H D O S I G N T
B L F A R N E R R
U M B R E A K E O
G E F O N T I E L
```

3. Give three facts about the following:  (3 × 2 = 6)

   a. Variable naming rules
   b. Visual Basic Programming
Chapter 6  Communication on the Internet

Max Marks 15

1. **Who am I?**  
(5)

Identify what is being talked about from the hints given.

a. I allow you to interact with many users but the communication is not instant.
b. I am a service in which multiple users talk to each other in real time.
c. I am a communication service over the Internet that allows instant transmission of text-based messages from sender to receiver.
d. I am the most popular social networking site today.
e. I am a website on which articles are posted regularly and displayed in reverse sequential order.

2. **Word Search**  
(4)

Search for four words related to the Internet and the Internet products in the grid below:

```
C   L   O   U   D   I   D   S   A
S   A   M   Y   X   G   T   C   M
G   R   E   Y   E   A   W   H   Y
A   R   O   O   E   S   I   P   S
M   A   S   U   H   I   T   O   P
I   H   L   T   S   T   T   M   A
N   L   E   U   R   N   E   G   C
G   M   B   B   E   A   R   L   E
P   E   C   E   C   L   E   E   W
```

3. **Give three facts about the following:**  
(3 × 2 = 6)

a. Online gaming
b. Picasa
Chapter 7  More Tools in Flash

Max Marks 15

1. **Who am I?**  
   Identify what is being talked about from the hints given.
   a. I am a tool used for drawing lines.
   b. I am a tool used to pick up colours and style from existing lines, brush strokes, and fills.
   c. I am the occurrence of a symbol.
   d. I am a tool used to select an instance of a symbol.
   e. I am a folder in which symbols are stored

2. **Word Search**  
   Search for four words related to Flash in the grid shown below:

   ![Word Search Grid]
   
   a. Timeline effects
   b. Gradient fill

3. **Give three facts about the following:**
   a. Timeline effects
   b. Gradient fill
Chapter 8  Animations in Flash

Max Marks 15

1. Who am I? (5)
   Identify what is being talked about from the hints given.
   a. I am the basic constituent of a flash movie.
   b. I help organise contents of a Flash document.
   c. I am a frame with black dots.
   d. I am the keyboard shortcut for inserting a frame.
   e. I am an in-built visual effect in Flash.

2. Word Search (4)
   Search for four words related to Flash/ animations in the grid below:
   
   G P L A Y H E A D
   U W B Y L T S T R
   B G R E Y E A B E
   E L A Y O U T S X
   V N S T A G E O R
   E E V D A T A E R
   L I S O U N D R T
   A E R T I C A L M
   A N I M A T I O N

3. Give three facts about the following: (3 × 2 = 6)
   a. Frame
   b. Layer
Chapter 9  Introduction to HTML 5

Max Marks 15

1. Who am I?
   Identify what is being talked about from the hints given.
   a. I am the language in which Web pages are written.
   b. I am the computer which is used for storing and running Websites.
   c. I am the number of sections in a website.
   d. I am used to view an HTML document.
   e. I am the first part of an HTML document.

2. Word Search
   Search for four words related to HTML in the grid below:

   C O N T A I N E R
   B P L A Y H E A D
   E L A Y O U T A G
   V N S T A G E O R
   E L E M E N T A B
   L I S O U N D R O
   A T I T L E H D D
   A N I M A T I O Y

   (3 × 2 = 6)

3. Give three facts about the following:
   a. HTML coding
   b. Cascading style Sheet
Chapter 10  Basic HTML 5 Commands

Max Marks 15

1. Who am I?
   Identify what is being talked about from the hints given.
   a. I am a deprecated element in HTML 5.
   b. I am the tag which defines a paragraph in HTML.
   c. I am the number of heading levels in HTML.
   d. I am the property used to set all the margins.
   e. I am used to apply a style to HTML elements.

2. Word Search
   Search for four words related to HTML in the grid below:
   
   | P | A | R | A | G | R | A | P | H | J |
   | B | P | R | O | P | E | R | T | Y | R |
   | E | L | A | Y | O | U | T | A | G | O |
   | C | O | M | M | E | N | T | O | R | F |
   | E | L | E | M | E | N | T | E | B | N |
   | H | O | R | I | Z | O | N | T | A | L |
   | A | E | R | T | I | T | L | E | D | S |
   | A | B | O | R | D | E | R | O | Y | T |

3. Give three facts about the following:
   (3 × 2 = 6)
   a. Comment tag in HTML
   b. Font Properties
Worksheet Answers:

Chapter 1  Formulas in Excel 2013

1. a. =  b. Formula  c. reference  d. Ready  e. marquee

Chapter 2  Creating Charts in Excel 2013

1. a. Chart  b. Line chart  c. Column chart  d. Bar chart  e. Scatter chart

Chapter 3  Computer Viruses

1. a. .exe  b. Virus  c. Startup  d. Program virus  e. Macro
2. a. Spybots  b. Spam  c. Antivirus  d. Worms  e. Macro
Chapter 4  Loops and Graphics in Small Basic

1. a. loop  b. 2  c. Step  d. WriteLine  e. FontBold

2. a. GraphicsWindow  b. Brushcolor  c. While...EndWhile
d. DrawText  e. FontItalic

Chapter 5  Introduction to Visual Basic

1. a. Property  b. Event  c. IDE  d. Title bar  e. Method

2. T O O L B O X G S
X R E P E A T X C
I E A L P M R S O
D A S W R I L E N
E H D O S I G N T
B L F A R N E R R
U M B R E A K E O
G E F O N T I E L
3. a. • Variable names must have less than 255 characters.
   • They should not contain spaces or periods.
   • They must not start with a digit.

b. • VB uses a GUI interface.
   • It is event-driven.
   • It is based on the BASIC programming language.

Chapter 6 Communication on the Internet

1. a. Newsgroup  b. Chatroom  c. Instant messaging(IM)  d. Facebook  e. Weblog

2. C L O U D I D S A
   S A M Y X G T C M
   G R E Y E A W H Y
   A R O O E S I P S
   M A S U H I T O P
   I H L T S T T M A
   N L E U R N E G C
   G M B B E A R L E
   P E C E C L E E W

3. a. • It denotes playing any type of virtual game over the Internet or over a computer network.
   • It requires latest flash and web browser versions.
   • Need for Speed and Call of Duty are examples of multiplayer games.

b. • It is a free photo-management software from Google.
   • It enables you to view and organise all the photos on your computer.
   • The Picasa program and Picasa Web Albums site work together.

Chapter 7 More Tools in Flash

1. a. Pen  b. Eyedropper  c. Instance  d. Selection(arrow)  e. Library

2. G R A D I E N T I S
   O A F I L L W X N O
   R L A Y O U T S S M
   E Y E D R O P P E R
   U E V D A T A A E R E
   T I N T A R Y R T S
   A E R T I C A L M H
   I N K B O T T L E U
3. a. • Timeline Effects are built-in features in Flash that help you create animations by simply selecting a few options.
   • Fade in, fade out, explode, etc. are a few Timeline effects.
   • Timeline Effects can be applied to a drawing object, a picture, or a symbol.

b. • The gradient fill applied to an object can be modified using the Gradient Transform Tool.
   • There are two kinds of gradient fills: linear gradient and radial gradient.
   • The boundary around an object filled with a linear gradient has on the right a rotation handle and a width adjustment handle.

Chapter 8 Animations in Flash

1. a. Frame b. Timeline window c. Keyframe d. F5 e. Filter

2.  G P L A Y H E A D
    U W B Y L T S T R
    B G R E Y E A B E
    E L A Y O U T S X
    V N S T A G E O R
    E E V D A T A E R
    L I S O U N D R T
    A E R T I C A L M
    A N I M A T I O N

3. a. • Frames are the basic units of a Flash movie.
   • Every fifth frame is numbered in the Timeline.
   • The keyboard shortcut to insert a frame is F5.

b. • Each new movie contains a single layer by default, but you can add as many layers as you want.
   • Layers are contained in the Timeline window and help organise the contents on the Stage.
   • To insert a layer, select Insert-> Timeline-> Layer
Chapter 9  Introduction to HTML 5

1. a. HTML  b. Server  c. Three  d. Web browser  e. Head

2. 

<table>
<thead>
<tr>
<th>CONTAINER</th>
<th>B</th>
<th>PLAYHEAD</th>
<th>E U T AG</th>
<th>V S A E R</th>
<th>E L M E N T EB</th>
<th>L I O R D</th>
<th>A T H D D</th>
<th>A N IM AT I O Y</th>
</tr>
</thead>
</table>

3. a. • Hyper Text Markup Language (HTML) is a computer language used to create documents (Web pages) for display on the World Wide Web.
   • An HTML document contains two distinct parts: HEAD and BODY.
   • The HTML code has three components: elements, tags, and attributes.

b. • Cascading Style Sheets or CSS is a style sheet that provides a set of style rules for displaying HTML elements in a Web page.
   • CSS helps multiple Web pages of a Website to share the same formatting.
   • The syntax of a CSS rule is as follows:
     selector {property1:property1-value; property2: property2-value; ........}

---

Chapter 10  Basic HTML 5 Commands

1. a. <centre>  b. <p>  c. Six  d. Margin  e. Inline styles

2. 

|-----------|----|---|---------------|-----------|--------------|---------------|-------------|--------------|

3. a. • HTML comments are not displayed by the browser.
   • These are used to explain HTML code.
   • The comment tags are <!-- and -->.

b. • You can set all font properties in one declaration using font.
   • The font properties that can be set are font-style, font-size and font-family.
   • Font names are separated by commas.
TEST PAPERS

- Test papers have been provided for all the chapters of the course book.
- Each test paper is of **25 marks** and has both theory (20) and practical (5) components.
- The test papers may be used for pen and paper assessment or the questions in them could be used to create your own assessment papers.
- They are also available as printable documents in digital resources.
Chapter 1  Formulas in Excel 2013

1. Fill in the blanks using the correct words: (5)
   a. A ......................... identifies a cell or a range of cells in a worksheet.
   b. A ......................... reference occurs when a formula refers to its own value.
   c. You cannot perform operations like subtraction, multiplication etc. on a ......................... .
   d. ......................... in Excel are predefined formulas that perform specific calculations.
   e. The ......................... button is used for adding and calculating functions in a worksheet.

2. Write T for the true statement and F for the false one: (5)
   a. An Excel formula always starts with an exclamation (!) sign. ......................
   b. The status bar at the bottom of the Excel window displays the current action being taken. ......................
   c. The ampersand (&) character is used to concatenate strings in Excel. ......................
   d. In a formula, if two operators have the same order of evaluation, Excel evaluates them from right to left......................
   e. B$2 is an example of mixed referencing. ......................

3. Very Short Answer Questions (4)
   a. What is the default reference created by Excel in a formula?
   b. Name the key whose function is performed by the Check button present in the Formula bar.
   c. Which feature in Excel automatically adds numbers in the selected cells?
   d. Name the method that adds a cell reference to a formula by clicking the cell.

4. Short Answer Questions (6)
   a. What do you mean by concatenation? Explain with an example.
   b. What is the possible reason for the error result “####” in a formula?
   c. On which two tabs of Excel is the AutoSum button available?

5. Lab Exercise (5)
   Pearl White Clothing Pvt. Ltd. maintains data on its sales in a worksheet as given below. Kainat has been given a task to calculate the total sales of the different branches, and the grand total of all the branches for the months of July, August, and September. Can you help her do the task?

<table>
<thead>
<tr>
<th>Branch</th>
<th>Month</th>
<th>Total Sale</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>July</td>
<td>August</td>
</tr>
<tr>
<td>Karachi</td>
<td>55000</td>
<td>50000</td>
</tr>
<tr>
<td>Lahore</td>
<td>26000</td>
<td>20000</td>
</tr>
<tr>
<td>Faisalabad</td>
<td>15000</td>
<td>20000</td>
</tr>
<tr>
<td>hyderabad</td>
<td>22000</td>
<td>14000</td>
</tr>
<tr>
<td>Islamabad</td>
<td>27000</td>
<td>24000</td>
</tr>
<tr>
<td>Jamshoro</td>
<td>34000</td>
<td>31000</td>
</tr>
<tr>
<td>Larkana</td>
<td>25000</td>
<td>22000</td>
</tr>
<tr>
<td>Multan</td>
<td>23000</td>
<td>21000</td>
</tr>
<tr>
<td></td>
<td><strong>Grand Total</strong></td>
<td></td>
</tr>
</tbody>
</table>
Chapter 2  Creating Charts in Excel 2013

1. Fill in the blanks using the correct words:  
   a. In a ......................... chart, each data point in a series is represented by a column that rises from the x-axis.  
   b. A chart is a pictorial representation of ...................... .  
   c. The ..................... area refers to the area within which all chart components are placed.  
   d. The base area in 3-D charts is known as the ......................... .  
   e. A ......................... chart plots data in concentric circles.  

2. Write T for the true statement and F for the false one:  
   a. The X-axis is the vertical axis of a chart. .....................  
   b. The X-axis of a scatter chart is marked by numbers and not text. .....................  
   c. A pie chart is used to plot data for a single data series. .....................  
   d. Excel places the chart in a box at the top left corner of a worksheet. .....................  
   e. In a 3-D chart, four walls and a floor make up the plot area. .....................  

3. Very Short Answer Questions  
   a. Name the chart that can be described as a column chart drawn sideways.  
   b. Which chart element can be used to add a table with the data to a chart?  
   c. Name the two additional tabs that appear on selecting a chart.  
   d. Which group on the DESIGN tab has the MoveChart option to move the chart to a new worksheet?  

4. Short Answer Questions  
   a. What do you mean by a combination chart? Explain with an example.  
   b. Name any four types of charts.  
   c. What is a sparkline?  

5. Lab Exercise  
   ABC hardware maintains data of its sales in a worksheet as given below. They have to create a column chart depicting the total sales in different locations. They also have to format the chart. Can you help them do the task?  

<table>
<thead>
<tr>
<th>Location</th>
<th>Total Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Karachi</td>
<td>145000</td>
</tr>
<tr>
<td>Lahore</td>
<td>132000</td>
</tr>
<tr>
<td>Faisalabad</td>
<td>120000</td>
</tr>
<tr>
<td>hyderabad</td>
<td>115000</td>
</tr>
<tr>
<td>Islamabad</td>
<td>136000</td>
</tr>
<tr>
<td>Jamshoro</td>
<td>102000</td>
</tr>
<tr>
<td>Larkana</td>
<td>95000</td>
</tr>
<tr>
<td>Multan</td>
<td>92000</td>
</tr>
</tbody>
</table>
Chapter 3  Computer Viruses

1. Fill in the blanks using the correct words:  
   a. .................................. are the programs that a computer uses to start itself up.  
   b. A .................................. is a set of commands written by the user to be executed later.  
   c. .................................. refers to unsolicited, unwanted emails.  
   d. Program viruses infect the ................................ files.  
   e. A .................................. is a program that appears useful, but is actually programmed to pass the user’s data to someone else.

2. Write T for the true statement and F for the false one:  
   a. You should first read the spam mails and then delete them. ..................................  
   b. A virus can infect both the software and the hardware of a computer. ...........................  
   c. Boot viruses are considered more dangerous than program viruses. ...........................  
   d. The virus definitions need to be updated regularly. ...........................  
   e. A computer virus cannot infect files on write-protected discs. ...........................  

3. Very Short Answer Questions  
   a. What is the name given to applications designed to detect and remove viruses from computer systems?  
   b. Give the short name for malicious software.  
   c. Which software program helps to keep viruses, hackers etc. from entering your computer over the Internet?  
   d. Give examples of some file extensions that can be infected by program viruses.  
   e. Give the names of any two popular antivirus programs.  

4. Short Answer Questions  
   a. What do you mean by a computer virus?  
   b. List any two common signs which indicate that a virus has attacked your computer.  
   c. What does a spyware do?  
   d. How are worms different from computer viruses?  
   e. What is a boot virus? Give an example of boot virus.
Chapter 4  Loops and Graphics in Small Basic

1. Fill in the blanks using the correct words:  
   (5)
   a. The ............................. object is used to draw lines, shapes, and text in many colours.
   b. The method to draw a square is ............................. .
   c. The default value of the FontName property of GraphicsWindow is ........................... .
   d. The ............................. statement is used to repeat a block of statements a specified number of times.
   e. The default value of the PenColor property of GraphicsWindow is ............................. .

2. Write T for the true statement and F for the false one:  
   (5)
   a. The While…EndWhile loop is used when the loop count is not known beforehand. .......................
   b. There are four looping statements in Small Basic. .......................
   c. The default value of step in For…EndFor is 0.1. .......................
   d. It is impossible to display text in the GraphicsWindow object. .......................
   e. The default value of the BrushColor property of GraphicsWindow is Sky Blue. .......................

3. Very Short Answer Questions  
   (4)
   a. What are the default values of the Width and the Height properties of the GraphicsWindow object?
   b. What would be the output of the following program?
      
      For I = 30 To 1 Step -5
      TextWindow.Write (I)
      EndFor

   c. Write down the command that will be used to set the colour used to fill a figure as blue.
   d. What is the default value of the Title property of the GraphicsWindow object?

4. Short Answer Questions  
   (6)
   a. Name the four Font related properties of the GraphicsWindow object and give their default values.
   c. Explain the For..EndFor looping statement with an example.

5. Lab Exercise  
   (5)
   Salim’s class teacher has asked the class to write a program in Small Basic to print “Welcome to Class 7A”. 
   The font should be Arial, font size should be 50, bold and italic should be enabled. The font colour should 
   be blue, the background colour should be yellow, and the text should appear approximately at the centre of 
   the screen.
Chapter 5  Introduction to Visual Basic

1. Fill in the blanks using the correct words: (5)
   a. Visual Basic is based on the ................................ programming language.
   b. The icons, buttons, dialog boxes, etc. that a GUI software uses, are called ......................... .
   c. In Visual Basic programming, moving the mouse is an ............................
   d. The ............................. at the top of the Visual Basic window displays the title of the project.
   e. ............................. is a named attribute of a control.

2. Write T for the true statement and F for the false one: (5)
   a. Visual Basic uses a Graphical User Interface to build programs. .........................
   b. “cust.name” is a valid variable name in Visual Basic. .........................
   c. Method is an action that can be performed on a control. .........................
   d. Two or more strings cannot be added one after the other. .........................
   e. The arithmetic operator Mod returns the remainder from an integer division. .........................

3. Very Short Answer Questions (4)
   a. What is the default extension of a Visual Basic form?
   b. With which keyword does a variable declaration in Visual Basic start?
   c. Name the Visual Basic window that lists the properties of the selected control on the form.
   d. What is the name of the control that is used to accept input from a user?

4. Short Answer Questions (6)
   a. What are the arithmetic operators that can be used in Visual Basic?
   b. What are the three ways in which a Visual Basic application can be run?
   c. What are the two methods of placing controls on a Visual Basic form?

5. Lab Exercise (5)
   Parveen wants to create a program in Visual Basic that asks the user to enter two positive numbers and prints the larger of the two numbers. Can you help her do the task?
Chapter 6  Communication on the Internet

1. Fill in the blanks using the correct words: (5)
   a. ................................... let you communicate with other users instantaneously through text messages.
   b. ................................... is the most popular Internet telephony software.
   c. A ................................... is a facility that informs interested readers of new content on a website.
   d. ................................... is a popular social networking site.
   e. ................................... is a communication service that allows instant transmission of text-based messages from the sender to the receiver.

2. Write T for the true statement and F for the false one: (5)
   a. While chatting, you should always use your real name. .........................
   b. In a blog, the most recent entry is displayed first. .........................
   c. A newsgroup communication is instant like a chat communication. .........................
   d. Microsoft Office 365 is an example of Online gaming. .........................
   e. Twitter was founded by Mark Zuckerberg. .........................

3. Very Short Answer Questions (5)
   a. What are the individual articles on a blog called?
   b. On which model does the FTP work?
   c. Name a photo management software provided by Google.
   d. Name the technology that uses the Internet and central remote servers to hold data and applications.
   e. What does the category COMP mean in a newsgroup?

4. Short Answer Questions (10)
   a. What do you mean by a chat room? Give an example of a website that provides chat room facility.
   b. What is the File Transfer Protocol?
   c. How does newsgroup differ from email?
   d. What do you mean by blogging? How are blogs created?
   e. What is a feed reader? Give examples.
Chapter 7  More Tools in Flash

1. Fill in the blanks using the correct words:  
   a. The ......................... in Flash is used for drawing precise paths like straight lines and smooth curves.
   b. The ......................... is used to move, rotate, or scale an object.
   c. In order to change the width of the gradient fill, you have to drag the ......................... handle to the left or the right.
   d. An ......................... is an occurrence of a symbol.
   e. The property ......................... is used to change the colour of an instance of a symbol.

2. Write T for the true statement and F for the false one:  
   a. To scale an object means to change its colour. .........................
   b. In order to move an object to a new position, you need to select either the fill or the outline. .........................
   c. In Flash, text can be added to the movies. .........................
   d. To modify the transparency of an instance, the colour property Alpha is modified .........................
   e. After converting text to a basic shape, you can still edit it as text. .........................

3. Very Short Answer Questions  
   a. Name the tool which has to be selected in order to modify the gradient fill of an object.
   b. Which tool is used to add text to the movies in Flash?
   c. Which tool is the Eyedropper tool linked to?
   d. What is the name of the folder in which symbols in a Flash movie are stored?

4. Short Answer Questions  
   a. How many objects are created when an object like a rectangle or a square is drawn in Flash? Name them.
   b. List the steps to group the outline and the fill of an object.
   c. What are Timeline effects used for? Give two examples of Timeline effects.

5. Lab Exercise  
   Tariq has been given a task of converting the text “Happy Birthday” into various shapes. Can you help him do the task?
Chapter 8  Animations in Flash

1. Fill in the blanks using the correct words: (5)
   a. The timeline contains ....................... for organizing the contents of a Flash document.
   b. The frames with black dots are called the ........................
   c. To move an object along a definite curved path, use a ....................... layer.
   d. The ....................... shows the number of frames per second that the animation plays.
   e. A ....................... is the basic unit of a Flash movie.

2. Write T for the true statement and F for the false one: (5)
   a. The keyboard shortcut to insert a frame is F5. ....................... 
   b. Every third frame in a timeline has the frame number. ....................... 
   c. When a layer is deleted, all objects on that layer also get deleted. ....................... 
   d. More than one filter cannot be applied to an object ....................... 
   e. The mask layer should always be below the layer that you want to mask. ....................... 

3. Very Short Answer Questions (4)
   a. What is the Onion skin feature used for?
   b. What is the keyboard shortcut to insert a keyframe?
   c. What is the white rectangular area where you add the contents of a Flash movie, called?
   d. Give two sound formats which are supported by Flash.

4. Short Answer Questions (6)
   a. What are filters? Give names of two filter types in Flash.
   b. What is the use of the mask layer feature? What should be kept in mind while using this feature?
   c. How do you change the order of the layers in Flash?

5. Lab Exercise (5)
   Mahum has been given a task to create an animation in which she has to show an aeroplane flying along a curved path. Can you help her do the task?
Chapter 9  Introduction to HTML 5

1. Fill in the blanks using the correct words: (5)
   a. A computer on the Internet that is used for storing and running a website is called a ......................... .
   b. The ......................... page is the first page of the website.
   c. The HTML elements that include both the ON and the OFF tags are called ......................... elements.
   d. ......................... give us extra information about elements.
   e. The ......................... section of an HTML document contains information about the document.

2. Write T for the true statement and F for the false one: (5)
   a. The subsection of a Website contains the headings for particular areas of the website. .........................
   b. A web browser is used to view the HTML documents. .........................
   c. Text editors let you create web pages without knowing how to write HTML. .........................
   d. Tag names are not case sensitive. .........................
   e. Attributes are always specified inside the start tag. .........................

3. Very Short Answer Questions (4)
   a. Which tool is used to create and save the HTML documents?
   b. Which types of HTML elements are called empty elements?
   c. Which background property specifies whether the background image is repeated or not?
   d. Which HTML tag is used to insert a line break?

4. Short Answer Questions (6)
   a. Name the three main sections of a website?
   b. Briefly explain the two types of HTML editors.
   c. What do you mean by cascading style sheets? Mention the different ways in which they can be included in an HTML document.

5. Lab Exercise (5)
   Sana has to create a web page on the Taj Mahal. Can you help her make the web page using HTML?
Chapter 10  Basic HTML 5 Commands

1. Fill in the blanks using the correct words:  (5)
   a. The ......................... property specifies the distance between two lines.
   b. A ......................... element is the element that is outdated and would soon become obsolete in the future.
   c. The ......................... properties are used to set the margins for an HTML element.
   d. The border-style property specifies the ......................... of the border.
   e. The ......................... property specifies all the font properties in one declaration.

2. Write T for the true statement and F for the false one:  (5)
   a. HTML provides for infinite heading levels. .........................
   b. The default value of the text-align property is left. .........................
   c. While specifying hexadecimal colour values, the values must be from 0 to GG. .........................
   d. In the text-shadow property, h-shadow specifies the position of the horizontal shadow. .........................
   e. The font-family property specifies the font size for the text in the HTML element. .........................

3. Very Short Answer Questions  (4)
   a. Which text property is used to control the capitalization of text?
   b. What is the default value of the font-style property?
   c. Name the property that is used to specify the horizontal alignment of text.
   d. Name the text property that can be used to underline text.

4. Short Answer Questions  (6)
   a. What does the text-shadow property do? How is the value for this property given?
   b. What are comments in HTML used for? Are comments displayed in the web browser?
   c. What are Inline styles used for?

5. Lab Exercise  (5)
   Jahangir has to create a write-up on Global warming and display it on a web page. He also has to set the following properties of the webpage:
   • Paragraph text should be in blue colour, fully justified. Font size should be medium and font should be Arial.
   • Heading level 1 should be used and it should be centre-aligned, green in colour, oblique, and in Arial font.
   • Text shadow should be applied to the heading.
   Can you help him do the task?
Chapter 1  Formulas in Excel 2013

1. a. Reference  b. Circular  c. Text string  d. Functions  e. Insert Function
2. a. F  b. T  c. T  d. F  e. T
3. a. By default, Excel creates **relative cell references** in a formula.
   b. The Check button present in the Formula bar performs the function of the **Enter** key.
   c. The **AutoSum** feature in Excel automatically adds numbers in the selected cells.
   d. **Pointing** is the method that adds a cell reference to a formula by clicking the cell.
4. a. Joining strings together is called **concatenation**. For example, if we type “Respect” & “ &” Elders” in a cell and press ENTER, we will see the result **Respect Elders**
   b. The possible reason for the error result “####” in a formula is that the column is not wide enough to display the value.
   c. The AutoSum button is present on the **HOME** tab and the **FORMULAS** tab.
5. i. Enter the data as given above.
   ii. Select the cell E3 and type “=B3+C3+D3” and press Enter.
   iii. Select the cell E3 and drag the AutoFill handle to the cell range E4:E10.
   iv. For the Grand Total Sale, select the cell E11 and in the **Editing** group on the **HOME** tab, click the arrow next to AutoSum and select Sum. The formula will appear in E11. Press Enter. The Grand Total of the sales will appear.

Chapter 2  Creating Charts in Excel 2013

1. a. Column  b. Data  c. Chart  d. Floor  e. Radar
2. a. F  b. T  c. T  d. F  e. F
3. a. A bar chart can be described as a column chart drawn sideways.
   b. The **DataTable** option adds a table with the data to a chart.
   c. The two additional tabs that appear on selecting a chart are—**DESIGN** and **FORMAT**.
   d. The **Location** group on the **DESIGN** tab has the **MoveChart** option to move the chart to a new worksheet.
4. a. A combination chart is a single chart that consists of a series that uses different chart types. It may include a second **value axis**. For example, you may have a chart that shows both columns and lines with two value axes. The value axis for the column chart may be on the left, while for the line chart it may be on the right.
   b. Four types of charts are: Line chart, Column chart, Pie chart, and Scatter chart.
   c. A sparkline is the miniature chart that is embedded in a single worksheet cell. It provides a visual representation of data.
5. i. Enter the data as given above.  
   ii. Select the cell range A1:B10.  
   iii. On the **INSERT** tab, in the **Charts** group, click the arrow below the Column option and select 2-D column.  
   iv. A column chart appears on the worksheet.  
   v. Select the chart. Now, click the **DESIGN** tab. In the **Chart Layouts** group, select the layout that you require.  
   vi. Now, click the legends to select it. Click the Shape Outline drop-down menu arrow in the **Shape Styles** group on the **FORMAT** tab and choose red colour from the palette. This adds a thin, red border around the legends.

---

**Chapter 3  Computer Viruses**

1. a. Boot records  
   b. Macro  
   c. Spam  
   d. Program  
   e. Trojan horse

2. a. F  
   b. F  
   c. T  
   d. T  
   e. T

3. a. The name given to applications designed to detect and remove viruses from computer systems is **antivirus software**.  
   b. Malware is the short term for malicious software.  
   c. The software program that helps to keep viruses, hackers etc. from entering a computer over the Internet is called the firewall.  
   d. Some file extensions that can be infected by program viruses are: .COM, .EXE, .DLL etc.  
   e. Two popular antivirus programs are: Quick Heal Total Security and Norton AntiVirus.

4. a. A computer virus is a software program that has the ability to make copies of itself and attach itself to other programs or files. Viruses are written by expert computer programmers and are intended to run on computer systems without the user’s knowledge.  
   b. Two common signs which indicate that a virus has attacked your computer are:  
   i. The computer runs slower than its normal speed.  
   ii. Applications take longer to load or do not work properly.  
   c. A spyware is a computer program that secretly gathers information about the user and passes it to advertisers and other parties. It is also called spybots or tracking software and can consume a lot of memory, making the computer very slow and difficult to work with.  
   d. Worms are different from viruses in that worms spread without any human action whereas viruses spread only when the user does something like running an infected program or attaching an infected file. Also, unlike viruses, worms usually do not cause direct damage to programs and files.  
   e. A Boot virus infects the boot records of hard disks and floppy disks. An example of boot virus is Danish Boot
Chapter 4  Loops and Graphics in Small Basic

1. a. GraphicsWindow  
   b. DrawRectangle  
   c. Tahoma  
   d. For…EndFor  
   e. Black

2. a. T  
   b. F  
   c. F  
   d. F  
   e. F

3. a. The default values of the Width and the Height properties of the GraphicsWindow object are 624 pixels and 444 pixels respectively.  
   b. The output of the given program would be: 30 25 20 15 10 5  
   c. The command used to set the colour used to fill a figure as blue is given below:  
      
       GraphicsWindow.BrushColor = “Blue”  
   
   d. The default value of the Title property of the GraphicsWindow object is Small Basic.

4. a. The four Font related properties of the GraphicsWindow object and their respective default values are given below:  
      FontName: Tahoma  
      FontSize: 12  
      FontBold: True  
      FontItalic: False  
   
   b. DrawLine: This method takes 4 arguments, DrawLine(x1, y1, x2, y2). It draws a line from one point (x1, y1) to another (x2, y2) using the current pen.  
      DrawText: This method takes 3 arguments, DrawText(x, y, text). It draws a line of text on the screen at the specified location (x, y) using brush and font properties.  
   
   c. The For…EndFor statement provides an easy way to create a loop. It is used to repeat a block of statements a specified number of times. This looping statement is preferred when the number of repetitions is known. For example, the following program prints the numbers 1 to 10:  
      For X = 1 To 10  
      TextWindow.Write (X)  
      EndFor

5. a. The program is as given below:  
   ‘This program has been developed by Salim of Class 7A’  
   GraphicsWindow.BackgroundColor = “Yellow”  
   GraphicsWindow.FontName = “Arial”
Chapter 5  Introduction to Visual Basic

1. a. BASIC b. Controls c. Event d. Title bar e. Property
2. a. T b. F c. T d. F e. T
3. a. The default extension of a Visual Basic form is .vb.
   b. A Visual Basic variable declaration starts with the keyword Dim.
   c. The Properties window in Visual Basic lists the properties of the selected control on the form.
   d. The control that is used to accept input from a user is the TextBox.
4. b. The arithmetic operators that can be used in Visual Basic are: Addition, Subtraction, Multiplication, Division, Exponent, Modulus, and Integer Division.
   c. A Visual Basic application can be run in the following three ways:
      a. Click DEBUG ► Start Debugging
      b. Press F5
      c. Click the Start button on the toolbar
   d. The two methods of placing controls on a Visual Basic form are: double-click the control in the Toolbox or click the control in the Toolbox, and with the left mouse button pressed down, drag and drop it onto the form.
5. i. Create a New Project.
   ii. Add three Labels, three TextBoxes and one Button, to the form.
iii. Set the following properties to controls:

<table>
<thead>
<tr>
<th>Control</th>
<th>Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Form1</td>
<td>Text: Find greater of two numbers</td>
</tr>
<tr>
<td>Label1</td>
<td>Text: Enter first number, Font: Bold, 12</td>
</tr>
<tr>
<td>Label2</td>
<td>Text: Enter second number, Font: Bold, 12</td>
</tr>
<tr>
<td>Label3</td>
<td>Text: Greater number, Font: Bold, 12</td>
</tr>
<tr>
<td>TextBox1</td>
<td>Font: Bold, 12</td>
</tr>
<tr>
<td>TextBox2</td>
<td>Font: Bold, 12</td>
</tr>
<tr>
<td>TextBox3</td>
<td>Font: Bold, 12 Enabled: False</td>
</tr>
<tr>
<td>Button1</td>
<td>Text: Display, Font: Bold, 12</td>
</tr>
</tbody>
</table>

iv. Double-click the **Display** button and add the following code (Fig. a):

```vbnet
Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
    Dim num1, num2, large As Integer
    num1 = Val(TextBox1.Text)
    num2 = Val(TextBox2.Text)
    If num1 > num2 Then
        large = num1
    Else
        large = num2
    End If
    TextBox3.Text = large
End Sub
```

Fig. a Programming code

v. Save the project and then run the program.

---

**Chapter 6  Communication on the Internet**

1. a. Chat programs  b. Skype  c. Web feed  d. Facebook  e. Instant messaging
2. a. F  b. T  c. F  d. F  e. F
3. a. The individual articles on a blog are called blog posts or entries.  
   b. The FTP works on the client-server model.  
   c. Picasa is a photo management software provided by Google.  
   d. The technology that uses the Internet and central remote servers to hold data and applications is known as Cloud Computing.  
   e. In a newsgroup, the category COMP refers to computer related topics.
4. a. A chat room is a service in which multiple users talk to each other in real time by posting messages. Websites like paltal.com provide chat room facilities.
b. The File Transfer Protocol is the simplest and the most secure way to exchange files over the Internet. When you download a file from a website, you are using the Internet to transfer the file from the other computer to your computer through FTP.

c. In case of a newsgroup, messages are not posted to somebody’s mailbox but on a bulletin board where any member can read and respond to them, unlike an email where messages are posted to somebody’s mailbox.

d. Authoring a blog, maintaining a blog, or adding an article to an existing blog is called blogging. Blogs are created through blog-publishing services offered by companies.

e. A feed reader is a program or a website that allows you to keep up with new content from Websites of your interest. Most browsers and email programs have feed readers built into them. Feed demon (standalone program) and My Yahoo! Reader (Web-based) are two feed readers.

---

Chapter 7  More Tools in Flash

1. a. Pen tool  b. Free Transform tool  c. Width adjustment
d. Instance  e. Tint

2. a. F  b. F  c. T  d. T  e. F

3. a. To modify the gradient fill of an object, the Gradient Transform tool has to be selected.

b. In Flash, the Text tool is used for inserting text to the movies.

c. The Eyedropper tool is linked to the Paint Bucket/Ink Bottle Tool.

d. The symbols in a Flash movie are stored in the Library folder.

4. a. When an object like a rectangle or a square is drawn, Flash creates two objects: the outline and the fill.

b. The steps to group the outline and the fill of an object are: Using the Arrow Tool, select the outline and the fill and then select Modify ➤ Group.

c. The Timeline effects are used for creating animations in Flash. Examples are fade in, fade out, etc.

5. i. Create a new Flash document.

ii. Use the Text Tool to write “Happy Birthday” on the stage.

iii. Use the Arrow Tool to select the text and select Modify ➤ Break Apart.

iv. Select Modify ➤ Break Apart again.

v. Click outside the converted text to deselect the shapes.

vi. Now move the pointer to the edge of one of the characters and drag it to reshape it.

vii. Use the Paint Bucket Tool to fill this reshaped character with another colour or gradient.

viii. Follow the same procedure to change the shape of other characters.
Chapter 8  Animations in Flash


2. a. T  b. F  c. T  d. F  e. F

3. a. The Onion skin feature is used to see the relative position of an object over several frames.
   b. The keyboard shortcut to insert a keyframe is F6.
   c. The white rectangular area where we add the contents of a Flash movie is called the Stage.
   d. Two sound formats supported by Flash are MP3 and WAV.

4. a. Filters are in-built visual effects in Flash. Two types of filters in Flash are Bevel and Glow.
   b. The mask layer feature is used to create special animation effects in Flash. While using this feature we should remember that the mask layer should always be above the layer we want to mask.
   c. To change the order of the layers, click the name of the layer that is to be moved, and drag it to the required position.

5. To create the given animation, follow the steps given below:
   i. Create a new Flash document.
   ii. Rename Layer 1 and give it the name “Aeroplane”.
   iii. Click frame 1. Select File -> Import -> Import to Stage and import the picture of an aeroplane.
   iv. Click frame 60 and insert a keyframe by pressing F6.
   v. To create a motion tween for the aeroplane, click any frame between frames 1 and 60 and choose Motion in the Tween menu of the Property inspector.
   vi. Click Add Motion Guide in the Timeline window. This creates a motion guide layer above the Aeroplane layer. The layer is automatically named as Guide: Aeroplane.
   vii. With the Guide: Aeroplane layer selected, click the Pencil Tool, and draw a path on the Stage.
   viii. Select the Aeroplane layer. Click any frame between Frame 1 and Frame 60.
   ix. Select the Snap checkbox in the Property inspector. Selecting Snap will snap the registration point of the object to the motion path. Also select the Orient to Path option.
   x. With the Aeroplane layer still selected, click frame 1.
   xi. Place the aeroplane on the path such that the registration point of the aeroplane is exactly above the start of the path.
   xii. Click frame 60 of the Aeroplane layer.
   xiii. Now place the aeroplane on the path such that the registration point of the aeroplane is exactly above the end of the path.
   xiv. Hide the motion guide layer.
   xv. Save the file and play the movie.
Chapter 9  Introduction to HTML 5


2. a. F b. T c. F d. T e. T

3. a. The HTML editor is used to create and save the HTML documents.
   b. The HTML elements that do not require an OFF tag are called empty elements.
   c. The background-repeat property specifies whether the background image is repeated or not.
   d. The tag <br> is used to insert a line break.

4. a. The three main sections of a website are: the home page, the main section, and the subsections.
   b. The two types of HTML editors are:
      • **WYSIWYG editor**: This kind of editor uses a graphical user interface to create a web page. The knowledge of HTML is not required for working on this editor.
      • **Text editor**: Text editors like Notepad and WordPad are used for creating web pages by writing the required HTML code.
   c. Cascading Style Sheet is a style sheet that provides a set of style rules for displaying HTML elements in a web page. They can be included in an HTML document in one of the following ways:
      • Using external style sheets
      • Using embedded style sheets
      • Using inline styles

5. i. Start notepad.
   ii. Type the following HTML code:

   ```html
   <!DOCTYPE html>
   <html>
   <head>
   <title>The TajMahal</title>
   <style type = "text/css">
   body { background-color: white}
   h1 {color: pink; text-align: centre}
   p {color: black; text-align: justify}
   </style>
   </head>
   <body> <b> THE TAJ MAHAL </b> <br> 
   <p>The Taj Mahal is a historical monument. It is situated on the bank of Yamuna River in Agra. <br>
   It was built by the Mughal Emperor Shahjahan in the memory of his wife Mumtaz Mahal. Its construction began in 1632 and was completed after almost two decades in 1653. <br>
   The Taj Mahal, one of the Seven Wonders of the World, is built of white marble.</p> 
   ```
iii. Select File ➤ Save and save the file as Taj.html.
iv. To view the document, open a web browser, say, Internet Explorer.
v. Open the file Taj.html in the web browser.

Chapter 10  Basic HTML 5 Commands


2. a. F  b. T  c. F  d. T  e. F

3. a. The text-transform property is used to control the capitalisation of text.
   b. The default value of the font-style property is normal.
   c. The text-align property is used to specify the horizontal alignment of text.
   d. The text-decoration property is used to underline text.

4. a. The text-shadow property applies a shadow to the text. The value for this property is given as:

   text-shadow: h-shadow v-shadow colour
   
   where, h-shadow specifies the position of horizontal shadow, v-shadow specifies the position of the vertical shadow and colour specifies the colour of the shadow.
   
   b. Comments in HTML are used for explaining the code. No, comments in an HTML document are not displayed by the browser.
   
   c. Inline styles are used to apply a style to specific elements on a Web page. This type of style is useful when you want to define specific styles for individual HTML elements. For creating and applying inline styles, you need to add a style attribute to the HTML tag.

5. i. Start Notepad and type the HTML code as below:

```
<!DOCTYPE html>
<html>
<head>
<title>Global Warming</title>
<style type= "text/css">
body {background-color: cyan}
p {color: blue; text-align: justify; font-family: "Arial"; font-size: medium}
h1 {text-align: centre; colour: green; font-style: oblique; font-family: “Arial”}
h1 {text-shadow: 5px 5px red}
</style>
</head>
<body>
<h1>Global Warming</h1>
```
<hr>
<p>Global warming is defined as the increase of the average temperature on earth. This increase in the Earth’s temperature is the cause of natural disasters like hurricanes, floods, and droughts which are becoming increasingly frequent all over the world. To prevent the dangers posed by global warming we have to reduce our consumption of fossil fuels drastically as the first measure.</p>
</body>
</html>

ii. Save the document as Global_warming.html.

iii. Open this file in a web browser.